none
Virtual Ethernet Adapter needs to be disabled and enabled upon startup of PC

    Question

  • I successfully created a Hyper-V Virtual Switch using Hyper-V Manager. I have successfully setup and run a Hyper-V Virtual Machine on my Windows 8 PC.

    I have one problem that I have not been able to solve. Each morning, when I power on my PC and login, the Status of IPv4 Connectivity shows "No network access". I have to Disable and Enable the "Hyper-V Virtual Ethernet Adapter" before my PC (Host Windows OS) gets network connectivity. After I do that, I have no further issues until the next morning when I power on my PC again. So far, I have not found anything the event logs or in my searching of MSDN or TechNet that would help me solve this issue.
    Thanks

    These are the items enabled (checked) for the Hyper-V Virtual Ethernet Adapter :
    Client for Microsoft Networks
    Symantec Network Security Intermediate Filter Driver
    Deterministic Network Enhancer
    QoS Packet Scheduler
    File and Print Sharing for Microsoft Networks
    Microsoft LLDP Protocol Driver
    Link-Layer Topology Discovery Mapper I/O Driver
    Link-Layer Topology Discovery Responder
    Internet Protocol Version 4 (TCP/IPv4)

    The driver is VMSWITCH.SYS File Version 6.2.9200.16384 (win8_rtm.120725-1247) Driver Date: 6/21/2006
    I have a static IP Address configured in the Internet Protocol Version 4 (TCP/IPv4) properties.

    The wired LAN card (Realtek PCIe GBE Family Controller) is a separate item in "Network Connections" with only "Hyper-V Extensible Virtual Switch" checked.


    Thursday, January 17, 2013 12:33 PM

Answers

  • Hi,

    > Each morning, when I power on my PC and login, the Status of IPv4 Connectivity shows "No network access".

    Did you mean this issue happened on Hyper-V host? Please check whether you have installed latest network card driver.

    If you mean the issue happened on guest virtual machine, you may disable NIC sleep power manager setting and check the result.

    You can disable his setting in Device Manager, expand Network Adapters, right-click the adapter, click Properties, click the Power Management tab, and then clear the Allow the computer to turn off this device to save power check box.

    From Windows 7 or Windows Server 2008 R2, you have two additional check boxes on the Power Management tab for the Network Adapter that defines whether this device can wake the computer:

    • Allow this device to wake the computer
    • Only allow a magic packet to wake the computer

    You can also use the registry to disable the Allow the computer to turn off this device to save power network adapter power management setting or to configure the wake options described above.

    To use Registry Editor to disable the Allow the computer to turn off this device to save power network adapter setting for a single computer, follow these steps:

    1. Click Start, click Run, type regedit in the Open box, and then click OK.

    2. Locate and then click the following registry subkey:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E972-E325-11CE-BFC1-08002bE10318}\DeviceNumber

    NoteDeviceNumber is the network adapter number. If a single network adapter is installed on the computer, the DeviceNumber is 0001.

    3. Click PnPCapabilities.

    4. On the Edit menu, click Modify.

    5. In the Value data box, type 24, and then click OK.

    Note By default, a value of 0 indicates that power management of the network adapter is enabled. A value of 24 will prevent Windows 7 from turning off the network adapter or let the network adapter wake the computer from standby.

    6. On the File menu, click Exit.

    For more information please refer to following MS articles:

    Information about power management setting on a network adapter
    http://support.microsoft.com/kb/2740020
    What's New in Power Management for Network Devices
    http://technet.microsoft.com/en-us/library/ee681739(v=WS.10).aspx


    Lawrence

    TechNet Community Support

    Friday, January 18, 2013 8:38 AM
    Moderator

All replies

  • http://social.technet.microsoft.com/Forums/en-US/w8itprovirt/threads is the forum for Windows 8 virtualization questions.

    I assume you mean that those settings you list above are on the Windows 8 virtual NIC and not on the virtual switch.  When a virtual switch is created, all those protocols are removed and placed onto a virtual NIC (if the switch is shared with the host).

    Is this a wired or wireless NIC?


    .:|:.:|:. tim

    Thursday, January 17, 2013 1:22 PM
  • Hi Tim,

    Hope all is well for you.

    It is Wired.

    In  "Network Connections", the term "Virtual Switch" is mentioned in both the "Hyper-V Virtual Ethernet Adapter" entry and the "Realtek PCIe GBE Family Controller" entry.

    The Device Name in the "Network Connections" display is "Hyper-V Virtual Ethernet Adapter #1" and the driver is VMSWITCH.SYS.

    The LAN card (Realtek PCIe GBE Family Controller) is a separate item in "Network Connections" with only "Hyper-V Extensible Virtual Switch" checked.

    I have to Disable and Enable the "Hyper-V Virtual Ethernet Adapter" each time I restart my PC after I have powered it off.


    Thursday, January 17, 2013 2:13 PM
  • Hi,

    > Each morning, when I power on my PC and login, the Status of IPv4 Connectivity shows "No network access".

    Did you mean this issue happened on Hyper-V host? Please check whether you have installed latest network card driver.

    If you mean the issue happened on guest virtual machine, you may disable NIC sleep power manager setting and check the result.

    You can disable his setting in Device Manager, expand Network Adapters, right-click the adapter, click Properties, click the Power Management tab, and then clear the Allow the computer to turn off this device to save power check box.

    From Windows 7 or Windows Server 2008 R2, you have two additional check boxes on the Power Management tab for the Network Adapter that defines whether this device can wake the computer:

    • Allow this device to wake the computer
    • Only allow a magic packet to wake the computer

    You can also use the registry to disable the Allow the computer to turn off this device to save power network adapter power management setting or to configure the wake options described above.

    To use Registry Editor to disable the Allow the computer to turn off this device to save power network adapter setting for a single computer, follow these steps:

    1. Click Start, click Run, type regedit in the Open box, and then click OK.

    2. Locate and then click the following registry subkey:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E972-E325-11CE-BFC1-08002bE10318}\DeviceNumber

    NoteDeviceNumber is the network adapter number. If a single network adapter is installed on the computer, the DeviceNumber is 0001.

    3. Click PnPCapabilities.

    4. On the Edit menu, click Modify.

    5. In the Value data box, type 24, and then click OK.

    Note By default, a value of 0 indicates that power management of the network adapter is enabled. A value of 24 will prevent Windows 7 from turning off the network adapter or let the network adapter wake the computer from standby.

    6. On the File menu, click Exit.

    For more information please refer to following MS articles:

    Information about power management setting on a network adapter
    http://support.microsoft.com/kb/2740020
    What's New in Power Management for Network Devices
    http://technet.microsoft.com/en-us/library/ee681739(v=WS.10).aspx


    Lawrence

    TechNet Community Support

    Friday, January 18, 2013 8:38 AM
    Moderator
  • Thank you for your response. It helped a great deal. It was the NIC driver version.

    In my note above, I did mean the Host Operating System (Windows 8 Professional) before any virtual machines are started.

    I had cleared the Allow the computer to turn off this device to save power checkbox when I first got the PC before I installed Hyper-V.

    I checked the registry entry that you suggested and found no PnPCapabilities item.

    I took your suggestion and checked the version of the NIC driver. My PC had the same version as is on the HP support web site. I checked the Realtek web site and found that there was a later version there. I downloaded it. I also downloaded the setup package from the HP support web site in case the setup package from the Realtek web site left me without network connectivity.

    Realtek PCIe GBE Family Controller
    The HP support web site (and my version): 8.2.612.2012 (6/12/2012). The Realtek web site version: 8.7.1025.2012 (10/25/2012). I installed the Realtek web site version, shutdown and powered on and, this time, I did not have to disable and enable the Hyper-V Virtual Ethernet Adapter in the host operating system to get Internet connectivity.

    Friday, January 18, 2013 2:05 PM
  • Hi,

    I have the sdame problem with my Intel 85279v adapter.

    I tried to download the latest driver from intel website, but problem remain.

    any other suggestion ?

    Fabrizio

    Saturday, June 08, 2013 11:39 AM