Table of Contents



Consider the following situation. You create a new Image Group in Windows Deployment Services and try to add a new Install Image to this group.

WDSUtil.exe /add-imagegroup /imagegroup:"6.1.7600.16385 (win7_rtm.090713-1255) — VHD" /Server:"MyWDS.Contoso.com"

Windows Deployment Services Management Utility [Version 6.1.7600.16385]
Copyright (C) Microsoft Corporation. All rights reserved.

The command completed successfully.

WDSUtil.exe /verbose /progress /add-image /imagefile:"C:\vhd\6.1.7600.16385.amd64fre.win7_rtm.090713-1255.Enterprise.en-US,ru-RU — App.vhd" /Server:"MyWDS.Contoso.com" /imagetype:"install" /imagegroup:"6.1.7600.16385 (win7_rtm.090713-1255) — VHD"

Windows Deployment Services Management Utility [Version 6.1.7600.16385]
Copyright (C) Microsoft Corporation. All rights reserved.

Enumerating images in the image file.

Verifying the integrity of the data in image file "C:\vhd\6.1.7600.16385.amd64fre.win7_rtm.090713-1255.Enterprise.en-US,ru-RU — App.vhd"...

Will add 1 install image(s) from file "C:\vhd\6.1.7600.16385.amd64fre.win7_rtm.090713-1255.Enterprise.en-US,ru-RU — App.vhd" to image group "6.1.7600.16385 (win7_rtm.090713-1255) — VHD"...

Adding install image "Enterprise_6.1.7600" to image group "6.1.7600.16385 (win7_rtm.090713-1255) — VHD"...

In this case you may receive the following error message

An error occurred while trying to execute the command.
Error Code: 0x7A
Error Description: The data area passed to a system call is too small.

Cause

This error happens if your Image Group name contains extended (aka high-bit aka non-ASCII) characters. In the above example this character is “—” (em dash).

Solution

You could replace an em dash with “--” (double hyphens). The following sequence of commands will work.

WDSUtil.exe /add-imagegroup /imagegroup:"6.1.7600.16385 (win7_rtm.090713-1255) -- VHD" /Server:"MyWDS.Contoso.com"

Windows Deployment Services Management Utility [Version 6.1.7600.16385]
Copyright (C) Microsoft Corporation. All rights reserved.

The command completed successfully.

WDSUtil.exe /verbose /progress /add-image /imagefile:"C:\vhd\6.1.7600.16385.amd64fre.win7_rtm.090713-1255.Enterprise.en-US,ru-RU — App.vhd" /imagetype:"install" /imagegroup:"6.1.7600.16385 (win7_rtm.090713-1255) -- VHD" /Server:"MyWDS.Contoso.com"

Windows Deployment Services Management Utility [Version 6.1.7600.16385]
Copyright (C) Microsoft Corporation. All rights reserved.

Enumerating images in the image file.

Verifying the integrity of the data in image file "C:\vhd\6.1.7600.16385.amd64fre.win7_rtm.090713-1255.Enterprise.en-US,ru-RU — App.vhd"...

Will add 1 install image(s) from file "C:\vhd\6.1.7600.16385.amd64fre.win7_rtm.090713-1255.Enterprise.en-US,ru-RU — App.vhd" to image group "6.1.7600.16385 (win7_rtm.090713-1255) -- VHD"...

Adding install image "Enterprise_6.1.7600" to image group "6.1.7600.16385 (win7_rtm.090713-1255) -- VHD"...

...................................................

Added install image "Enterprise_6.1.7600" using file name "6.1.7600.16385.amd64fre.win7_rtm.090713-1255.Enterprise.en-US,ru-RU — App.vhd".

Updating image metadata...

The command completed successfully.

Note that you can use extended characters in the Install Image filename and this would not cause any errors.