[Howto] Use the Webrecorder on windows 64bit. 

I don’t know if this is already posted but if so you can stop reading. If not continue:

 

A long time ago when i started to use windows 7 x64 and the ops console x64 i had the known problem of the webrecorder that wasn’t showing up in internet explorer. The trick of opening a x64 internet explorer and enable it didn’t do the fix. This  because SCOM is opening the internet explorer that is defined by a registry default key. (I looked at the source code of the Microsoft.Mom.RecorderBar.RecorderBarRemote class and noticed the method LaunchIE() is doing …..

 

 

string fileName = Registry.GetValue(@"HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\App Paths\IEXPLORE.EXE", "", null) as string;

 

 

….to get the internet explorer path.

 

So to fix this issue you must change this regkey to the x64 internet explorer.

Change key value:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\App Paths\IEXPLORE.EXE\(Default)

From:

C:\Program Files (x86)\Internet Explorer\IEXPLORE.EXE

To:

C:\Program Files\Internet Explorer\IEXPLORE.EXE

 

[1] Please notice that changing this key will also cause every internet explorer to start as x64. So change it back to the x32 value after you have done your recording.

[2] Please notice that you must open regkey under admin and also change the owner to administrators to change the permissions to full otherwise you can’t edit the value of the key!!

 

Hope this helps out some of us.

 

Michel Kamp