AD FS 2.0: Continuously Prompted for Credentials When Using FireFox 3.6.3

AD FS 2.0: Continuously Prompted for Credentials When Using FireFox 3.6.3

Symptoms

  • Users are continuously prompted for credentials when authenticating to AD FS 2.0 while using FireFox 3.6.3. Internet Explorer does not exhibit this behavior.

Cause

  • The default FireFox 3.6.3 network authentication configuration is incorrect.

Resolution

  • Option 1: Upgrade to a newer version of Firefox

 

  • Option 2:
    • a. Launch FireFox 3.6.3
    • b. Click Tools > Clear Recent History
    • c. In the location bar, type "about:config" (without the quotes) and press Enter
    • d. The about:config will warn: "This might void your warranty!". Click "I'll be careful, I promise!" to continue to the about:config page
    • e. On the about:config page, double-click "network.auth.force-generic-ntlm" and set its value to "true" ("false" is the default)
    • f. Close FireFox 3.6.3
    • g. Launch FireFox 3.6.3
    • h. Click Tools > Clear Recent History
    • i. Attempt to access the AD FS 2.0-protected resource again
Sort by: Published Date | Most Recent | Most Useful
Comments
Page 1 of 1 (5 items)