Troubleshooting FIM: Connecting to remote server failed with the following error message: Access is denied

Troubleshooting FIM: Connecting to remote server failed with the following error message: Access is denied

Environment

  • Forefront Identity Manager 2010 (FIM2010)
  • Active Directory Management Agent
  • Export Action

Applies to

  • ILM 2007 FP1 SP1
  • FIM 2010, and/or FIM 2010 R2

Problem statement

We have an Active Directory Management Agent that creates and updates user and group objects in Active Directory.  We received a stopped-dll-exception error when running the export.  Per the Stopped-DLL-Exception Troubleshooter document, we went to the Application Event Log and found an Event ID 0.  We reviewed the error and found the below error. 
   
APPLICATION EVENT LOG – Event ID 0
EVENT ID 0
==========================================================================
Log Name:      Application
Source:        FIMSynchronizationService
Date:          11/16/2012 3:25:14 PM
Event ID:      0
Task Category: None
Level:         Error
Keywords:      Classic
User:          N/A
Description:
The description for Event ID 0 from source FIMSynchronizationService cannot be found. Either the component that raises this event is not installed on your local computer or the installation is corrupted. You can install or repair the component on the local computer.
 
If the event originated on another computer, the display information had to be saved with the event.
 
The following information was included with the event:
 
There is an error in Exch2010Extension BeginExportToCd() function.Type: System.Management.Automation.Remoting.PSRemotingTransportException
 
Message: Connecting to remote server failed with the following error message : Access is denied. For more information, see the about_Remote_Troubleshooting Help topic.
 
Stack Trace:    at System.Management.Automation.Runspaces.Internal.RunspacePoolInternal.EndOpen(IAsyncResult asyncResult)
   at System.Management.Automation.Runspaces.RunspacePool.Open()
   at System.Management.Automation.RemoteRunspace.Open()
   at Exch2010Extension.Exch2010ExtensionClass.OpenConnection(String uri, PSCredential credential)
   at Exch2010Extension.Exch2010ExtensionClass.BeginExportToCd(String connectTo, String domain, String server, String user, String password)

Root cause

We reviewed the Configure Extensions properties tab in the Active Directory Management Agent.  We noticed that the URI was using HTTPS instead of HTTP.

Resolution

We removed the “s” from HTTPS and used HTTP for the URI, and the export worked successfully.

See also

Sort by: Published Date | Most Recent | Most Useful
Comments
  • Thank you for information.

  • So does this indicate that the Exchange environment was not configured (properly) to support SSL, or that FIM cannot make an SSL connection to Exchange?

    Either way, it's good to know that the use of HTTPS could result in an "access is denied" message.  Thank you.

    Chris

Page 1 of 1 (2 items)