none
3.5.3 can't install_github packages RRS feed

  • Question

  • install.packages(c("coda","mvtnorm","devtools","loo")) library(devtools) devtools::install_github("rmcelreath/rethinking")

    got error

    Downloading GitHub repo rmcelreath/rethinking@master
    Error in utils::download.file(url, path, method = download_method(), quiet = quiet,  :
      cannot open URL 'https://api.github.com/repos/rmcelreath/rethinking/tarball/master'
    Wednesday, July 31, 2019 5:41 AM

All replies

  • The installation works for me. It is probably a firewall or proxy settings issue on your machine - are you sitting behind a corporate proxy server?

    I would try the following suggestion mentioned here:
    https://stackoverflow.com/questions/17783686/solution-how-to-install-github-when-there-is-a-proxy
    to set your proxy server via the 'set_config()' function.

    Hope this helps.
    Wednesday, July 31, 2019 9:42 PM
  • Hi I am using MS R Open 3.5.3 and VS 2017 RTVS on Win 10.

    After upgrading R from 3.4.x to 3.5.x I had same problems.

    Finally I found work around :

    options(download.file.method = "wininet")

    https://support.rstudio.com/hc/en-us/articles/206827897-Secure-Package-Downloads-for-R


    Friday, August 23, 2019 10:37 AM