none
BizTalk Orchestration Performance issue - Taking long time to process each step RRS feed

  • Question

  • My BizTalkk Application flow is time consuming, each step is taking 1 second to process. 
    I receive a simple 1KB JSON, on Receive Pipeline just to convert from JSON to xml it is taking 1 second.Then it is taking 2 seconds to hit my Orchestration receive port.Another 1 second to execute a Map and then send response back to the caller.
    Not sure why its taking almost 5 seconds and sometimes it takes 10-12 seconds.

    I am using BizTalk 2016, why is that I am seeing this performance issue ? Is there any way to resolve this ? Please advise

    On tracking service instances

    

    I have tried Fiddler, it is something fishy going on in BizTalk Orchestration

    ServerConnected: 16:24:23.007
    FiddlerBeginRequest: 16:24:23.007
    ServerGotRequest: 16:24:23.007
    ServerBeginResponse: 16:24:33.508
    GotResponseHeaders: 16:24:33.508
    ServerDoneResponse: 16:24:33.508
    ClientBeginResponse: 16:24:33.508
    ClientDoneResponse: 16:24:33.508

    Overall Elapsed: 0:00:10.505


    RH


    • Edited by Dan2890 Wednesday, October 16, 2019 8:38 PM a
    Wednesday, October 16, 2019 8:26 PM

All replies

  • Hi,

    You can expect some latency unless you've re-configured the Latency on the hosts doing the Receive, Processing and Send. What's your Polling intervals on the hosts?

    Br,

    Leo


    Did my post help? Please use "Mark as answer" or "Propose as answer". Thank you!

    Thursday, October 17, 2019 10:50 AM
  • Polling Interval are default 500ms

    Messaging : 500ms

    Orchestration : 500ms

    The minimum Polling interval is 50ms.


    RH

    Thursday, October 17, 2019 5:30 PM
  • Experts any advise ?

    I have tried using Separate Isolated Host instance, disabled Global tracking on the server , have IIS App pool set to Always Running (in Advanced Settings) but when a portal(POSTMAN) is sending message to BizTalk REST service, it is taking like 10 seconds to send Acknowledgement.

    On using Fiddler, it just shows the time the server received request and time response was sent.

    There is almost 10-12 secs gap. Not sure why there is so much delay.

    How to minimize this delay, as I know BizTalk can process over 100s of messages in a second. What is causing this performance issue ?

    This is not on in Dev, but also other QA servers too which has high availability resources still performance issue

    Please advise if anyone has suggestion to avoid this delays

      


    RH

    Wednesday, October 23, 2019 11:46 PM