Report Viewer 2012 Beta - Installation Fails Missing System CLR Types RC0? RRS feed

  • Question

  • I am trying to install the Report Viewer 2012 Beta (http://www.microsoft.com/download/en/details.aspx?id=29024) and it right away fails saying that I am missing the installation prerequisite of Microsoft System CLR Types for SQL Server 2012 RC0.  I have looked everywhere for this file and tried installing a number of the SQL Server Feature packs I could find but I still get this error.  I did not have this issue with the Report Viewer 2012 CTP released in September of 2011, just this beta one released in February 2012.  Please advise.
    Monday, March 19, 2012 9:14 PM

All replies

  • I had similar problem and the solution that works for me is:

    1. Download the "Microsoft® System CLR Types for Microsoft® SQL Server® 2012" from here http://www.microsoft.com/download/en/details.aspx?id=29065

    2. Right click on the SQLSysClrTypes.msi and select UNINSTALL and press OK to all warnings (e.g. that the component is used by other applications)

    3. Start the your installation again.

    Tuesday, March 20, 2012 3:46 PM
  • Thank you for the response, I did as you suggested and still produces the same error.  I think there is something wrong with the dependencies check in the Report Viewer 2012 Beta installer.  You can see the error I get when I run the reportviewer.exe here: 


    Also, I tried this on another fresh machine to make sure that it wasn't something isolated to my machine, it happens the same there.
    • Edited by BeckerBen2 Tuesday, March 20, 2012 4:19 PM
    Tuesday, March 20, 2012 4:19 PM