locked
QIK CLI Duplicates RRS feed

  • Question

  • I am trying to learn to use QIK CLI and am having troubles getting it to work properly.  My version of QIKCLI.exe is 3.1.0.1, which came with OIS version 6.3.

    I use the QIK CLI wizard to create a package, which is a very simple PowerShell command.  The wizard completes successvully and then I select to Build Integration Pack.  That wizard completes successfully as well.  I go into deployment manager and select Register IP with the Management Server, and the wizard fails with "Registration of the Integration Pack <Name> with the Management Server failed."  The log adds "IDispatch error # 3092".

    Refreshing the Deployment Manager's Integration Packs shows the pack I just tried to install, along with every other failed attempt I have made prior.  This list keeps growing with each failed attempt.  If I remove one or all of them in the Deployment Manager, after refreshing they all disappear, but the next time I run the QIK CLI wizard, all of them plus the new one appear in the list again.  The whole problem may have been precipitated by failures early on in my learning, possibly by trying to use a category name with an apostrophe in it.

    This looks like a bug; is there some way I can clean this thing up so that I don't have eight superfluous entries in the Deployment Manager associated with this IP?


    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."
    Sunday, January 23, 2011 11:18 PM

Answers

All replies

  • I have tried my best to repro. I cannot. I even used apostrophe's in the category name and the product name. So far no errors. Any more info you can give?
    Friday, January 28, 2011 11:47 PM
  • Have you tried naming it something like "Ed's Command" with the apostrophe?

    I can tell you that my test lab Client is still doing this.  Is there something I can send you?  Or I'd even be willing to do a desktop share so you can see it yourself.  It's the weirdest thing.

    I tried looking in the SQL database to see what's going on, but the table structure was a bit too much for me.

    Thanks!


    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."
    Saturday, January 29, 2011 6:45 AM
  • Seems weird. Can you open a case and ask for assistance from our support team?
    Tuesday, February 8, 2011 12:02 AM
  • Unfortunately not since my work with that customer has ended.  I will forward this link to the customer should they choose to open a ticket.

    Thanks for your help.

     


    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."
    Tuesday, February 8, 2011 12:32 AM