none
Enabled BranchCache; now can't disable it RRS feed

  • Question

  • I enabled BranchCache for my SCCM clients (ver 5.00.8853.1006) and this went well, apart from a handful of users who now found themselves unable to start a local web service using port 80. No problem (I thought), I'll just push out a different set of Client Settings and set Enable BranchCache to No.

    This worked - in the sense that those targeted clients now show that the BranchCache Service mode is Disabled but the current status remains Running.

    This means these clients are all still listening on port 80, courtesy of BranchCache. Why???

    I have checked RSOP on these clients and BranchCache hasn't been configured, so I'm at a loss as to how to disable it without having to use a GPO - which I don't want to do unless I really have to. I just want to know why the SCCM Client settings are not having the full effect.

    Edit: here are the last entries from the client's CAS log if that means anything to anyone:

    Un-configuring cache size.
    Disabling BranchCache.
    Allowed:0, SSL:1, Httpport:8003, Broadcastport:8004
    Client configuration __InstanceModificationEvent notification received
    DisablePeerDistribution: Successfully disabled PeerDistribution
    Setting BranchCache size to 10 of disk
    SetCacheSize: Successfully set cache size
    The client is not allowed to be a superpeer. Will stop superpeer controller
    Superpeercontroller agent stopping
    Broadcast listener shutdown signal recieved.
    Exiting broadcast listener thread
    Waiting for the broadcast listner thread to exit.
    Waiting for the http listener thread to exit.
    SuperPeerController has stopped
    WinPEBranchCacheStartup task is starting...
    CSuperPeerController::FinalConstruct entered
    ===========================================================
    Un-configuring cache size.
    Disabling BranchCache.
    DisablePeerDistribution: Successfully disabled PeerDistribution
    Setting BranchCache size to 10 of disk
    SetCacheSize: Successfully set cache size
    Not starting superpeer agent since the client agent setting for superpeer is disabled
    ===== CacheManager: Initializing cache state from Wmi. =====
    Cache size is 5120 MB.  Location is C:\Windows\ccmcache
    CacheManager: MaxCacheDuration:43200 - MinTombstoneDuration:1440
    CacheManager: There are currently 31294464 bytes used for cached content items (2 total, 2 active, 0 tombstoned, 0 expired).
    ===== CacheManager: Cache state initialization completed =====
    


    • Edited by AndyChips Tuesday, September 17, 2019 10:59 AM
    Tuesday, September 17, 2019 10:51 AM

Answers

  • Update: Fixed

    OK, perhaps I'm misunderstanding how these settings work and I probably need to really read up about this properly. I simply changed Configure BranchCache to No and this fully disabled BranchCache on the clients.

    This seems counterintuitive to me. I do want to configure BranchCache, but I want to configure it as Off. This is why my previous settings seemed logical to me.

    You live and learn.

    • Marked as answer by AndyChips Tuesday, September 17, 2019 1:49 PM
    Tuesday, September 17, 2019 1:49 PM

All replies

  • Update: Fixed

    OK, perhaps I'm misunderstanding how these settings work and I probably need to really read up about this properly. I simply changed Configure BranchCache to No and this fully disabled BranchCache on the clients.

    This seems counterintuitive to me. I do want to configure BranchCache, but I want to configure it as Off. This is why my previous settings seemed logical to me.

    You live and learn.

    • Marked as answer by AndyChips Tuesday, September 17, 2019 1:49 PM
    Tuesday, September 17, 2019 1:49 PM
  • Hi,

    Thank you for posting and sharing here, it could be helpful to someone who has the similar issue.
    Your previous settings seem to be more logical, but it did not disable BranchCache fully on clients.

    Regards,
    Allen

    Please remember to mark the replies as answers if they help.

    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Wednesday, September 18, 2019 2:11 AM