Change Drive Letter and Paths... greyed out. Can't assign drive letter. RRS feed

  • Question


    I have a drive that has a lot of information on it that I need. A user left our company and all of his files are on this drive. I was handed it and asked to build a VM with all his information on it. When I plug the drive in it loads the drivers and shows up just fine in Computer Management (shown below), but not in Computer. So I think, ok, I'll just add a drive letter but that option is greyed out and won't let me. The disk is initialized and appears to be healthy. I have gone to device manager and made sure there were no problems there as well. It was also an external drive so I removed it and made it an internal drive on my machine but got the same results. It shows up in BIOS but obviously can't boot off of it since it is not an OS drive.

    Deleting/formatting the drive is not an option. Is there a way to get this drive accessible without that? Deleting it is the exact opposite of what I want done here. 


    Wednesday, June 18, 2014 5:03 PM


  • That looks like a mac formatted drive, that's why it wont work on your PC. Try installing Paragon HFS+ for Windows.
    • Marked as answer by MSIONLINE Wednesday, February 18, 2015 12:48 PM
    Wednesday, February 18, 2015 9:18 AM

All replies

  • Hi,

    Please try this:

    1. Open a command prompt.

    2. Type in diskpart.

    3. Type list disk to see a list of disks.

    4. Type select disk #  (where # is the disk you want).

    5. Type list volume to see partitions.

    6. Type select volume #  (where # is the volume you want).

    7. Type assign letter=x  (where x is the drive letter).

    Karen Hu
    TechNet Community Support

    Friday, June 20, 2014 6:17 AM
  • Thank you for the response. Below is how far I get with what you wrote. It does not give me a volume number which means I can't assign it a letter :(

    Any other tips? I feel like this was close!

    Friday, June 20, 2014 12:11 PM
  • Here is a 'straw-clutcher' that is worth spending a few minutes checking:

    Go to Control Panel > All Control Panel Items > Folder Options > View Tab, scroll down and confirm that there is a tick in ‘Show drive letters’. Also, the field ’Hide empty drives in the Computer folder‘ should be ticked for removable storage.

    Now go to Disk Management and try to select a drive letter.

    Ninety-nine per cent of politicians give the rest a bad name.

    Friday, June 20, 2014 1:25 PM
  • Thanks but both are ticked with no luck :(
    Friday, June 20, 2014 3:01 PM
  • Hi,

    According to your screenshot. It seems that this disk is UEFI protected.

    The UEFI specification defines a new model for the interface between personal-computer operating systems and platform firmware, updating BIOS interfaces such as MBR. UEFI supports the GUID Partition Table (GPT), a more flexible partitioning scheme.

    Please insert that disk into a computer which supports UEFI. And then follow these steps to change a GUID partition table disk into a master boot record disk:

    1.Back up or move all volumes on the basic GUID partition table (GPT) disk you want to convert into a master boot record (MBR) disk.

    2.If the disk contains any partitions or volumes, right-click any volumes on the disk and then click Delete Volume.

    3.Right-click the GPT disk that you want to change into an MBR disk, and then click Convert to MBR disk.

    After that, insert it to your computer to check the result.

    Karen Hu
    TechNet Community Support

    • Marked as answer by Michael_LS Wednesday, July 2, 2014 2:37 AM
    • Unmarked as answer by MSIONLINE Wednesday, July 2, 2014 6:34 PM
    Wednesday, June 25, 2014 9:15 AM
  • This solution sounds like you want me to delete all the data on the drive. I cannot back up anything (besides cloning it) because I cannot access the disk. Is there a way to  back up the data somewhere else without being able to access it?

    The disk is confirmed GPT if that helps, so it sounds like it does need to be switched to MBR but the solution above looks like I would lose all that data. 

    Let me know if I am misunderstanding!

    Wednesday, July 2, 2014 6:34 PM
  • Hi,

    You could  insert that disk into a computer which supports UEFI to access the drive and backup the data.

    Karen Hu
    TechNet Community Support

    Monday, July 7, 2014 9:49 AM
  • That looks like a mac formatted drive, that's why it wont work on your PC. Try installing Paragon HFS+ for Windows.
    • Marked as answer by MSIONLINE Wednesday, February 18, 2015 12:48 PM
    Wednesday, February 18, 2015 9:18 AM
  • It was a Mac formatted drive, forgot to update this thread awhile ago. 
    Wednesday, February 18, 2015 12:49 PM
  • Same situation with an external drive which was plugged to Sony TV. I tried to assign drive letter with Diskpart also, but still no visuability and no Access to it. Only selection I have is to delete partition.
    Thursday, May 28, 2015 5:54 PM
  • I was having a similar problem, tried all the fixes here, none of which worked (and my computer is even UEFI compatible.) The workaround I ended up doing, was loading up a Linux VM (Linux is always smart about reading any file system, regardless,) attached the USB drive to it, which it then auto-mounted, copied it to the VM drive, then, in my case, since I didn't have guest additions loaded, I used a python -m SimpleHTTPServer to transfer the files to the host computer, but you can use guest addition drag and drop as well, or something like winscp/scp or whatever through an ssh tunnel.

    Alternately, you could fire up a bootable linux distro, mount the USB drive and your main HD partition, then copy it straight over that way (assuming your main HD isn't encrypted, of course.)

    Good luck =)

    Wednesday, July 8, 2015 3:21 PM
  • Hey! I am facing the same problems! Did you find a solution!
    Sunday, July 26, 2015 12:19 PM
  • Hi I have got exactly the same problem as described above. The disk was not formatted on a Mac but came out of a NAS drive. The drive speed up as having 4 healthy primary partitions and one 24MB unallocated partition. The partitions were I think created using the NAS software. The drive is a SATA drive and I have put it in a case mount which is connected to the computer using USB. As above I only have the option to Delete Volume which I don't want to do as I want to recover the data which is stored on the disk. Hope you can help Rodger.
    Sunday, August 30, 2015 3:30 PM
  • Hi all,

    Has anyone found a simple answer to this? I cannot remember but mine might be formatted on a Mac however I do not have any access to it now.

    I am not anywhere great with all those drivers and software related words I've read above, so any simple steps I can follow to help me gain my harddisk back please?

    Thank you in advance,


    Friday, October 30, 2015 12:42 AM
  • Thank you.

    I have a read only Centon 64GB USB. using your method, I have assigned the drive letter but now I need to to remove the write protection. Any solutions?


    Wednesday, November 18, 2015 4:02 PM
  • Installing Paragon HFS+ worked like a CHAMP! In fact I didn't have to do anything. When I rebooted after the installation the drive appeared like magic. This post just saved me the cost of replacing this ITB drive, thanks a million!
    Saturday, January 2, 2016 6:03 AM
  • I've spent most of this afternoon panicking that I'd lost all my data off of my external hard drive, trying every sort of recovery software, and then I stumbled across your post and within a minute my problem was solved. You my friend are a hero and a lifesaver and a god among mortals. 
    Wednesday, February 10, 2016 8:15 PM
  • I'm having this issue except this drive has never been used on a mac, and it has been used with this computer many times before. Idk what to do.
    Monday, February 29, 2016 5:07 AM
  • Hey, this might be late, but you can follow the simple and easy steps proffered in this link http://www.howtogeek.com/195530/how-to-convert-a-mac-formatted-drive-to-a-windows-drive/

    I used it and it worked

    • Proposed as answer by Zenof Tuesday, January 15, 2019 9:22 AM
    Thursday, May 12, 2016 5:24 PM
  • I wouldn't have imagined that a faulty cable connecting my USB Flash Drive to the laptop could cause the Flash Drive to start up, show on PC greyed out like yours and show in diskpart command prompt and even be able to update its driver. But it did all this with a faulty cable, but when I changed the cable to another, the flash drive just started working like it should. This time I'm going to get around safe-copying my most important files... soon

    • Edited by MrFinland Wednesday, May 18, 2016 6:55 PM
    Wednesday, May 18, 2016 6:53 PM
  • Did not work.  Everything still greyed out.  Not recognized as a Mac OSX volume.


    Wednesday, July 6, 2016 4:45 PM
  • That worked!  Chaa-ching!!  Now I've got to figure out how to force the read-write attribute read-only - off

    I do it at the DOS level, and I get an ack that it was changed, but when I try to format, it gags: sorry dude - READ ONLY


    Wednesday, July 6, 2016 4:58 PM
  • I've used HFSexplorer - Paragon HFS+ doesn't work with GPT partions

    With HFSexplorer you need to make sure the drive appears in Disk Management - from HFSexplorer go Ctrl-L

    then select disk number and partion number (that would be 1 - 2 in the above case) 

    then extract - if the disk shows up in Disk management, HFSexplorer can extract the files - also from GPT disks

    Thursday, August 11, 2016 3:49 PM
  • I have the same problem as the above user.

    I followed your steps with the following:

    >> select disk 7

    >> list volume

    When I type this I see Volumes 0 through 9 with Volume 0, 1, 3, 4, 5, 6, and 8 assigned a letter already.

    Volumes 0 and 1 are DVD-ROM.

    Volume 2 is a 100 MB partition (Label: System)

    Volume 3 is my C drive

    Volume 4 is my I drive

    Volume 5, 6 and 8 are removable E, F and H drives (0 MB, no media)

    Volume 7 is removable as well but does not have an assigned name

    Volume 9 is a 200 MB partition

    Which volume should I select? It looks as though I should select Volume 7 (unassigned and removable). So I tried it:

    >> select volume 7

    >> assign letter=G

    Now in my Computer folder "Removable Disk (G:)" shows up. But when I click on it it says "Please Insert Disk".

    Any further suggestions?


    Tuesday, August 23, 2016 5:15 PM
  • Solution when "change drive letter and paths" greyed out of a partition ?
    This problem occurs because of partition type ID changed and not as per Operating system installed.

    Below video will solve your problem.


    I hope it works for you. :-)

    • Proposed as answer by sindhvaddhruv Wednesday, September 28, 2016 8:27 PM
    Wednesday, September 28, 2016 8:27 PM
  • i think the program minitool partition (free download) works great.

    i have the same problem and this is what i did:

    select the drive and then click migrate os to ssd/hd wizard

    click apply changes

    then there should be an option to create partition, click that, choose a drive and yeah, the drive is working!

    PS: pls do a backup as the partition thing seem confusing and hopefully no one format the wrong one.
    • Edited by koganei14 Wednesday, November 23, 2016 2:03 AM
    Wednesday, November 23, 2016 2:02 AM
  • Hi,

    Please try this:

    1. Open a command prompt.

    2. Type in diskpart.

    3. Type list disk to see a list of disks.

    4. Type select disk #  (where # is the disk you want).

    5. Type list volume to see partitions.

    6. Type select volume #  (where # is the volume you want).

    7. Type assign letter=x  (where x is the drive letter).

    Karen Hu
    TechNet Community Support

    did not work for me. list volume shows disk 1 volumes even if i select disk 2 before.

    Monday, January 9, 2017 2:51 AM
  • Found a free alternative to read and copy the files with DiskInternals Linux Reader. It worked fine on Windows 7. More info at https://www.diskinternals.com/linux-reader/.

    • Proposed as answer by idearius Monday, February 27, 2017 3:48 PM
    Monday, February 27, 2017 3:47 PM
  • This one worked for me, the other above methods of DISKPART and HFS did not.  The drive has a partition created in Linux and I needed to open it in Windows.
    Monday, March 27, 2017 6:38 PM
  • Worked for me too after I tried all the other suggestions.
    Thursday, July 20, 2017 6:07 PM

    Thank you!!

    You can install a free 10 days trial, it solved my issue <g class="gr_ gr_85 gr-alert gr_spell gr_inline_cards gr_run_anim ContextualSpelling ins-del multiReplace" data-gr-id="85" id="85">instantaly</g>

    Monday, October 16, 2017 12:37 PM
  • That looks like a mac formatted drive, that's why it wont work on your PC. Try installing Paragon HFS+ for Windows.
    this is the best solution, don't waste your time reading and trying <g class="gr_ gr_52 gr-alert gr_spell gr_inline_cards gr_run_anim ContextualSpelling ins-del multiReplace" data-gr-id="52" id="52">usless</g> solutions 
    Monday, October 16, 2017 12:38 PM
  • Great this worked for me thank you so much, I thought I had lost my hard drive. I have a WD Element 500GB external hard drive, it stopped working after I tried to make a new volume on it. Now after using mini tool I was able to add a new letter to the drive, and now I have formatted and back up again thank you so much.
    Tuesday, November 14, 2017 5:29 PM
  • This is a Mac formatted volume, but the Mac won't show it either.   I tried the Paragon product.  It didn't help either.

    Monday, December 11, 2017 4:06 PM
  • Thank you so much for posting this.

    Solved it straight  away - tried other methods but this is the answer.

    Also got me connected to a cool website...thanks again

    Recommended others to follow link...


    Thursday, December 28, 2017 11:57 PM
  • Just wanted to thank this thread for covering this topic. After installing Paragon HFS+, restarted windows, turned on the app to verify my disk. Shortly after, at disk management, it allowed me the option to change drive name. 
    Saturday, April 7, 2018 10:07 PM
  • Thank you, this helped one of my users today when i was having this exact problem and disk management options were greyed out. 3 years later hah
    Tuesday, September 18, 2018 5:35 PM
  • This link worked and fixed the problem.  Thanks!
    Wednesday, September 19, 2018 5:46 PM
  • Try this only if its a new drive with no data you wish to keep. it worked for me no problems...Just click Delete Volume, windows will do the rest and you can then assign a new Drive letter.
    Wednesday, January 2, 2019 2:21 PM
  • In diskmgmt.msc  one cannot edit other HDs when they are in use,open device mgr,locate the HD,R.click,set to Uninstall/exit device mgr,return to diskmgmt,re-edit the options.This being a new letter change can work if the letter isn't set to other HD...Plus,to change/edit storage,R.click on cmd,run as Administrator,in cmd type: DiskPart in DiskPart/list disk/type: list volume/type: HELP for all cmds .Plus Windows PowerShell has ability to edit drives.


    look in scriptcenter for more

    Thursday, January 3, 2019 12:55 AM
  • I used minitool partition wizard (free edition) to recover the files directly after failing with diskpart and HFS+ for windows.

    In the software, I simply clicked on the healthy partition (with no volume and no drive letter) that I want the data to be recovered from and clicked on "Data Recovery" - it recovered everything I needed.

    I was then free to reformat the HDD as I wished with the data safely extracted.

    • Proposed as answer by Gurns Sunday, January 27, 2019 9:27 AM
    Saturday, January 26, 2019 1:59 PM
  • Thank you so much for your post this worked like a champ deleted the volume and like you said windows picked it up and everything is good now again thank you
    Wednesday, May 15, 2019 9:43 PM
  • After days of searching and trying to fix my drive this did it! Solution found!!!!!!!!!!!! Simply installed and restarted and then I was able to assign a drive letter in disk management, then it mounted!
    Tuesday, March 24, 2020 7:47 PM
  • Just spent some time on trying to play with diskpart, minitool partition wizard, tried to find some errors in the windows logs with no luck.
    then tried sfc /scannow

    And boom, magic. It found some errors, fixed. And now it works fine!

    • Edited by IvanDav Wednesday, April 22, 2020 8:48 AM
    Wednesday, April 22, 2020 8:47 AM