locked
while doing sequence -Error 1719.The Windows Installer Service could not be accessed RRS feed

  • Question

  •  

    Hi All,

    I am trying to sequence applications using App-V 4.5 RTM. But I am facing  windows installer. Need help in this regard.

    I am getting the below error.

    Error 1719.The Windows Installer Service could not be accessed. This can occur if you are running Windows in safe mode, or if the Windows Installer is not correctly installed. Contact your support personnel for assistance.

    As soon as I click begin monitoring, I am getting the above error.

    Please suggest if there is work around.

    Thanks,

    Hasnath.

    Thursday, November 27, 2008 11:36 AM

Answers

  •  

    I just had the same issue, i logged off, then ran MSTSC with the /console switch and I no longer got the error.

     

    • Proposed as answer by znack Sunday, January 8, 2012 4:33 PM
    • Marked as answer by Aaron.ParkerModerator Sunday, January 8, 2012 10:20 PM
    Tuesday, December 9, 2008 4:32 PM
  •  

    i ran into same problem. turns out it would not work my remote desktop to server. it is a virtual server. if i went in via the console it then worked fine.
    Tuesday, December 2, 2008 9:29 PM

All replies

  • Hi,

     

    Did you install the Sequencer itself with the .MSI of with the .EXE?

    Microsoft delivers both. If you used the .MSI try using the .EXE to install the Sequencer itself.

     

    Make sure in the sequencer configuration under Tools -> Options, on the General Tab, the option "Allow use of MSI Installer" is checked.

     

    Regards,

    Rodney

    Thursday, November 27, 2008 7:48 PM
    Answerer
  •  

    Hi

     

    Thanks for the quick reply.

    I installed the sequencer using EXE only and even checked the option which u mentioned.

    But no luck......Sad

    Any other suggestions please.

     

    Hasnath

     

    Friday, November 28, 2008 3:47 AM
  • HI,

     

    I have done all the possiblities.Registring , unregestring of MSIserver, Installed newer version of windows installer

    Installed App-V 4.5 RTM sequncer on some other VM, but no luck.

    I tried installing of the package on the machine, just to check if the package is running fine.It is installing fine.

    Then it must not be a windows installer problem.

    It must be some link between the sequencer and windows installer which is missing.

    On to the same machine, i have uninstalled RTM and installed RC1 to check.Its working fine.

    Is there some configurations to be done before seqeuncing...if we are using App-V 4.5 RTM Sequencer?

    Is there any one facing the same problem?

    Please suggest how to reslove this issue.

    I am sending out few lines from sft-seq-log.txt which i felt will be useful to trace issue.

     

    -------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
    [11/30/2008 13:41:59] =============== Sequencer launched.  Sequencer version:  4.5.0.1485 ===============
    [11/30/2008 13:41:59] 
    [11/30/2008 13:41:59] Sequencer started.
    [11/30/2008 13:41:59 VRB     ] CSGApplicationManager::Initialize Driver connected
    [11/30/2008 13:41:59 VRB CORE] Success to EnablePrivilege(s)
    [11/30/2008 13:41:59 VRB CORE] Success to EnablePrivilege(s)
    [11/30/2008 13:41:59 VRB CORE] InstallUnhandledExceptionFilter: Existing Exception Filter 0x77BB8D4B
    [11/30/2008 13:41:59 VRB PRGF] The default OSD node could not be found in the project file (no file specified).  One will be created.
    [11/30/2008 13:41:59 VRB PRGF] A deleted objects node could not be found in the sequencer project file (no file specified).  One will be created.
    [11/30/2008 13:41:59 VRB RTSK] Checking for Windows Vista...
    [11/30/2008 13:42:01 VRB RTSK] Checking for Windows Vista...
    [11/30/2008 13:42:01 VRB PRGF] The default OSD node could not be found in the project file (no file specified).  One will be created.
    [11/30/2008 13:42:01 VRB PRGF] A deleted objects node could not be found in the sequencer project file (no file specified).  One will be created.
    [11/30/2008 13:42:01 VRB PRGF] The default OSD node could not be found in the project file (no file specified).  One will be created.
    [11/30/2008 13:42:01 VRB PRGF] A deleted objects node could not be found in the sequencer project file (no file specified).  One will be created.
    [11/30/2008 13:42:01 VRB RTSK] Checking for Windows Vista...
    [11/30/2008 13:42:08 VRB RTSK] Checking for Windows Vista...
    [11/30/2008 13:42:09 VRB PRGF] The default OSD node could not be found in the project file (no file specified).  One will be created.
    [11/30/2008 13:42:09 VRB PRGF] A deleted objects node could not be found in the sequencer project file (no file specified).  One will be created.
    [11/30/2008 13:42:09 VRB PRGF] The default OSD node could not be found in the project file (no file specified).  One will be created.
    [11/30/2008 13:42:09 VRB PRGF] A deleted objects node could not be found in the sequencer project file (no file specified).  One will be created.
    [11/30/2008 13:42:09 VRB RTSK] Checking for Windows Vista...
    [11/30/2008 13:42:09 VRB     ] CSGApplicationManager::create_suite= 0xA4A340
    [11/30/2008 13:42:23 VRB     ] CSGApplicationManager::create_suite= 0xA56DD0
    [11/30/2008 13:42:23 VRB     ] Shared Registry GUID = {00000000-0000-0000-0000-000000000000} Decrementation
    [11/30/2008 13:42:23 VRB RTSK] >>>>>>>>>>>>>>>  Starting prescan...
    [11/30/2008 13:42:23 VRB RTSK] setting initial environment.
    [11/30/2008 13:42:23 VRB RTSK] setting up VFS.
    [11/30/2008 13:42:23 VRB RTSK] <<<<<<<<<<<<<<<  Prescan complete.
    [11/30/2008 13:42:23 VRB RTSK] >>>>>>>>>>>>>>>  Starting upload...
    [11/30/2008 13:42:23 VRB RTSK] ...uploading VRG.
    [11/30/2008 13:42:23 VRB     ] CVirtualRegistry::UploadVirtualRegistry():  isPrimaryNamespace is false
    [11/30/2008 13:42:23 VRB     ] CVirtualRegistry::UploadVirtualRegistry():  Uploading Sec 1
    [11/30/2008 13:42:23 VRB RTSK] ...uploading VFS.
    [11/30/2008 13:42:23 VRB RTSK] ...uploading short path table.
    [11/30/2008 13:42:23 VRB RTSK] ...uploading Virtual Objects.
    [11/30/2008 13:42:23 VRB RTSK] ...setting VE.
    [11/30/2008 13:42:23 VRB RTSK] Turned off VE.
    [11/30/2008 13:42:23 VRB RTSK] ...installing virtual fonts.
    [11/30/2008 13:42:23 VRB RTSK] <<<<<<<<<<<<<<<  Upload complete.
    [11/30/2008 13:42:23 VRB RTSK] Windows Vista is not present.
    [11/30/2008 13:42:23 VRB RTSK] Obtaining shell from registry.
    [11/30/2008 13:42:23 VRB RTSK] Attempting to monitor process d.
    [11/30/2008 13:42:23 VRB RTSK] Attempt to monitor process 920 was sucessful (0).
    [11/30/2008 13:42:23 VRB RTSK] Attempting to monitor process d.
    [11/30/2008 13:42:23 VRB RTSK] Attempt to monitor process 3088 was sucessful (0).
    [11/30/2008 13:42:23 VRB RTSK] No Evironment registry changes found.  Passing settings change on to base window class.
    [11/30/2008 13:42:27 VRB RTSK] Started new non-service process (3520) (msiexec.exe) in App: -502049224.
    [11/30/2008 13:42:27 VRB VFSX] SxS: Starting SxS DRP public-to-private assembly conversion for:  c:\windows\system32\uxtheme.dll
    [11/30/2008 13:42:27 VRB VFSX] SxS: Starting SxS DRP public-to-private assembly conversion for:  c:\windows\system32\shlwapi.dll
    [11/30/2008 13:42:27 VRB RTSK] Started new service process (3548) (msiexec.exe) in App: -502049224.
    [11/30/2008 13:42:27 VRB VFSX] SxS: Starting SxS DRP public-to-private assembly conversion for:  c:\windows\microsoft.net\framework\v2.0.50727\fusion.dll
    [11/30/2008 13:42:28 VRB VFSX] SxS: Starting SxS DRP public-to-private assembly conversion for:  c:\windows\system32\shell32.dll
    [11/30/2008 13:42:28 VRB VFSX] SxS: Starting SxS DRP public-to-private assembly conversion for:  c:\windows\system32\msiexec.exe
    [11/30/2008 13:42:38 VRB RTSK] Terminated new non-service process (3520) in App: -502049224.
    [11/30/2008 13:42:38 VRB RTSK] Setting services only event.
    [11/30/2008 13:42:57 VRB RTSK] Checking for Windows Vista...
    [11/30/2008 13:42:58 VRB     ] Shared Registry GUID = {00000000-0000-0000-0000-000000000000} Decrementation
    [11/30/2008 13:42:58 VRB PRGF] The default OSD node could not be found in the project file (no file specified).  One will be created.
    [11/30/2008 13:42:58 VRB PRGF] A deleted objects node could not be found in the sequencer project file (no file specified).  One will be created.
    [11/30/2008 13:42:58 VRB CORE] Sequencer terminating normally...
    [11/30/2008 13:42:58] Sequencer releasing log resources...

    -------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

     

    Thanks in Advance.

     

    Regards,

    Hasnath

    Sunday, November 30, 2008 8:32 AM
  •  

    i ran into same problem. turns out it would not work my remote desktop to server. it is a virtual server. if i went in via the console it then worked fine.
    Tuesday, December 2, 2008 9:29 PM
  •  

    I just had the same issue, i logged off, then ran MSTSC with the /console switch and I no longer got the error.

     

    • Proposed as answer by znack Sunday, January 8, 2012 4:33 PM
    • Marked as answer by Aaron.ParkerModerator Sunday, January 8, 2012 10:20 PM
    Tuesday, December 9, 2008 4:32 PM
  • With App V 4.5 or App V 4/6 Sequencer use the RDP connection with /admin option or /console option and that fixes the problem provided the Sequencer is a Clean Sequencer

    1. Revert you VM Workstation / Sequencer to a Clean State

    2. Connect via RDP using

    mstsc /admin /v:SequencerVM

    mstsc /console /v:SequencerVM

    here SequencerVM is the Sequencing Workstation

    Wednesday, November 14, 2012 11:37 AM