locked
omiserver-recv.trc filling up the filesystem RRS feed

  • Question

  • SCOM 2019ur1 with latest unix MP and agent.

    On agents we see a fast growing /var/opt/omi/log/tracefile omiserver-recv.trc which grows with 5mb per hour.

    I cannot find that file in the documentation, it seems to log winrm stuff wich is of no use for us.

    How can we disable the logging to this file?
    I already run the stoptracing.cmd command on the gateway, we set logging level to error:
    scxadmin -log-set all errors

    But none had effect.


    Ronald

    Thursday, June 25, 2020 8:27 AM

Answers

  • This was raised as a Pull Request in the agent's github repo (https://github.com/microsoft/omi/pull/644) and some code was merged to add these files to logrotate.

    So you can add the same entry to logrotate conf file (omilogrotate.conf ) yourself, or wait for next release of the agent which will probably include it.

    /var/opt/omi/log/*.log /var/opt/omi/log/*.trc {
        # keep 5 worth of backlogs
        rotate 5
        copytruncate
    }

    Thursday, June 25, 2020 8:37 AM

All replies

  • This was raised as a Pull Request in the agent's github repo (https://github.com/microsoft/omi/pull/644) and some code was merged to add these files to logrotate.

    So you can add the same entry to logrotate conf file (omilogrotate.conf ) yourself, or wait for next release of the agent which will probably include it.

    /var/opt/omi/log/*.log /var/opt/omi/log/*.trc {
        # keep 5 worth of backlogs
        rotate 5
        copytruncate
    }

    Thursday, June 25, 2020 8:37 AM
  • Thx CyrAz, i've found that article also.

    But i don't know much about github and pull requests so i don't know what actions i need to take to use that new functionality, but more important, that is just a dirty workaround since we don't want this info to be logged at all.

    Isn't there a way to disable that logfile? Since it has trc in the name i would guess it is a trace file which you only enable when you're troubleshooting?


    Ronald

    Thursday, June 25, 2020 8:46 AM
  • I don't have a running linux agent available now, but by having a look at the source code in github it seems these files are generated when the agent is started with logging and http tracing enabled 

    To enable logging, start 'omiserver' with the option: '–loglevel
    <level number>'.  To generate HTTP 'trc' files, start 'omiserver' with
    the option: '–httptrace'.  Without these options, logging and 'trc'
    files will not be enabled.

    Thursday, June 25, 2020 8:52 AM
  • But we can also see that in some source files, the tracing seems to be forcefully enabled anyway : 

    #define FORCE_TRACING 1

    However don't take my word on that, I'm not super great at C development :o

    Thursday, June 25, 2020 8:59 AM
  • I now asked the admin of the server to add this

    httptrace=false

    to

    /etc/opt/omi/conf/omiserver.conf

    Maybe that will do the trick



    Ronald

    Thursday, June 25, 2020 9:02 AM
  • Too bad, setting httptrace=false seems to be ignored.

    Ronald

    Thursday, June 25, 2020 9:10 AM