none
Project Server 2016 GeneralInvalidColumnValue/PROJ_OPT_CURRENCY_CODE error RRS feed

  • Question

  • Hey.

    I have setup a Microsoft Project 2016 Server, but if i  try and create a new project via the ms project site collection like "http://MySharePointSite/sites/MSProjectPWA/_layouts/15/pwa/Wizards/CreateProject.aspx?src=GettingStarted#{"stage":1,"eptUid":"09fa52b4-059b-4527-926e-99f9be96437a"}", it just returns the error "GeneralInvalidColumnValue" to the UI" and 

    the ULS Log states

    "Error is: GeneralInvalidColumnValue. Details: Attributes:  PROJ_OPT_CURRENCY_CODE  . Standard Information: PSI Entry Point:  Project User: i:0#.w|REM Correlation Id: 61f90dbe-2f5f-e811-972f-00155d008604 PWA Site URL: http://MySharePointSite/sites/MSProjectPWA SA Name: MS Project Server PSError: GeneralInvalidColumnValue (20000)"

    "PSI Entry Point:  Project User: i:0#.w|REM Correlation Id: 6812466f-2d5f-e811-972f-00155d008604 PWA Site URL: http://MySharePointSite/sites/MSProjectPWA SA Name: MS Project Server PSError: NoError (0) XML: <errinfo><dataset name="ProjectDataSet"><table name="Project"><row PROJ_UID="6c12466f-2d5f-e811-972f-00155d008604"><error id="20000" name="GeneralInvalidColumnValue" uid="7012466f-2d5f-e811-972f-00155d008604" column="PROJ_OPT_CURRENCY_CODE" /></row></table></dataset></errinfo>".

    If i create a new project from Ms project from office or i import it it works fine.

    I also get errors other places, like if i try and access "Additional Server Settings" i get a cultural error in the ULS Log 

    Application error when access /_layouts/15/pwa/Admin/ServerConfig.aspx, Error=Culture ID 4096 (0x1000) is a neutral culture; a region cannot be created from it.  Parameter name: culture  
     at System.Globalization.RegionInfo..ctor(Int32 culture)    
     at Microsoft.Office.Project.PWA.ApplicationPages.ServerConfigPage.PJWebPage_OnLoad(EventArgs e)    
     at Microsoft.Office.Project.PWA.PJWebPage.OnLoad(EventArgs e)    
     at System.Web.UI.Control.LoadRecursive()    
     at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)

    I have tried to setup ms project on 2 different farms with the exact same result.



    • Edited by SharpX Thursday, May 24, 2018 9:39 AM
    Thursday, May 24, 2018 8:50 AM

All replies

  • Hello SharpX.  I know this thread is old, but did you ever resolve your issue?  If so, can you share with us how you resolved it?

    Thanks


    Chris Addis - MCTS

    Tuesday, February 5, 2019 1:19 PM
  • Make sure that the Project client and project web site match with the currency.

    Project client, look at Options/Display/Currency

    Project Web app, look at Server settings / Currency settings.  

    Make sure that they don't conflict.


    Michael Wharton, Project MVP, MBA, PMP and a Great Guy <br/> Website http://www.WhartonComputer.com <br/> Blog http://MyProjectExpert.com contains my field notes and SQL queries

    Tuesday, February 5, 2019 5:35 PM
    Moderator
  • Thank you Michael for the recommendation.  Today, working with Microsoft Premier Support, we tried your recommendation in addition to other actions.  Unfortunately, that solution did not help.  Neither did the other actions Microsoft tried solve the issue.  We will reconvene soon with support and try additional items.  I hope to post a solution soon, unless someone here proposes addition actions to try.

    Chris Addis - MCTS

    Wednesday, June 12, 2019 3:55 PM