none
Application Installs being skipped during OSD Task Sequence RRS feed

  • Question

  • Very odd issue with a imaging a Lenovo T460s. Application part of Task Sequence is skipped enitrely. Checking the SMSTS.LOG shows the following warning;

    Exit Code=2 may indicate that INF file of the driver refers to files that do not exist in the driver source folder. Remove the problematic driver from the Driver Package. They can be identified by looking at what driver installs failed (specifically error code 2) in the DISM log file. The error may be not fatal and DISM might have continued to install additional drivers. OSDDriverClient 9/11/2019 11:56:44 AM 964 (0x03C4)

    Other Lenovo models do not exhibit this behavior.

    Any help would be very much appreciated.

    Thx


    Wednesday, September 11, 2019 8:39 PM

Answers

  • So I added a step to restart before it continued with Application installs and the machine now completes with all applications being installed. Thank you to all those who responded.
    • Marked as answer by SCCMnimdA Friday, September 13, 2019 2:44 PM
    Friday, September 13, 2019 2:44 PM

All replies

  • Hi,

    May we know if it tried to install a driver? If yes, please try deploying the drivers via exe/msi as an application/package instead of using a driver package step. 

    If you are using an Auto Apply Driver or a Install Driver Package task, then the TS isn't responsible for installing drivers. These two tasks merely make the drivers available to Windows and Windows Setup so that they can install the drivers per their driver installation logic. You should be able to use pnputil or devcon to force a driver install as part of a script run during the TS after the Setup Windows and ConfigMgr

    Here are some articles for your reference: 

    Can't apply Surface Pro 6 drivers during TS
    Update a device driver Configuration Manager 2012
    install specific driver on TS sccm

    Thanks for your time.

    Best regards,
    Simon Ren

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Thursday, September 12, 2019 6:49 AM
  • Hi Simon,

    I have a query that checks the model SELECT * FROM Win32_ComputerSystem WHERE (Model LIKE "%20FAS5MJ00%" OR Model LIKE "%20F9003GUS%" OR Model LIKE "%20FAS5MJ00%")

    and then installs the appropriate driver package, in this case it picks the Lenovo T460s driver package.

    Everything else in the Task Sequence runs but for some bizarre reason it skips past the application installs.

    :/


    Thursday, September 12, 2019 3:35 PM
  • So I added a step to restart before it continued with Application installs and the machine now completes with all applications being installed. Thank you to all those who responded.
    • Marked as answer by SCCMnimdA Friday, September 13, 2019 2:44 PM
    Friday, September 13, 2019 2:44 PM
  • Hi,
     
    Thanks for your sharing. This may help the users who have similar issue. Thank you!
     
    Thanks and regards,
    Simon 

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Wednesday, September 18, 2019 1:46 AM
  • Hi,

    Thanks for your feedback. Here is a simple summary of this thread:

    Issue Symptom:
    Application part of Task Sequence is skipped entirely in Lenovo T460s

    Solution:
    Add the restart step in task sequence before install applications. 

    Reference Links:
    Application troubleshooting in deepth

    Thanks and regards,
    Simon

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Friday, September 27, 2019 9:17 AM