none
Simple EDI Failing to Parse RRS feed

  • Question

  • The simple EDI file looks fine to me. It passes lint using a utility however, it's failing when I pass it to my Home Depot partner.

    They say it's failing in the IDT but, I don't see why.

    The error they give is Excess Trailing Data Element Delimiter(s) after ITD05 (D.E. 351) at col. 13

    The IDT has 7 sections in the documentation so it must be something further up and that's just where the error finally failing.

    I've redacted a few things but the lengths and data-types are all the same.

    ISA*00*          *00*          *01*00000000      *12*000000000000   *190910*0718*U*00406*000000449*0*P*>~GS*IN*00000000*000000000000*20190910*0718*449*X*004010~ST*810*0001~BIG*20190909*87007*20190908*53834248~N1*RI*NAME REDACTED*93*8119~ITD*01*3*2**30**~IT1*1*1*EA*6.94**VN*107111~PID*F****FMM-2-S Standard Refrigerator Replacement Filter Fits Whirlpool Filter 4~TDS*694~CAD*ZZ****UPSS**CN*1Z914RE30300405984~SE*9*0001~GE*1*449~IEA*1*000000449~ 

    Wednesday, September 11, 2019 3:20 PM

All replies

  • Hi,

    The segment is 

    ITD*01*3*2**30**~

    There are 2 element delimiters with no values.  Depending on how the validation is set, the trailing delimiters with no value may cause errors.

    Try

    ITD*01*3*2**30~

    Mike

    Wednesday, September 11, 2019 5:29 PM
  • Try to validate your edi using edi notepad, it should show you any errors there may be in this payload.
    Tuesday, October 1, 2019 5:27 PM