none
deploying Office 365 1808 RRS feed

  • Question

  • I have created a task sequence that installs 5 packages and 1 application.  All 5 packages work. They download to the C__SMSTaskSequence\packages folder and execute.  The 1 Application does Not download and does Not run.  

    The Application in Question is Office v1808.     I looked in the SMSTS.LOG file on the target machine and it says: Successfully completed the action (MS Office 1808) with the exit win32 code 0

    Yet it never downloads or installs.   

    I was thinking it could be the .XML we're calling.  Here is it.  Does this look kosher?  

    <Configuration>
      <Add OfficeClientEdition="32" Channel="Targeted" Version="16.0.10730.20102" OfficeMgmtCOM="True" ForceUpgrade="TRUE">
        <Product ID="O365ProPlusRetail">
          <Language ID="en-US" />
          <ExcludeApp ID="Groove" />
          </Product>
      </Add>
      <Display AcceptEULA="TRUE" />
      <Property Name="SharedComputerLicensing" Value="0" />
      <Property Name="PinIconsToTaskbar" Value="FALSE" />
      <Property Name="AUTOACTIVATE" Value="1" />
    </Configuration>

    so I tried to copy all of the Office source files down to target machine and run setup.exe /configure Office.xml   and it worked.  Office was installed.

    Why would this fail via a Task Sequence?

    • Edited by mqh7 Thursday, June 20, 2019 9:25 PM
    Thursday, June 20, 2019 9:22 PM

All replies

  • I am experiencing something I've never seen and it only happens with Office 1808.   Everything I've already posted is still happening.  But I decided to create a Package to see if that made a difference.   I created the package which included a .CMD file that calls the setup.exe

    echo "Right before we run setup.exe  %DATE% %TIME%" >> "c:\windows\temp\Office1808.txt"
    "@%~dp0setup.exe" /configure "%~dp0CONFIGURATION64.xml"
    echo "We just ran CONFIGURATION64.xml %DATE% %TIME%" >> "c:\windows\temp\Office1808.txt"

    SCCM copies all source files down to c:\windows\ccmcache and runs the .CMD file.   But it never runs setup.exe.   My Office1808.txt file has this inside of it.

    echo "Right before we run setup.exe %DATE% %TIME%" >> "c:\windows\temp\Office1808.txt" "@%~dp0setup.exe" /configure "%~dp0CONFIGURATION64.xml" echo "We just ran CONFIGURATION64.xml %DATE% %TIME%" >> "c:\windows\temp\Office1808.txt"


    So it took 0 seconds to run.   But..... if I open up a CMD window and I type in setup /configure configuration64.xml then it works.  It takes about 5 min and it upgrades Office.   

    What would cause this behavior?   


    mqh7

    Friday, June 21, 2019 2:44 PM
  • So no matter what I do Office 1808 x64 will NOT execute via a CMD file.  i.e. "@%~dp0setup.exe" /configure etc....etc....

    Why? No errors are written anyplace. It just does Nothing. SCCM runs everything as SYSTEM so it has rights but it does nothing.

    but any other package I run that uses @%~dp works fine. Is there a certain way to run this software using SCCM?


    mqh7

    Friday, June 21, 2019 3:59 PM
  • Hi,

    May we know which client edition of Office you would like to install, Office 1808 x64 or Office 1808 x32? In the .XML file the client edition is 32, and the CMD file  is "@%~dp0setup.exe" /configure "%~dp0CONFIGURATION64.xml". May this be the cause?

    Thanks and regards,
    Simon Ren

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, June 25, 2019 7:57 AM