none
Error when configuring EDI/AS2 RRS feed

  • Question

  • Hi

    We have an environment that has 4 BizTalk servers and 4 SQL nodes.  We are in the process of installing/configuring BizTalk 2016 and using the always on option within SQL 2016.  We have all configured up to and including BAM Tools.  We did the install of the EDI/AS2 section but we had to unconfigure the EDI and the BAM Tools.  Then we removed the databases, data and log files.  After that we were able to reconfigure the BAM Tools but when we get to the EDI/AS2 section, the configuration fails and within the LOG file, we see:

    Deploying Activity... ERROR: The BAM deployment failed.

    DTS package BAM_DM_ResendJournalActivity already exists on server :Listener/MSGBOXDB

    Based on what I found on the web, it says to run the following commands:

    Bm.exe remove-all -DefinitionFile:"C:\Program Files (x86)\Microsoft BizTalk Server 2016\AS2ReportingActivityDefs.xml"

    Bm.exe remove-all -DefinitionFile:"C:\Program Files (x86)\Microsoft BizTalk Server 2016\EdiReportingActivityDefs.xml"

    Bm.exe remove-all -DefinitionFile:"C:\Program Files (x86)\Microsoft BizTalk Server 2016\EdiReportingActivityIndexes.xml"

    When I run the first one, it comes back with …done, and the second one also.  But the third one says:

    ERROR: The BAM definition XML is not valid.

    The BAM definition XML is not valid.

    I have asked the DBA to check the Integration Services to find BAM_BM but he cannot find any.

    We have been struggling with this for the last 3 days.  Any help would be greatly appreciated.

    Thanks

    Shawn

    Wednesday, September 18, 2019 12:32 AM

Answers

All replies