Error: Unable to determine libssl.so path RRS feed

  • Question

  • Hi,

    Trying to install a agent on a new red hat 7.5 system. The install via the scom console fails with an error about winrm so i purged the installation and tried to install the agent manually.

    The installation gives an error:
    Error: Unable to determine libssl.so path

    After the error the installation seems to run ok, even the certificate is created but when i then run discovery i get the same winrm error again. I noticed there is no listener process on port 1270, agent will not stop normally, killing/restarting gets the listener process up and running but discovery still fails.

    I think the error about libssl seems to be the root cause but i don't know how to solve this.

    openssl version
    OpenSSL 1.1.1d  10 Sep 2019

    yum list installed|grep -i openssl
    openssl.x86_64                          1:1.0.2k-12.el7            @anaconda/7.5
    openssl-libs.x86_64                     1:1.0.2k-12.el7            @anaconda/7.5
    openssl098e.x86_64                      0.9.8e-29.el7_2.3          @anaconda/7.5
    openssl11.x86_64                        1:1.1.1c-1.el7             @epel
    openssl11-libs.x86_64                   1:1.1.1c-1.el7             @epel
    pyOpenSSL.x86_64                        0.13.1-3.el7               @anaconda/7.5

    [svcscom]$ ldconfig -p|grep -i ssl
            libssl3.so (libc6,x86-64) => /lib64/libssl3.so
            libssl.so.10 (libc6,x86-64) => /lib64/libssl.so.10
            libssl.so.6 (libc6,x86-64) => /lib64/libssl.so.6
            libssl.so.1.1 (libc6,x86-64) => /lib64/libssl.so.1.1
            libssl.so (libc6,x86-64) => /lib64/libssl.so
            libevent_openssl-2.0.so.5 (libc6,x86-64) => /lib64/libevent_openssl-2.0.so.5

    [svcscom]$ ls -al /lib64/libssl.so
    lrwxrwxrwx. 1 root root 27 Mar 16 10:55 /lib64/libssl.so -> /usr/lib64/libssl.so.1.0.2k

    so for me the path to that library seems ok.


    Friday, June 5, 2020 9:18 AM

All replies

  • Support for OpenSSL 1.1.0 was introduced with SCOM 1807 and 2019. What version of SCOM are you running?
    Friday, June 5, 2020 9:46 AM
  • Sorry, i had to mention that, we run 2019 UR1


    Friday, June 5, 2020 9:49 AM
  • You can check the function used to determine libssl.so location (create_ssl_links() ) in the omiagent source code (it's a pretty easy to read .sh script) : https://github.com/microsoft/omi/blob/master/Unix/scripts/installssllinks

    That may help you understand why/where it fails...


    • Edited by CyrAz Friday, June 5, 2020 10:33 AM
    Friday, June 5, 2020 10:30 AM
  • Tnx,

    It goes wrong on line 73, that command gives no output.

    $ which openssl

    $ ldd /usr/bin/openssl| grep libssl.so | awk '{print $3}'
    <no output>

    If i run it without the grep and awk it shows

     ldd /usr/bin/openssl
            linux-vdso.so.1 =>  (0x00007ffc43fe7000)
            libdl.so.2 => /lib64/libdl.so.2 (0x00007f70c357b000)
            libpthread.so.0 => /lib64/libpthread.so.0 (0x00007f70c335f000)
            libc.so.6 => /lib64/libc.so.6 (0x00007f70c2f92000)
            /lib64/ld-linux-x86-64.so.2 (0x00007f70c377f000)

    So there seems to be missing some link i guess but i don't have a clue how to solve this.

    Strangly i see the same output on an equally new node where i could install the agent without issue


    Friday, June 5, 2020 11:53 AM
  • That's unfortunately as far as my Linux skill goes without being able to tinker around myself :/
    • Edited by CyrAz Friday, June 5, 2020 12:17 PM
    Friday, June 5, 2020 12:17 PM
  • Thanks for your help sofar, i'll wait till monday if somebody else has an idea and if not open an support case.


    Friday, June 5, 2020 12:43 PM
  • Hi,

    Have you managed solving this?

    Running into the same problem with a CentOS 8 server in my SCOM 2019 environment.



    Tuesday, June 23, 2020 8:07 AM
  • Hi Daniel,

    Not yet, still working on the issue with microsoft support. Once we know the solution i will add it to this topic.


    Tuesday, June 23, 2020 8:17 AM
  • Alright, thanks!
    Tuesday, June 23, 2020 8:32 AM
  • Hi Daniel,

    Agent is finally installed and working ok.

    Unfortunately there's not a clear cause and solution, there has been a lot of actions taken by other people during my holiday's and they cannot tell me what was finally the cause and solution.

    Did you manage to get your agent working?


    Friday, July 24, 2020 7:25 AM