locked
SoftGrid Management Console Errors 0000C800 and 0000C802 RRS feed

  • Question

  • Yet another bump in the road to getting SoftGrid up and running per the Trial Guide.....

    Netting it out:  I am trying to connect SoftGrid Console to Softgrid Server and am  getting  errors (0000C800  and 0000C802 .  I am trying  to do Trial Guide Step #3 on Page 19 (Testing of Default Application.)

    I have spent the last 2 hours or so trying various permutations (outlined and referenced below)  of accounts and ports changes, and have checked out various TechNet articles about those error messages.   Bottom line:  99% of the stuff looks fine as is but I am not able to connect....   That last 1%...well ...read on... it is stuff that is pretty low down on the list and stuff that I just don't grok (yet).

    Update:  It is now 10 hours later and I am still no further along ... Jump to the end of  the below background info to see my current situation.  I think it has something to do with giving ASP.NET worker process the right permissions....but I don't know exactly how to do that.

    Background:
    Environment:  Intel Quad 64 hardware.  Server 2008 RC1 (with hyper-vBeta)  host running a Server 2008RC1/HyperVBeta  child vm.   On child VM (I named it {SoftGridManager), I have installed SoftGrid Manager, and all the required components (SQL Express, C++, IIS Roles, Terminal Server roles).   In a separate child VM I have  an Active Directory domain controller set up. and  the two VMs talke to each other fine.

    Actions taken
    So here I am, happy to be getting down to the short strokes of implementing this lab trial.  I had just set up a separate physical server and went through the Sequencer process and successfully packaged up WordViewer2003.sprj  just like it said to do in the Trial Guide.  I even copied the Word Viewer 2003 folder (with the output of the packaging process) over to the content directory of the SoftGrid Manager Server on the VM called "SoftGridManager".   (see step 44 on Trial Guide page 35)

    OK... now I am ready to take step 45 (page 36): 
    "Add the new application to Microsoft System Center aPplication virtualization Management Console following the instructions provided with the pre-sequenced application. "   Ok,... so I skip back to page Trial Guide page 19 ("Testing the Default Application") and follow Steps 1 (Administrative Tools, click SoftGrid Management Console)  & 2 (in ACTIONS pane, click CONNECT TO SOFTGRID SYSTEM)

    I continue onto to Step 3: "In the CONNECT TO SOFTGRID SYSTEMS dialog bbox, in the WEB SERVICE HOST NAME field, type "localhost", and click OK" .

    Fine, sez I, and I type in "localhost" and leave everything else as the default.  That means Port==80 and Login Credentials == Use current Windows Account 

    Note on my AD set-up:  (I am logged in as Administrator of the SoftGridManager server child VM.  I had previously included the Administrator account in the security group I created on the domain controller for administering SoftGrid.  That was added under the base domain "dev.xxxx.com\Microsoft Application Virtualization" (a folder that is a sibling of dev.xxxx.com's folders called:  Users, Builtin, computers, domain controllers and foriegnSecurityPrincipals)   In the  folder i created 2 security groups:  1) Administrators - MS Application Virtualization  and 2) SoftGrid Users; and two users:  1) MS Application Virtualization AD Browser User  (probably not needed)  and 2) TestUser.    In that "Administrators - MS Application Virtualization" security group I have added a few users including the Administrator  from dev.xxxx.com/Users  and TestUser from dev.xxxx.com/Microsoft Application Virtualization

    Anyway.,,,, back to the main storyline....

    So I click "OK hoping to be logged in and it sits there in hourglass mode until  up comes the following error: "SoftGrid Management Console; Unexpected error occured. Please report the following error code to your system administrator.  Error code 0000C800

    I click OK and tell myself, maybe I got the permissionings wrong.  So I check through AD and am pretty sure everything is right but I say, let me specify a windows account to log in on.  So I click the radio button "Specify  Windows account" and type in a series of account credentials....always getting the same C800 error in response.   I entered the following account formats:   DEV\Administrator; DEV.xxxx.com\Administrator; xxxx.com\Administrator.   I also did the same for TestUser.

    The only time when I got a different response was when I entered the account without the Domain portion:  Administrator.  In that case I got the Error 0000C801  .  I check out that KB930470 and try the trouble shooting hints.  1) Port number is invalid (I believe this is correct based on other research - see below) .  The other troubleshooting hints all require you to first connect the Management Console to the SoftGrid Server...which is exactly what I can't do!!!!!)

    In any event, I figure that error C801 is a red herring and its just that I need to include the domain since it says that I need to include the domain in the instructions on the connect dialog box.

    OK... so I say, "maybe I should try it with the actual host name instead of localhost.    So I try the various permutations and always get the errors   I try:  SoftGridManager.dev.xxxx.com  (error c800) , SoftGridManager.xxxx.com  (error C809), and SoftGridManager (Error C800).   I did all of these using the default "Use Current Windows Account" and default Port 80.
     
    OK... now its time to do the troubleshooting on error 0000C800 :

    1."Verify that the SoftGrid Management Console version and the SoftGrid Management Web Service version are the same."  I did that and they are the same (4.5.0.606 (Beta) )

    2) "Verify that the SoftGrid Management Web Service is functioning correctly. To do this, type the following command in a standard Web browser:
    http://webserver_name/SoftGridManagement/Authorization.rem?wsdl
    If the SoftGrid Management Web Service is functioning correctly, text that resembles the following is displayed:
    System.NullreferenceException: Object reference not set to an instance of an object. at System.runtime.Remoting. ... "
      OK...no problems here

    3) "Verify that the port that is specified in the Connect to SoftGrid System dialog box is the SoftGrid Management Web Service port. "
     Huh?  No instructions on how to do that.   So I search around and find out 80 is correct.  I had even tried ports 332 and port 554 which came up as a documentation bug during sequencing a packaging (Trial Guide page 29  Step 7.d.iii)
    No assuming that this is the right port.

    4) "Verify that the SoftGrid Management Web Service server can connect to the database. To do this, follow these steps on the SoftGrid Management Web Service server:
    a. Locate the "%ProgramFiles%\Softricity\SoftGrid Management Service" folder.
    b. Right-click SftMgmt.udl, and then click Properties.
    c. Click the Connection tab.
    d. Click Test Connection to validate the connection.  

    It Fails the test .  It gives me the error "Microsoft DataLink Error.  Test connection failed because of an error in initialzing provider. [DBNETLIB][ConnectionOpen (Connect()).]SQL Server does not exist of access denied.


    hum...... lets read on in the KB

    e. "If the test fails, verify that the following information that is entered on the Connection tab is correct:
    Server name < it says "SoftGridManager.dev.xxxx.com"   let me try it with the other iterations . I try it with "localhost" and "SoftGridManager" both with the database defined as SoftGrid and SQLEXPRESS.   No luck...same error>
    User name <I keep it at the default "USe Windows NT Integrated security">
    Password <same as above>
    Database name  <I change "SoftGrid" to SQLEXPRESS" while keeping the servername at the default,   No Luck, same error>
    Change any incorrect information, click OK, and then stop and restart the SoftGrid Management Web Service.  <I cancel out and doublecheck that no changes were made.>
    While I have that properties box up, I go check out the  "Providers" tab.  It is highlighted on "Microsoft OLE EB Provider for SQL Server.   hummm..... seems reasonable.

    SO, Here is the first test that does not work.   all the info is correct but the connection test does not work AND THERE IS NO FURTHER INSTRUCTIONS IN THE KB as to what I should do with this step..  Does anyone know?   I am sort of a dead-end here...

    ....so I decide to continue soldiering along the KB

    5." If the information that is entered on the Connection tab is correct, use the PING command to verify that the SoftGrid Management Web Service server can communicate with the database server." 
     No problem here.  I open up a command line and ping SoftGridManager.dev.xxxx.com  and I get 100% return.  It says " Repy from ::1: time<1ms;  Packets sent: 4 ; Packets received: 4

    6. "Verify that the database service is started. For example, make sure that the MSSQLSERVER service is started."

    No problems here.  Well, no instructions on how to do that...so I just go to cmd  and type net start.  I see 2 SQl related services running:   SQL Server (SQLEXPRESS)    and SQL Server VSS Writer .

    7 "If you are running Microsoft Windows 2000 Server and if the Microsoft .NET Framework was installed before Internet Information Services (IIS) was installed, follow these steps to register the .NET Framework with IIS:
    a. At a command prompt, move to the %systemroot%\Microsoft.NET\Framework\version_number folder.
    b. Type aspnet_regiis.exe /i, and then press ENTER."
    Well, I am running Server 2008...but what the heck, let me give it a go....

    So I cd %systemroot%\Microsoft.NET\Framework\  and then do a DIR looking for sub-directories.   I see v1.0.3705 , v1.1.4322 and v2.0.50727 . 

    so I cd v2.0.50727  and then type aspnet_regiis.exe /i

    Low and behold....I get the following error message:

    "The error indicates that IIS is not instaled on the machine.  Please install IIS before using this tool.  Finished installing ASP.NET "



    Wah?!!!!  ... I installed IIS days ago and even checked that it had ASP.NET per Steps 2 & 3 on Trial Guide page 11.   I look back at my notebook and notice that I made the following penciled remark regarding the step by step instructions in Step 3 for checking if ASP.NET has been installed:   "Not exactly the same  wording on Server 2008... but ASP shows."

    Hum...sez I... I guess I'll need to doublecheck the ASP.NET through server Administrative Tools\IIS Manager.  But first...what is that last line the command returned: "Finished installing ASP.NET"  .  hummm...past tense....maybe it cleaned it up for me.   so I ran the command again and got the same error message verbatim.   Ah well... lets go and check out the ASP.NET again per the instructions on Page 11 of the Trial guide.

    So I make sure that I am on the SoftGridServer VM and I click Start\Administrative Tools\IIS Manager     (I see that I also have IIS 6.0 Manager...but I'll look at that later)

    In the lef t pane I doubleclick and then expand SOFTGRIDMANAGER (SOFTGRIDMANAGER\Administrator) .  As I mouse over it, it shows me that it is http://localhost/ .

    In the middle plane, the first thing that shows is the ASP.NET area.   Yup, its there....lets click into some of the icons and see if I can see anything unusual

    ...In the Session State icon,  the "Session State Mode Settings" comes up with the radio button on "In Process".     The SQL Server connection string is in there (data source=localhost;IntegratedSecurity=SSPI) but that string is grayed out and the radio button is not on (because it is on "In process"  "    Not sure if this all means anything

    moving on.... I go down to the IIS Area...

    I see the icon for Worker Processes and click on it.   There is nothing in there  ...not sure if this is significant or not

    well....nothing that grabs my attention... before I give up this line of research,,, lets see what I can see via the  Server Manager/ add roles dialog.....

    I scroll down to Web Server (IIS)  and I see:  System Services: 4 running, 1 stopped.

    Humm... I wonder what is stopped....lets click on that link.

    I see:

    ASP.NET State Service     aspnet_state    stopped     manual      no

    hummm
     
    I highlight that service and the description says "  Provides upport for out-of-process session states for ASP.NET.  If this service is stopped, out of process requests will not be processed."

    humm...not sure if that is exactly my problem, but what the heck, lets change the prferences to  start/enabled

    So I set start up to be Automatic and started the service.   I confirmed that the current state is running.

    Feeling hopeful, I go back to the cmd line and retype aspnet_regiis.exe /i.

    DAMN!  Same #@%! error.


    "The error indicates that IIS is not instaled on the machine.  Please install IIS before using this tool.  Finished installing ASP.NET "

    Oh well...lets check out Server Manager/Roles/WebServer/Add Role Services....

    Nothing really interesting here.   The only stuff that is left uninstalled are things that you would not think make would make a (positive difference) in this situaiton:  (custom logging, ODBC Logging, Digest authentication, IIS Client Certificate mapping authentication URL authorization, IP and Domain restrictions, Dynamic Content compression, Management Service, FTP Publishing Service)

    No dice here....lets go check out IIS 6 Compatibility stuff... I remember I had trouble installing SoftGrid in the first place until I was told through TechNet that i had to enable IIS 6 compatibility mode


    So I start/Administrative tools/IIS6 Manager ..highlight the one thing that is in the left pane ( Internet Information Services)  and the right pane just says "There are no items to show in this view

    Oy... Another Dead end

    So lets turn back to the KB and keep on keeping on.....

    8. "Verify that the ASP.NET worker process account has Read permissions for the SftMgmt.udl file and for the SftReporting.udl file. The following table lists the ASP.NET worker process account names for various scenarios.
    Operating system Role ASP.NET work process account
    Windows 2000 Server Member server ASP.NET account (computer_name\ASPNET)
    Windows Server 2003 Member server ASP.NET account (computer_name\ASPNET)
    Windows 2000 Server Domain controller Account that starts the IIS process (domain_name\IWAM_computer_name)
    Windows Server 2003 Domain controller Network Service account

    <Well.... I am using Server 2008... nothing in here tells me what to look for.   I guess I will keep my eyes open and generally look in the direction of Server 2003.







    To verify the permissions for the ASP.NET worker process account, follow these steps on the SoftGrid Management Web Service server:
    a. Locate the "%ProgramFiles%\Softricity\SoftGrid Management Service" folder.
    <OK, this is a little different the  actual path in 2008 is: ~ Program Files (x86)\Microsoft SoftGrid\Microsoft System Center virtual Application Server\ SoftGrid Management Service :
    b. Right-click SftMgmt.udl, and then click Properties.  <ok>
    c. Click the Security tab. <righty-o>
    . Add the appropriate ASP.NET worker process account, and then assign Read permissions to the account.

    WHAAAAA?!!!

    Ok, first all the Groups/Users that already are in there have right enabled.   The names are:  ISUER, SYSTEM, Local Service, Network Service, Administrators (SoftGridManager\Administrators)
    (IIS_IUSERS (SoftGridManager\IIS_IUSERS)

    No  mention of :
        Member Server , ASP.NET or  account (SOFTGRIDMANAGER\ASPNET)

    but there is something for domain controllers.... and a separate one for Enterprise Domain Controllers.....lets add those...





    However
    there is already NETWORK SERVICE   and it already has READ enabled.
    So no need to re-add that.,...

    OK... I'm game... I'll try adding... so I click "Add"....
    Hit Advance in order to see all possible names and up comes the  Windows security box asking me to authenticate to the AD Domain Controller....   I log in with the Administrator account and am let in.

    I then click "Find now" and a listing of all known objects are in there....but nothing about ASPNET account  or member server.

    There is, however, a few objects about domain controls... I'll add Domain controler  and Enterprise Domain Controller.     I'll even add Network

    I'll try to manually type in ASPNET  and SOFTGRIDMANAGER\ASP.NET  but no luck there




    e.
    Click OK.


    f. Locate the "%programfiles%\Softricity\SoftGrid Reporting Service" folder.
    g. Right-click SftReporting.udl, and then click Properties.

    <Can't find any SFTReporting.udl or even anything that refers to a SoftGrid Reporting service
    h. Click the Security tab.
    i. Add the appropriate ASP.NET worker process account, and then assign Read permissions to the account.
    j. Click OK.


    SO Here is another Dead-end...Can't figure out how to add anything that talks about ASP to the SFTMGMT.udl



    OK... so on to Step 9.   I have high hopes for Step 9 since it is my last chance.   Also it was refered to in this Technet posting


    9.Verify that the ASP.NET worker process account on the SoftGrid Management Web Service server has the following permissions.

    How do I do this..... going to research this now....



    Location Permission
    %systemroot%\Temp Full control
    %systemroot%\Microsoft.NET\Framework \version_number\Temporary ASP.NET Files Full control

    Well... I'm about to give up :-(

    googling around I came up with two possibilities for permissioning

    One was to go through Administration Tools/IIS/SOFTGRIDMANAGER\Default Web Site\SoftGridManagement\bin\permissions and make sure everything has read privs.

    Did that

    The other way was to go to  %systemroot%\Microsoft.NET\Framework \v2.x.x.  and run  aspnet_regiis.exe -ga <user>

    I am a bit confused which <user> to put there.

    I did:
    aspnet_regiis.exe -ga  Administrator
    aspnet_regiis.exe -ga  System

    The program ran and said that it gave permissions.

    I tried to connect from management console to Softgrid and still got C800 error.


    Grasping at straws... I went into SoftGrid Manager and clicked "Reset SoftGrid Administrators"


    Since there were no servernames in the pull down boxes , I tried localhost and SoftGridManager  using the Administrator's credentials.   No luck.  


    Somehow I got to the screen where it is supposed to show the current SoftGrid administrator groups. and there is nothing in the list.  I click add and see tons of objects from AD.   I click on the first thing "Administrators - MS Application Virtualization"   and click OK   ,, when I hit Finish, I get....ERROR  0000C800 !!!!


    I started this on Saturday morning at 8AM.   It is now Saturday night at  9:30pm.   I did not go out all day.  1 hour for dinner.


    What am I missing? (except a life)



    Saturday, February 9, 2008 11:09 PM

Answers

  • Just out of curiosity, did you ever get this sorted?  We sometimes see this error and oddly, if you right click the management console and runas your admin account -- it will sometimes launch ???  I've heard it could be related to .NET on the server.

     

    Wednesday, February 20, 2008 1:06 PM

All replies

  • Using Sql Express requires a change there.  I haven't used the guide as it wasn't available when I installed the beta, but on my website I have a video that takes you through the process, including what I guess was missing when you set up Sql Express for the 4.5 Beta.

     

     http://www.tmurgent.com/Videos/Sequencing%20With%20Tim%20Mangan/Episode%207/Episode7.htm

     

     

    Monday, February 11, 2008 3:54 PM
    Moderator
  •  

    Thanks Tim.

     

    Hope there are no "gotchas" since I am doing this on Server 2008 RC1 and your video is done on Server 2003

     

     

    Ken

    Monday, February 11, 2008 5:08 PM
  • Just out of curiosity, did you ever get this sorted?  We sometimes see this error and oddly, if you right click the management console and runas your admin account -- it will sometimes launch ???  I've heard it could be related to .NET on the server.

     

    Wednesday, February 20, 2008 1:06 PM
  •  

    Thanks for that; download 135 mbs of video and sit through 35 mins of rubbish for 60 seconds of something useful.

     

    I take it that being an MVP doesn't include common or helpful sense?

     

    Regards,

    Brian

    Thursday, March 20, 2008 3:06 AM
  • Hey, you spent 10 hours (intially) on something the documentation covered but either you didn't read or didn't comprehend.  Whats another 35 minutes to get it visually?

     

    Thursday, March 20, 2008 5:36 PM
    Moderator
  • So, guys, would it be possible to post the solution to this problem here?
    Thursday, June 18, 2009 4:02 AM
  • I had the exact same problem and this solved my problem.

    http://blogs.catapultsystems.com/javery/archive/2009/09/29/appv-error-0000c800.aspx



    Thursday, February 4, 2010 11:21 PM
  • I experienced the same problem while connecting to a database which was set up dedicated for App-V usage. I followed KB 930565 and while performing the check on step 4, I ran into problems. I found out that configuration of SftMgmt.udl was incorrect. In order to solve the problem, I renamed SftMgmt.udl to SftMgmt.old and created a new SftMgmt.udl (create a notepad txt-file and rename it to udl instantly). After setting the server, database and authentication configuration within the udl-file, while keeping the other settings as default as possible, I could successfully set up a connection with the App-V database (both from the UDL and mgmt console).
    Saturday, April 10, 2010 4:47 PM
  • I got the same issue. I also spent 10 hrs here and tried several things. However, I would recommend to update the documentation to the most current systems, such as Windows Server 2008 R2 and AppV 4.6 and how to create a new SftMgmt.UDL. This plus a restart solved the isse - Thanks Richard
    Lothar Zeitler
    • Proposed as answer by JSakthiG Thursday, September 30, 2010 4:42 PM
    Friday, July 2, 2010 12:08 AM
  • Sorry guys.. I clicked on the wrong option and proposed the last entry as an answer. It was unintended.

    I had the same problem and the following thread helped me: 

    http://www.experts-exchange.com/OS/Microsoft_Operating_Systems/Server/Windows_Server_2008/Q_24694474.html

    "Problem solved!

    Started "Sql Server Configuration Manager", under "SQL Server Network Configuration" we enabled "Named Pipes" and "TCP/IP".

    This solution isn't mentioned in any of the thread/googling I have read"

    As part of troubleshooting I tried using Procmon to see if there are any access denied errors. I couldn't see any and I could see that the traffic from the App-v management server was able to reach to SQL server (in my case both were same) and I was able to open the SQL management console also successfully as the Appvadmin user I created as per the guide. 

    Hope this helps others.

    • Proposed as answer by Hacedilla Tuesday, September 4, 2012 9:04 AM
    Thursday, September 30, 2010 4:47 PM
  • After many hours on this, what worked for me:

    Make sure you actually SHARE the Content folder under the Sharing tab, not just give permissions under the Permissions tab. 

    I also incorporated other fixes from online tips along the way (like the pipes/tcpip suggestion above), so not sure if they also played a part, but in the end the doors opened when I shared Content. 

    Happy to be moving along at last.

    Friday, December 3, 2010 6:40 PM
  • Make sure you actually SHARE the Content folder under the Sharing tab

    Just gave it works without share content folder. Just recreated .UDL file.

    Thursday, May 3, 2012 12:45 PM