locked
Error 0000C801 in Console - on server 2008 RRS feed

  • Question

  • Hi all, I have an issue running the Softgrid Managment Console

     

    My platform is:

     Server 2008 x86 Standard

     SCAV management server 4.5.0.606

     SQL 2005 Express installed locally

     The server happens (in this PoC) to also be a DC

     

    The installation of the management server worked (well, eventually), however when I run the Softgrid Management Console and try to 'Connect to SoftGrid System' I get the following error:

     

    Unable to log into the SoftGrid System

    Invalid user name or password

    Error code: 0000C801

     

    I am running the console on the computer that is the management server, and the error occurs both if I use 'the current windows account' or if I specify an account.

     

    The user I'm logged in as is a member the admin group I configured during setup (also happens to be a domain admin as it's just a test environment)

     

    Firewall on the 2008 server is currently disabled.

     

    Now of course I think the issue is related to IIS 7, but I have checked out a bunch of settings and can't seem to find the cause.

    I’ve have done the following:

     

    ·         Installed some of the IIS6 compatibility stuff (had to to even get the softgrid installation to work)

    o   IIS 7 management scripts and tools

    o   IIS 6 Metabase compatibility

    o   IIS 6 Management Console

    ·         Granted NetworkService and the machine$ account read access to “C:\Program Files\Microsoft SoftGrid\Microsoft System Center Virtual Application Server\SoftGrid Management Service” (as the ‘Classic .NET AppPool’ is running as NetworkService).

    ·         I have also given NetworkService full control to:

    ·         C:\Windows\Microsoft.NET\Framework\v2.0.50727\Temporary ASP.NET Files

    ·         %SystemRoot%\Temp

    ·         Granted NetworkService Local Launch and Local Activation rights on both  ‘IIS admin’ and ‘IIS W3 control’ DCOM items

    ·         Checked out auth options in IIS7 and things look ok (anonymous and forms are disabled. ASP.NET impersonation is enabled (authenticated user).

     

    This is written to the IIS log when a connection is attempted with the softgrid console:

    2008-05-16 03:56:57 ::1 POST /SoftGridManagement/Authorization.rem - 80 - ::1 Mozilla/4.0+(compatible;+MSIE+6.0;+Windows+6.0.6001.65536;+MS+.NET+Remoting;+MS+.NET+CLR+2.0.50727.1434+) 401 2 5 1060

     

    Anyone have any ideas?

     

    Thanks,

    Michael.

    Friday, May 16, 2008 5:29 AM

Answers

  • The article (http://support.microsoft.com/kb/930470) details the IIS 6 auth settings required when this error is seen. Specifically it states to enable basic auth and/or Integrated windows auth.

    Turns out that IIS7 does not have Windows Auth installed by default (It does have ASP.NET Impersonation which was enabled and I thought that may have worked - hence why I didn't go down this path earlier).
     
    Installing Windows Authentication in IIS7 has solved my issue.

    [In Server Manager, under IIS, click Add Role Services. Under Web Server \ Security tick Windows Authentication]

     

    One other thing I have discovered along the way is that you should also ensure no proxy is being used (softgrid console will use the proxy setting in IE) - though this wasn't my issue.

     

    Monday, May 19, 2008 12:22 AM

All replies

  •  I have the same issue...... I has been take more than 8 hours to resolve it.But also no idea....

    Friday, May 16, 2008 10:00 AM
  • The article (http://support.microsoft.com/kb/930470) details the IIS 6 auth settings required when this error is seen. Specifically it states to enable basic auth and/or Integrated windows auth.

    Turns out that IIS7 does not have Windows Auth installed by default (It does have ASP.NET Impersonation which was enabled and I thought that may have worked - hence why I didn't go down this path earlier).
     
    Installing Windows Authentication in IIS7 has solved my issue.

    [In Server Manager, under IIS, click Add Role Services. Under Web Server \ Security tick Windows Authentication]

     

    One other thing I have discovered along the way is that you should also ensure no proxy is being used (softgrid console will use the proxy setting in IE) - though this wasn't my issue.

     

    Monday, May 19, 2008 12:22 AM
  •  Michael

     

     Thank you very much ... Smile

     

    Tuesday, May 20, 2008 1:45 AM
  • Michael, U rock!

     

    I've been searching for hours and the only link I found on the www net was this forum item.

    Anyway, the 'Windows Authentication' did the trick.

     

    thx

    (a SoftGrid 3.2, 4.0, 4.2 fan)

     

    Thursday, September 18, 2008 11:07 AM
  • Michael,

    This is definitely a good finding, it saved me for what I have been reading at least 8 hours of frustration! ... once thing that most of us have failed to realize is that IIS 7.0 is an entire different species of monster and that a lot of the features we overlooked in IIS 6.0 because they were installed by default or not necessarily so in IIS 7.0 ... thanks dude!

    Tuesday, May 12, 2009 7:26 PM
  • Thanks!
    Friday, February 11, 2011 1:05 PM