none
Surface Dock network port issues RRS feed

  • Question

  • We are in the process of getting ready to deploy Surface Pro 4's with Windows 10 and we've come across a major issue with the new Surface Docks. The network adapter in the dock keeps disappearing/disconnecting/failing after a certain amount of time. We are experiencing about 95% failure rate during imaging.

    Some examples we are seeing:

    - During imaging (via SCCM 2012 R2 SP1), the task sequence will fail at random points. Before turning it off, running an ipconfig results in no network adapters connected anymore. Looking at the logs, the task sequence has failed due to no network connectivity. 

    - During imaging (again via SCCM), I'll have a CMD window open continuously pinging a PC on the network. At some random point some packet loss will start occurring, the task sequence will fail, and then the pinging returns to normal. Again looking at the logs, the failure is a result of lost network connectivity.

    We have tried 6 different docks now, with 5 different Surface Pro 4's and the results are the same on all. The failure always occurs after the WIM has been applied and is running through applying different software and scripts.

    I've checked the network driver we are using and it is the latest provided by Microsoft: Version 8.19.0602.2015, dated 6-2-15. I have tried with previous driver versions to see if there is any change (there isn't). We have also made the entire Surface Pro 4 driver and firmware pack (was Jan 2016, now using Feb 2016 version with no difference) available during our task sequence build so the Surface's are grabbing the most recent drivers available. This has been confirmed in the 5% of machines that do successfully build, all the other devices are detected fine.

    We are currently using the exact same Task Sequence on the same subnet (even the same cables) to image Surface Pro 3's and Virtual Machines (different subnet) and they are working fine.

    If we use the USB to Ethernet adapter on the exact same devices/network cables, the devices image fine. The issue follows the Surface Docks.

    We can't prove it but we have a hunch that when the Surface is reaching the fully charged state, the dock is turning the power supply to the Surface off which is also affecting the network connection periodically. Does anyone know how we could prove this [or not]?

    Googling the issue has brought up similar reported issues: http://answers.microsoft.com/en-us/surface/forum/surfacc-surfpower/surface-pro-4-dock-ethernet-connectivity-problems/cea55eb9-db31-464e-b737-1253fa7ff757?auth=1

    http://answers.microsoft.com/en-us/surface/forum/surfpro4-surfperf/wifinetworking-issue-when-connected-to-docking/d9cfa028-1817-4ab5-a87e-a84d73d945d1?page=1&auth=1

    Anyone experiencing similar issues? Any ideas for how else I can troubleshoot?

    • Edited by Θ Tuesday, February 23, 2016 12:03 AM
    Tuesday, February 23, 2016 12:02 AM

All replies

  • I am having a similar problem with just my single surface book and dock. intermittent Ethernet issues previously, and now with a replacement dock it seems total Ethernet absence. All updates installed. Any help appreciated.
    Wednesday, February 24, 2016 3:19 AM
  • Just to follow up, Microsoft have confirmed with us that this is a widespread issue affecting all their Surface Docks. No fix at the moment but they're working on one.

    Tuesday, March 8, 2016 1:54 AM
  • Good to know - and the problem (or another) affects my external screens (x2) using dock as well which will refuse to awaken from sleep, causing a meltdown in screen setting generally. Do you know if this is widespread also? All problems seem to be very hush hush
    Tuesday, March 8, 2016 2:15 AM
  • We don't have anyone using 2 external monitors (only 1 monitor) so we haven't come across that issue nor brought it up with MS. We do have other random once-off issues which we can't really get a grasp on, but it may be Windows 10 or Surface Pro related. The network issue is such a huge problem for us that we haven't really looked at anything else yet as this issue alone is stopping deployment. 

    But yes, for such a 'widespread issue' the 8 or so support staff I've spoken to at Microsoft prior to today seemed to have no idea at all.

    Tuesday, March 8, 2016 2:23 AM
  • Thanks

    I am "deployed" and am looking seriously at returning this product and going for an XPS 13 or similar. Really don't want to, but my surface book trust is pretty much gone.

    Good luck out there

    Tuesday, March 8, 2016 2:34 AM
  • Hello,

    Do you have an open ticket with Microsoft so that I can quote it when we call in for support due to similar issues we're experiencing?

    thanks!

    Tuesday, March 8, 2016 6:01 PM
  • Hi all......subscribe to this post since I have similar issues.

    I use SCCM 2012 R2 SP1 CU3 (5.00.8239.1403) and have the same issues deploying the Windows 10 Enterprise image to my Surface Pro 4.

    At some point, and with less application assigned in the task sequence, I thought that re-imaging from a running OS was working fine......but it seems not.

    Hopefully MS will provide a solution soon, since now these Surface Pro 4 we have are useless.

    ********************

    I also do have an issue with booting from USB....using the dock and USB stick it is hardly possible to boot from USB. I have had it working for a few times, but mostly it won't work :-( Anyone else have this USB boot issue ?

    • Edited by pollewops Tuesday, May 24, 2016 9:19 AM
    Tuesday, May 24, 2016 9:14 AM
  • Did you ever find a solution to this? we have been having the same issue and the only thing that seems to fix the issue is to use a Ethernet dongle..I have updated all drivers , dock changed the power settings etc.

    any help would be greatly appreciated!

    thanks so much


    Jennifer

    Thursday, January 19, 2017 7:16 AM
  • I would also like to know if the issue is solved.

    The Surface Dock keep failing randomly throughout the day.
    Any one?

    Friday, March 17, 2017 2:39 AM
  • Well, a year and a half since the original post, and a widespread issue relating to Ethernet connectivity drop outs on a piece of kit branded with Microsoft goes on ignored?  I thought when I got the latest Surface Pro, that this would have surely been investigated.  It seems not.  Very disappointing.
    Monday, July 24, 2017 12:25 AM
  • WOW, I had a well setup Surface pro with the dock that worked perfectly fine for nearly a year, But just 2 months back I faced the same problem as above. Microsoft diagnosed the machine but found no problem and told me to get the dock replaced. I got that done (thank God it was free). But that did not solve the problem. Today, I received my refurbished Surface pro (again, thank God I had a extended warranty plan) and I am busy setting up the same and started to get the same problem but with a lesser frequency. YES, the battery is 100% and the dock is disconnecting after nearly every 4 minutes. MICROSOFT pls help.
    Wednesday, September 13, 2017 7:14 PM
  • Had simular problem...

    Possible solution.

    Go to Network and sharing centre > Change adapter properties > Surface Ethernet Adapter > Properties > Configure > Advanced

    Disable - Energy Efficient Ethernet
    Disable - Selective suspend

    Seems to have fixed problem - Ethernet up for 46 hours - no dropouts

    Happy bug squishing!

    Note: still cannot get to operate at 1000Base-T Gigabit speeds, seems to be limited to 100 mbps.

      

    Wednesday, October 4, 2017 3:56 AM
  • hi, I have the same issue, I have updated the DOCK & SURFACE to the latest firmware BUT it seems after the latest Feb 2018 Cumulative it has happened again.  Microsoft need to sort this issue out, it's affecting people.

    @salkillen, I will try your solution now.

    Thanks

    Friday, February 16, 2018 9:44 AM
  • Having same issue.  Screen did it for a long time, now the ethernet is dropping me every few minutes.  Started after an upgrade I suspect.  Began noticing it around late January or early February 2018.

    Friday, February 23, 2018 8:19 PM
  • Same problem here using a Surface Book2 and surface dock as a trial machine in our business. This issues is preventing us from deploying surfaces throughout our office.
    Wednesday, March 7, 2018 10:32 PM
  • Having the same issue with numerous Surface 4's and docking stations that we just purchased. If we take the network cable out of the dock and run on the wireless, everything works fine, no disconnects. I found a blog that a user had posted with the following changes to the Ethernet adapter card and it resolved our issues with the  intermittent network disconnects.

    • Open Network and Internet settings
    • Click on Change adapter settings
    • Control Panel\All Control Panel Items\Network Connections
    • Right click on the Ethernet
    • Click Properties
    • Click on Configure
    • Click on Advanced
    • Click on Energy Efficient Ethernet and set to Disable
    • Click on Selective suspend and set to Disable Disable
    • Click on OK
    • Restart Surface

    Thursday, March 8, 2018 1:28 PM
  • I just wanted to say I had the exact surface dock issues with a Surfacebook 2 15 inch and a surface dock having intermittent connection issues and dropping it all completely, basically restarting the connection. It would happen mostly when under network load such as downloading.  I changed the setting above on disabling the two surface dock network settings and it instantly fixed the issue so far. *Crossing Fingers* I will remember this if I run across the issue again on another surface product.
    Monday, March 12, 2018 3:36 PM
  • We rolled out 50 Surface Pro 3 with the clamp docking station and some Surface Pro 4 with the Brick docking station about 3 years ago.  If you move the machines from one docking station to another you often can't get an valid IP address.  Appears to be something to do with the the docking stations as you can plug the same ethernet cable from the back of the docking station directly into a laptop and up pops the connection no problem.  Still trying to find a solution.  We also had "Battery failures" but that was a firmware issue.  The expensive detachable keyboards don't last too long and if you do have a problem its back to Microsoft everytime as it can't be fixed in the field.  Would I go down this route again for a business again, No, and I'm looking to refresh already.  plently of thin form laptops available.  Infact a couple of users now have a Dell Laptop and I dont have any support issues.  Think carefully, thats all I can say.

    The latest machines maybe a better bet though. (we wont go down that route though after this experience)


    • Edited by ChrisSK Thursday, April 19, 2018 1:11 PM
    Thursday, April 19, 2018 1:11 PM
  • I've tried everything discussed here and my surface book2+dock (both with all updates) disappears from the Ethernet network every few seconds. I barely have time to copy a few files and it dies, so I must rely on slow WIFI at 1995 speeds. I can't believe Microsoft cannot fix this! The only support option I see is to mail them the laptop back..!? I am not please with my $3800 purchase.
    Sunday, July 22, 2018 3:10 AM
  • Your solution partially fixed my problem as well.

    Should be 200mbps but I'm topping out at 140.

    Anyway, huge improvement for now. Thank you

    Friday, August 3, 2018 1:26 AM

    • Go to Device Manager as Admin (devmgmt.msc
    • Network Adapters --> Surface ethernet adapters. Go to properties --> Advanced. Disable Energy Efficient Ethernet and Selective suspend.

    I have applied it to a few users and result is 100%. Right now Microsoft does not have a fix for it.



    Thursday, November 1, 2018 2:21 PM
  • I had my surface pro 4 with dock working perfectly. Then we moved. Couldn’t get the monitors to work. Just switched the dock power supply from a smart strip to the battery backup. Voila, both screens are now up and running. For what it’s worth.
    • Proposed as answer by rdcsfd Sunday, April 28, 2019 11:59 PM
    Sunday, April 28, 2019 11:59 PM