Windows 8.1 RTM Apps Crash on Launch RRS feed

  • Question

  • Since a few days, several 'modern' apps (including Mail, Skype, News, Calendar) are crashing when launching them.

    The event log shows the following errors:

    Event 54, AppModel Runtime

    Modification was detected in package Microsoft.SkypeApp_2.0.0.5011_x86__kzf8qxf38zg5c (C:\Program Files\WindowsApps\Microsoft.WinJS.2.0_1.0.9600.16395_neutral__8wekyb3d8bbwe\css\ui-light.css).

    Event 59, AppModel Runtime

    App Integrity terminated an application. Integrity check for microsoft.windowscommunicationsapps_17.4.9600.16384_x64__8wekyb3d8bbwe returned 0.

    I am not aware of any changes to my installation (except the regular Defender updates and a few new drivers over the past couple of days.

    How can this be fixed?

    Tuesday, September 24, 2013 5:15 AM

All replies

  • Hi,

    Firstly, If you have not tried system restore, I suggest you have a try to check if we can get rid of this problem.

    How to restore, refresh, or reset your PC:


    If it doesn't work, I suggest you run Application troubleshooter to check the result.

    Run Application troubleshooter:

    Download and run the Modern UI App troubleshooter and check.


    Meanwhile, try to reset Store Cache and check if it helps.

    1. Press Windows key + Q.

    2. In the Search box type WSReset.exe and hit enter.

    That should reset your cache for the store.

    If the issue persists, we try to modify the setting below to test it.

    1.open Control Panel>>Language>>Change date, time, or number formats.

    2.In Region dialog box, change the Long time and Short time to anything that doesn't have "tt" in it.



    TechNet Community Support

    Wednesday, September 25, 2013 2:33 PM
  • Hi Kevin,

    Thank you for your response. I tried everything you mentioned except the PC refresh (I am a bit hesitant here, because it looks like I'd need to reinstall all non-modern apps, Office etc), but with no success. If there are no other ideas how to track this issue down I'll do that though.


    Wednesday, September 25, 2013 3:32 PM
  • Hi Kevin,

    I had refreshed my PC, and it worked for a few weeks. Right now, this issue occurred again, after an update to the 'Maps' application was installed through the store. I tried all the steps mentioned by you (except the refresh), but it doesn't work - any idea? I don't really want to do a refresh again (always a few hours to get everything up and running again)


    Saturday, October 12, 2013 7:09 AM
  • Hi,

    According to your description, I suggest you try system restore to check if we can get rid of this problem.

    How to restore, refresh, or reset your PC


    If the issue persists, I suggest you uninstall the Map app and reinstall it.

    Hope these could be helpful and keep post.


    Wednesday, October 16, 2013 3:00 AM