locked
SQL Server 2012 Upgrade from 2008 R2 > Error due to no SSL on reporting services website RRS feed

  • Question

  • Hello

    I have just tried to upgrade SQL Server 2008 R2 to SQL Server 2012 and it seemed to be going well until I got an error about 2 thirds of the way through saying something like:

    Error: A Secure Sockets Layer (SSL) certificate is not configured on the Web site

    It then completes with ticks next to everything except for Reporting Services which has a cross.

    Upon further reading it seems I could have avoided this by installing an SSL certificate on the website prior to the upgrade.

    So now Reporting Services doesn't seem to be installed (there is nothing under default website).

    However if I re-run the installer it is ticked to indicate it is already installed and if I choose the upgrade option it tells me there are no components remaining which can be upgraded.

    So I'm not sure how I can fix this.

    I could uninstall the feature and re-install it but not sure if that is the best option.

    I have added an SSL binding to the default website.

    Thanks for any help.

    Robin


    Robin Wilson

    Tuesday, March 13, 2012 12:12 PM

All replies

  • I have now tried detaching all the databases and uninstalling SQL Server 2012.

    SQL Server 2008 R2 still seemed to be installed too with all the shared features even though it was supposed to upgrade everything so I removed all traces of that too and then once everything was gone from Programs and Features I removed what was left of the SQL Server folders in Program Files and Program Files (x86).

    I then did a full new install of SQL Server 2012 and it said it had completed successfully this time with no warnings or errors.

    However reporting services is still not present even though I chose to install and configure it in native mode during setup.

    If I go to https://server/reports I get a 404 error and looking in IIS there are no virtual directories under the default website.

    If I go to http://server/reports it redirects to https://rws-db1/Reports/Pages/Folder.aspx but this also gives a 404.

    Before being forced to wipe the whole server and start again does anyone know of a way to fix this?

    Thanks

    Robin


    Robin Wilson

    Friday, March 16, 2012 1:51 PM
  • After further reading it appears that Reporting Services doesn't use IIS and after disabling IIS I can get to reporting services by going to the FQDN address (https://server.domain.com/reports).

    However it seems to be using basic authentication as it pops up a box asking for the username and password.

    Is there any way to get it to use NTLM and to be accessible using the old links (http://server/reports)?

    Looking in the rsreportserver.config file it only has RSWindowsNTLM listed so I'm really not sure what's up with it.

    Any help would be appreciated.

    Thanks
    Robin


    Robin Wilson

    Friday, March 16, 2012 5:00 PM