none
R script errors out in high load RRS feed

  • Question

  • I have a model trained as a web service. When running a high load with multiple predictions in batch, and try to run a stand alone single prediction through an online app, I get the following failure

    2019-03-15 07:30:08 - U02012003 1 row(s) affected
    2019-03-15 07:30:08             A 'R' script error occurred during execution of 'sp_execute_external_script' with HRESULT 0x80004004.
    2019-03-15 07:30:08 - U02004025 Job-script execution was aborted.
    2019-03-15 07:30:08 - U02012006 SQL Rollback executed

    The CPU is only at 15% and only 12G out of 64G is used on the ML server (SQL 2017)

    Is it a question of web nodes or compute nodes not being available?

    Any help is greatly appreciated. we have this issue in production


    ramesh bala

    Sunday, March 17, 2019 5:45 PM

All replies

  • Unfortunately, you will need to debug your R code line-by-line to find the problem. Somewhere in your R code one of the statements in causing a problem with running the script or you are doing something that can't done that way when running as a web service.

    My suggestion would be that you try and isolate which line in the code is causing the problem, by individually removing lines from your R script. 

    If you can isolate which line is causing the problem you can attach a short reproduce script to this post and we can look further into the problem for you.

    Thursday, March 21, 2019 4:09 PM