none
LDAP Query for Email Address RRS feed

  • Question

  • Hallo,

    I have a Network Multi Function Printer, once i select users from Active Directory LDAP it Comes out two email address local and the Primary how can i filter the query to select only the email address under the user properties General.

    the current query is 

    (&(department=IFD XXXXXX)(!(userAccountControl:1.2.840.113556.1.4.803:=2)))

    thanks 


    Safwat

    Thursday, January 10, 2019 2:26 PM

Answers

  • The attribute on the "General" tab of ADUC user properties is "mail". This is labeled "E-mail" in the ADUC GUI. I think you want to retrieve the mail attribute, rather than filter on it. But to add a filter clause involving the mail attribute, you would use a filter similar to:

    (&(department=IFD XXXXXX)(!(userAccountControl:1.2.840.113556.1.4.803:=2))(mail=username@domain.com))

    Otherwise, retrieve the value of the mail attribute.


    Richard Mueller - MVP Enterprise Mobility (Identity and Access)

    • Marked as answer by Safwat Mosali Thursday, February 21, 2019 9:15 AM
    Thursday, January 10, 2019 2:53 PM
  • Hallo,

    it is working thanks after restarting the printer


    Safwat



    • Edited by Safwat Mosali Thursday, February 21, 2019 9:15 AM
    • Marked as answer by Safwat Mosali Thursday, February 21, 2019 9:15 AM
    Monday, January 21, 2019 8:26 AM

All replies

  • The attribute on the "General" tab of ADUC user properties is "mail". This is labeled "E-mail" in the ADUC GUI. I think you want to retrieve the mail attribute, rather than filter on it. But to add a filter clause involving the mail attribute, you would use a filter similar to:

    (&(department=IFD XXXXXX)(!(userAccountControl:1.2.840.113556.1.4.803:=2))(mail=username@domain.com))

    Otherwise, retrieve the value of the mail attribute.


    Richard Mueller - MVP Enterprise Mobility (Identity and Access)

    • Marked as answer by Safwat Mosali Thursday, February 21, 2019 9:15 AM
    Thursday, January 10, 2019 2:53 PM
  • Hallo,

    it is working thanks after restarting the printer


    Safwat



    • Edited by Safwat Mosali Thursday, February 21, 2019 9:15 AM
    • Marked as answer by Safwat Mosali Thursday, February 21, 2019 9:15 AM
    Monday, January 21, 2019 8:26 AM