How to upgrade Blogical SFTP adapter to Biztalk 2016 RRS feed

  • Question

  • Hi All,

    We are working on Biztalk upgrade from Biztalk 2010 to Biztalk 2016, one of the Interface is using Blogical SFTP adapter in Biztalk 2010, 

    I know Biztalk 2016 has out of the box SFTP adapter, but we still want to use Blogical SFTP adapter in Biztalk 2016,

    Can some one provide me the installation file of Blogical SFTP adapter, which we can use in Biztalk 2016?



    Monday, July 8, 2019 6:22 AM

All replies

  • Why do you still want to use the BLogical.

    2016 SFTP adapters are supported MS adapters. Its always good to use that unless there is some feature that MS adapter does not provide


    Blog: My Blog

    BizTalkApplicationDeploymentTool: BizTalk Application Deployment Tool/

    Monday, July 8, 2019 11:26 AM
  • Hi,

    We want to use Blogical SFTP adapter vs Biztalk SFTP adapter, since it has some features which is required for our project, where those features are not provided by Biztalk SFTP adapter,



    Monday, July 8, 2019 12:32 PM
  • Which features does Blogical SFTP adapter has that is missing with the out of the box SFTP (after applying the latest CU / Feature Pack)?  CU 6 added Read Only functionality as well as fixing some issues.

    Have you tried installing the Blogical SFTP adapter on BizTalk 2016?  What issues / errors did you encounter.

    Have you tried downloading the source code from GitHub and updating it to .Net 4.6 or 4.7 and recompiling?

    Monday, July 8, 2019 9:37 PM
  • You can find the source at GitHub'


    When asking a question please be as thoroughly as possible this will make it easier to assist you

    Sunday, July 21, 2019 11:47 AM
  • Blogical SFTP supports more SFTP servers than the native adapter, or have less bugs.

    I've been struggling for one day to get the native adapter to delete the files after they are downloaded. About one third of the files are deleted. If they are not deleted the adapter will hang until the host instance is restarted.

    According to other official Microsoft pages the built in adapter will support any server that WinSCP supports but this is not the case. WinSCP UI works very well with MOVEit's SFTP server but the built in SFTP adapter does not, it doesn't even support fingerprint that start with "ssh-rsa 2048" so I am forced to use them both.
    Wednesday, October 9, 2019 11:59 AM
  • Jonas, what version of BizTalk and CU are you talking about? If you are talking about anything before BizTalk 2016 with CU 6, then yes there were a number of know issues and limitations.
    Wednesday, October 9, 2019 7:03 PM