sb-messaging adapter failing RRS feed

  • Question

  • I'am struggling with a problem with the sb-messaging adapter. 

    I have created one sb-messaging adapter that sends messages to a topic on azure service bus that seems to work fine. When I setup a second similar adapter to send messages to a topic on another servicebus (with same confiuration as the first one) I get the following error:

    A message going to a one-way send port is being suspended. Reason:The send port configuration corresponding to the message was not found. 
     This usually happens when a send port was deleted while it still had some active messages.

    I'am totally sure that I have not deleted any send ports with active messages. There are also no other errors or warnings in the event log that I can relate to this. The first sb-messaging adatper works fine so I'am really confused.

    Below is System information and software installed.

    Windows - Windows server 2012 R2 on a virual machine in Azure 

    Visual Studio - Professional 2013

    SQL Server - SQL Server 2014 Enterprise Edition with SP1 

    BizTalk Server - BizTalk 2013 R2 Developer Edition (I have tried to install both CU1 and CU2 but it doesn't seem to solve the problem)

    I would really appreciate any help on this.



    Thursday, May 12, 2016 8:44 AM

All replies

  • Hi Jarl,

    This very well could be an SSO issue.  Are you getting any SSO errors in the event log?  Intermittent SSO issues could cause the inconsistent results you are seeing.   

    Of course, as the port configuration is stored in the SSODB, if access to this database is restricted port configuration cannot be accessed and so the message could not be delivered.


    Also, try changing the send handler to run under different host instance and restart the SSO service.

    Rachit Sikroria (Microsoft Azure MVP)

    Thursday, May 12, 2016 8:48 AM
  • Hi Rachit,

    There is no SSO errors in the event log. I have tried to run it under a different host instance but it doesn't seem to help. The strange thing is that the first sb-messaging adapter I created is running on the same host instance without any issues.

    On another virtual machine I faced the same problem when setting up the second sb-messaging adapter. On that machine I unistalled both biztalk and deleted both the biztalk database and the SSO database and reinstalled everything from scratch. For sb-messaging adapters on this machine I constantly get the same error "A message going to a one-way send port is being suspended".

    Can there be some naming confusing when I create more than one SB-messaging adapter? Do you know if there are some configurations that are not stored in the database but in the registery that can affect this?

    Thursday, May 12, 2016 9:25 AM
  • Hi Jarl,

    I know this is an old thread, but would you remember how you would have fixed this?


    Wednesday, April 4, 2018 12:00 PM
  • can you use SAS for authentication on the sb-messaging adapter in BTS 2013 R2?
    ACS is deprecated on Azure as we speak

    Might be related with your issue?


    Wednesday, April 4, 2018 12:37 PM
  • I'm struggeling with the same problem. I re-installed BizTalk and still get the same error message. Did you find any solution to this? (BizTalk 2016, Win Srv 2016).
    Thursday, November 29, 2018 2:43 PM
  • Hi,

    is there any update to this issue? Exactly the same error for me in three environments. I changed the host, the queues, recreated ports, always the same error.

    Tried to send from the same machine with a small dotNet program and everything works. So there must be some issue with the biztalk adapter.

    Any hints?

    Thank you,

    Thursday, October 17, 2019 4:16 PM
  • I am having the exact same issue as well. Did anyone manage to solve this problem.


    Friday, January 31, 2020 2:22 PM