none
Sequencing SAP Business Explorer with Office 2016 RRS feed

  • Question

  • Hello,

    I'm having a bit of a nightmare.  I am trying to sequence SAP BEX Analyzer 7 with the latest patch (10) using App-V 5.1 on a Windows 10 machine.  The way it works, when loading the Analyzer, Excel 2016 should load and load up the BI Addon.  This is working absolutley fine on the Sequencer, however, when I then publish it to my own Windows 10 VDI, if I click the icon, it starts an Excel process but nothing comes up, no splash screen for Excel, nothing.  The process never stops and I have to manually kill it using task manager.

    The Office installation is local to the machine, not virtualised.

    Does anyone have any ideas please ? 

    I've tried enabling and disabling local system interaction but it makes no difference.

    Thank you,

    Daniel


    • Edited by Mr-DPG Thursday, December 8, 2016 11:15 AM
    Thursday, December 8, 2016 11:13 AM

Answers

All replies

  • Are you using Office 2016 VL, or O365?

    What are your COM -and Named Objects Isolation settings? For BEX you need the default settings (SAP itself needs integration settings with Objects enabled).


    Roy Essers

    Saturday, December 24, 2016 12:13 PM
  • Hello,

    Sorry for the delay in reply. 

    We are using O365. Moved recently.

    I have been leaving all COM and named object settings as they are, i.e. unticked.  As you say SAPGUI itself needs those ticked, but I know that it does break BEX if they are ticked.  I just tried enabling them at one point in desperation.

    The frustration is how it works when on the sequencing machine but not when published proper.  

    When sequencing it is a blank Windows 10 image that has 2016 installed but not activated.  So before I begin to package I load Excel and give it my account to let it activate first, close it again and then I start the sequencing process.

    Thanks,

    Daniel


    • Edited by Mr-DPG Thursday, January 12, 2017 2:35 PM
    Thursday, January 12, 2017 2:33 PM
  • I'm running it on Windows 2016 with Office 2016, and it runs just fine:

    http://pasteboard.co/m84SOuDV1.png

    My guess is W10 or 2016 wouldn't make that big of a difference. However, what most people seem to forget with App-V 5.1 is package cleanup. App-V 5.1 and addins is very tricky. You really need to clean up any MS related registry keys and files or else it will break. Especially when you are running connection groups.

    This is what my package looks like after editing:

    http://pasteboard.co/m8880dZpN.png

    http://pasteboard.co/m88PRcdMz.png

    http://pasteboard.co/m89df7AxE.png

    It works fine with no adjustments on Office 2010, 2013 & 2016.

    Btw I was working on a blog how to sequence SAP:

    https://appv.recipes/index.php/2017/01/14/sequencing-sap-gui-7-40-with-app-v-5-1/

    Saturday, January 14, 2017 10:32 PM
  • Hello,

    Did you manage to figure this out?

    Wednesday, June 6, 2018 10:57 AM
  • TodorS, did you set the COM and named objects as I suggested?

    Roy Essers

    Wednesday, June 6, 2018 6:02 PM
  • Hi Martijn,

    Did you release the "sequencing-sap-gui-7-40-with-app-v-5-1" paper?  or by any chance a new version of your recipe for SAP GUI 7.60 and SAP Secure Logon client 3.0??

    If so, can you please send me a copy?

    shaun@wimpory.co.nz

    Regards

    Shaun

    Wednesday, July 17, 2019 8:38 AM