Exception has been thrown by the target of an invocation. RRS feed

  • Question

  • I'm currently getting this error when I try to launch SSMS. Here is my install scenario:

    1. Installed VS2010 Premium.

    2. Applied VS2010 SP1.

    3. Installed Windows7 SP1.

    4. Installed SQL2012 RC0 with the following:

    - Database Engine Services + SQL Server Replication

    - Management Tools - Basic + Management Tools - Complete

    Note: I specifically excluded SQL Server Data Tools (SSDT)

    5. Installed SSDT CTP4.

    6. Reapplied VS2010 SP1.


    At this point, everything was working fine. I was able to launch VS2010, SSMS and created databases, etc. However, I wanted to use the Database Project/EF integration features, so I needed to install VS2011 Preview.


    7. Installed VS2011 Preview.


    After the installation, there was a SQL Server "installation" error, but I ignored it with the thought that it was related to the fact that I already installed RC0.

    At this point, I was able to launch VS2011, and exercise the integration features I wanted to play around with. After doing a couple of model-to-database and database-to-model syncs, I wanted to check it out on the actual database. So, I tried to launch SSMS. This is when I was getting the error.

    Since this error, I have tried the following without resolution:

    - Reapply VS2010 SP1.

    - Uninstall SQL Express (the one that was installed by VS2011), but this uninstall failed.


    Has anyone encountered this, and does anyone have any suggestions of how to resolve it. My goal is to run VS2010, VS2011, SQL2012RC0 side-by-side, with the ultimate goal of using the Database Project integration features.




    Tuesday, November 29, 2011 4:48 PM

All replies

  • Hey Jayson,

    I am having the same problem. I followed about the same installation order as you and I receive the same error message as you. I think the problem is the .NET version that is supplied with VS2011.

    Before this fresh install of Windows 7 I tried installing SQL 2012 RC0 AFTER installing VS2011, but that gave me installation errors. Googling on those errors showed me that certain patches to .NET 4.0 could not be applied (KB2544514 and KB2533523).

    When you first install SQL 2012 before VS2011 those patches will be applied with no problem, but repairing the SQL install AFTER the VS2011 installation gave me the same errors again (those two KB's could not be applied).

    Did you have any luck getting it working again?



    Saturday, December 3, 2011 7:00 AM
  • Hi Jayson and Wim,

    No need to un-install and install the products, please follow my blog post.




    Vidya Vrat Agarwal. http://dotnetpassion.blogspot,com
    Monday, February 6, 2012 6:18 AM
  • yes it works ... thanks Vidya Vrat
    • Edited by Gurprem Wednesday, February 8, 2012 3:57 PM
    Wednesday, February 8, 2012 3:52 PM