locked
Migrating from SBS 2011 to Server 2016 with Exchange 2016 RRS feed

  • Question

  • Hello,

    I have set up a test network to plan for moving my client from SBS 2011 to Server 2016 with Exchange 2016. I have been using the guides from SBS Susan that points to Techgenix as well as a similar guide on MSExpertTalk. Everything has been going fine until I get to the "Update the internal DNS record to point to the Exchange 2016 server". Both guides have me change the autodiscover and mail record on the DNS server to point to the new Exchange 2016 server. The issue I am running into is there are no mail or autodiscover records in the DNS server pointing to the Exchange 2010 server to update. The instructions I am following are for moving a 2010 Exchange server that is not part of SBS, so I am assuming there is something a little different in SBS and are stored elsewhere?

    Any assistance is greatly appreciated.

    John

    Wednesday, July 22, 2020 3:26 PM

Answers

  • Just want to update and close this issue.

    It turns out that it was operator error.

    I was updating the DNS records on the new DNS server (the new 2016 AD DC) but everything was pointing to the old DNS server (the one in SBS 2011).

    Anyway, after I made this discovery and updated everything went as expected.

    Thanks for your time.

    John

    • Marked as answer by John Anemone Thursday, July 23, 2020 9:54 PM
    Thursday, July 23, 2020 9:54 PM

All replies

  • Hi,

    in an environment where there is only one Exchange server and any device accessing it is a member in AD, there's no need for any additioal DNS namespaces or records for Exchange. Outlook will pull the Autodiscover SCP (pointing to the server FQDN) from AD, and Autodiscover will point the client to the server FQDN as well.

    That said, I seem to remember that SBS did create namespaces in the external DNS zone (remote.company.com etc.) That's where there record you were instructed to modify would be. If there aren't any, you're good ;-)


    Evgenij Smirnov

    http://evgenij.smirnov.de

    Wednesday, July 22, 2020 3:50 PM
  • You need DNS record in the public space for:

    • SRV record like _autodiscover._tcp.domain.com 0 0 443 mail.domain.com
    • A record for mail.domain.com that has your public IP address
    • Cname record for autodiscover.domain.com -> mail.domain.com

    On your local DNS server create a zone for mail.domain.com and create an empty Host A record with the local IP address of your EX2016

    On the certificate you will use on your new EX2016 you need domain.com, mail.domain.com and autodiscover.domain.com.

    During the migration and after the EX2016 has been fully configured you need to forward traffic for port 443 and 25 to the internal IP address of your EX2016.

    If setup properly EX2016 will down proxy connections to the 2010 server if a mailbox has not been migrated.

    In addition to this you must set SCP on the SBS to the URL for the EX2016. Do this also for autodiscover


    Mariëtte Knap [alumna Microsoft SBS MVP]
    www.server-essentials.com | Linkedin | Migrations done the easy way | DNN MVP 2019

    Wednesday, July 22, 2020 5:22 PM
  • Hi Evenij,

    I am prepping to move from Exchange 2010 to 2016. So I am adding a 2nd Exchange server. Migrating the users from the 2010 to the 2016. The SBS box has functioning correctly up to this point ( I am testing this with a VDX of the actual server); all of my DNS public records are set. The issue I am having is the Internal DNS on the SBS box (as well as the mock 2016 Domain Controller I also created). Just after installing the Exchange 2016 I updated the SCP (per the instructions on both of the sites I mentioned earlier).

    The issue is that when I try to navigate to the new Exchange server I can only get to it by using it's name (ie Exchange2016.domain.local

    If I attempt to connect to it using the internal url (mail.domain.com/owa) it connects me to the 2010 Exchange server and errors out as the mailbox is not on that server.

    I manually created the mail and autodiscover records that the instructions require and they are pointed to the new Exchange (2016) server, but I still connect to the old Exchange (2010) server.  

      

    Wednesday, July 22, 2020 6:28 PM
  • If I attempt to connect to it using the internal url (mail.domain.com/owa) it connects me to the 2010 Exchange server and errors out as the mailbox is not on that server.

    If you ping that domain do you get the correct IP address in return?


    Mariëtte Knap [alumna Microsoft SBS MVP]
    www.server-essentials.com | Linkedin | Migrations done the easy way | DNN MVP 2019

    Wednesday, July 22, 2020 6:55 PM
  • Hi Mariette,

    No, I get the ip address of the 2010 server. I started following the steps in assistants.microsoft.com; when I get to the step to enable and configure Outlook Anywhere but I am still running into the same issue. All requests go to the 2010 Exchange. Currently rebooting the servers and am going to try again.

    Wednesday, July 22, 2020 8:14 PM
  • Hi John, 

    After confirmed with our exchange engineer, your issue is more related with Exchange. We recommend to create a new thread on Exchange forum, as they are more familiar with your issue. 

    If my information is useful for you, please mark it as answer. 

    This "Small Business Server" Forum will be migrating to a new home on Microsoft Q&A, please refer to this sticky post for more details.

    Bests, 


    "Small Business Server" forum will be migrating to a new home on Microsoft Q&A!

    We invite you to post new questions in the "Small Business Server"  forum's new home on Microsoft Q&A!

    For more information, please refer to the sticky post.
    • Edited by Joy-Qiao Thursday, July 23, 2020 2:57 AM
    Thursday, July 23, 2020 2:56 AM
  • Just want to update and close this issue.

    It turns out that it was operator error.

    I was updating the DNS records on the new DNS server (the new 2016 AD DC) but everything was pointing to the old DNS server (the one in SBS 2011).

    Anyway, after I made this discovery and updated everything went as expected.

    Thanks for your time.

    John

    • Marked as answer by John Anemone Thursday, July 23, 2020 9:54 PM
    Thursday, July 23, 2020 9:54 PM