locked
Exchange 2016 Post Install Can't access ECP : Invalid Username or Password RRS feed

  • Question

  • Hello,

    I'm stuck on this problem for 2 days and I can't seems to get over it.

    I'm installing Exchange 2016 in a new environment, Dell server with Windows Server 2012 R2 Std, with AD on a different Windows Server 2012 R2. Forest functionnality is Windows Server 2012.

    All the prerequisites were matched, I got no errors at Exchange Installation, Server is Up to date, I can access https://exchange/ecp (that redirects me to owa), but I Can't log in with an admin account that I used to install Exchange, I always get the "Invalid username or password".

    I tried creating new users with Admins rights, tried reset Authentication, tried reser Virtuals Directories, tried recreate a new Exchange certificate, nothing works.

    When I get on owa directly though, if i put the good password i got an 500 Error (So no AD problems supposedly).

    I really need help since I don't know where to search anymore. I can provide any informations you'll need.

    Thank you

    Clement

    Thursday, June 16, 2016 7:48 PM

Answers

  • Okay I gave up and I installed Exchange 2013. Problem solved.
    • Marked as answer by Expert SA Tuesday, June 21, 2016 10:02 AM
    Tuesday, June 21, 2016 10:02 AM

All replies

  • Hi Clement,

    For your description, I know that failed to login ECP with 500 error.

    Can you login EAC with domain administrator by "https://localhost/ecp"?

    If this issue remain exists, please confirm:
    1. Ensure all Exchange services works fine.
    2. Open IIS and the Application Pools to view whether ECP Application Pool is running on .NET Framework v4.0.
    3. Run "Get-Mailbox -Arbitration" to check SystemMailbox{bb558c35-97f1-4cb9-8ff7-d53741dc928c} exist.

    If the mailbox was deleted but the AD account still exists, please run below command to enable: Enable-Mailbox "SystemMailbox{bb558c35-97f1-4cb9-8ff7-d53741dc928c}" -Arbitration
    If the AD account was deleted, please run: Setup /PrepareAD first, then run Enable-Mailbox to enable.

    Moreover, here's a similar thread and blog about this issue, for your reference:
    https://social.technet.microsoft.com/Forums/exchange/en-US/777b51ee-330d-43cc-a56e-4614d44aed7b/unable-to-access-owa-or-ecp-something-went-wrong-or-500-unexpected-error?forum=exchangesvrclients
    http://social.technet.microsoft.com/wiki/contents/articles/31044.exchange-2013-unable-to-access-ecp-encounter-500-unexpected-error.aspx


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Allen Wang
    TechNet Community Support

    Friday, June 17, 2016 5:12 AM
  • Hi Allen,

    Thanks for you help.

    All the Exchange services looks good, all running except Notifications Broker and IMAP/POP.

    On IIS ECP and OWA App Pool are correctly running on v4.0.

    The System Mailbox is correctly created and in AD.

    I tried your 2 topics but none of the actions seems to do the trick..

    Thank you

    Clement

    Friday, June 17, 2016 8:30 AM
  • Hi Clement,

    Do you have the mailbox enable for the administrator account. please try to run this command from exchange powershell:-

    enable-mailbox "administrator" and try to login on the ECP page.

    and also please make sure you have added to Organization management group in AD which used to create once you setup the exchange first time.

    Friday, June 17, 2016 10:19 AM
  • may be similar to a problem I had to troubleshoot recently - see here for the fix that worked for me:

    https://community.spiceworks.com/topic/514617-exchange-2013-unable-to-login-to-owa-ecp

    Friday, June 17, 2016 10:42 AM
  • Hello,

    Yes My Administrator account has a mailbox, I tried again by doing

    Disable-Mailbox Administrator

    Enable-Mailbox Administrator

    And it still doesn't work. The account is in the Organization Group.

    Thank you

    Friday, June 17, 2016 10:47 AM
  • I tried that again fmason but with no luck.

    I read on this topic :

    https://social.technet.microsoft.com/Forums/fr-FR/3258b6b6-4bcd-4149-b65d-043693e9c644/how-to-reset-exchange-2013-ecp-admin-page-broken?forum=exchangesvradmin

    That we shouldn't do Remove-OwaVirtualDirectory -Identity "EXCHANGE\owa (Exchange Back End)"

    And I think among all the commandlines I've entered I may have entered this one. Will it changes something ? I tried redo Remove-WebApplication and New-WebApplication though.

    Thanks

    • Edited by Expert SA Friday, June 17, 2016 11:00 AM
    Friday, June 17, 2016 10:58 AM
  • Can you check the event logs from MS exchange front end HTTP proxy? Have you tried configuring outlook if that's just the problem with OWA/ECP virtual directory?

    Can you provide the output for:-

    get-Owavirtualdirectory -identity "E15MBX\owa (Exchange Back End)" |fl 

    Get-ECPvirtualdirectory -identity "E15MBX\owa (Exchange Back End)" |fl 

    Thanks,

    Friday, June 17, 2016 11:23 AM
  • Well It'll be prefered if I could have access to ecp, it'll be a bit easier after the install.

    I didn't tried to configure Outlook for now.

    In the MS Exchange Front End HTTP Proxy I only got 1001 (starting) and 1002 (shutting down) events.

    The 2 commandlines tells me :

    "The Operation couldn't be performed because object "EXCHANGE\owa (Exchange Back End)" couldn't be found on 'dc.domain.local' "

    But If I do : NewEcpVirtualDirectory -InternalUrl "https://exchange/ecp" -WebsiteName "Exchange Back End"

    I got this error : "The Active Directory configuration for the virtual directory "ecp" is already existing in «CN=ecp (Exchange Back End),CN=HTTP,CN=Protocols,CN=EXCHANGE,CN=Servers,CN=Exchange Administrative Group (FYDIBOHF23SPDLT),CN=Administrative Groups,CN=cabinetph,CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=domain,DC=local»"


    Delete this Active Directory configuration manually

    • Edited by Expert SA Friday, June 17, 2016 12:09 PM
    Friday, June 17, 2016 12:07 PM
  • Does anyone have any ideas ?

    I'm stuck on this problem, even after a fresh install, and I really need to end this installation fast now...

    Thanks

    Monday, June 20, 2016 11:44 AM
  • Okay I gave up and I installed Exchange 2013. Problem solved.
    • Marked as answer by Expert SA Tuesday, June 21, 2016 10:02 AM
    Tuesday, June 21, 2016 10:02 AM
  • I have the same problem, I have a 2010 exchange server in the environment and I decided it is time to upgrade to 2016, unfortunately ECP is not accepting the administrator user name or password!

    It seems that it is trying to load from the 2010

    Anyone can help?

    Thank you

    Wednesday, August 15, 2018 2:54 PM