locked
BAM Portal Website - Asking for Windows Credentials RRS feed

  • Question

  • I have a problem when I try to browse the BAM Portal Website. It's asking for Credentials (Windows Authentication) and even though I enter the correct credentials, the credentials window keeps popping up. I'm using the same credentials which administers the Application Pool for this portal and is the same account that was used for BizTalk Configuration of BAM Portal.

    Question 1 - Why does it ask for credentials, which I believe it should not?

    Question 2 - Why does it not accept the credentials?

    I have set up the Authentication to be "Windows Authentication" for this portal. Portal is set up under "Default Website" and is of course accessed using http: //localhost/bam

    Please help.

    Thursday, May 30, 2013 8:34 PM

Answers

  • If windows authentication is setup and you are using IE then it should not prompt. Check you .NET Authorization Rules in IIS for BAM virtual directory. Most likely it is denying you access to db. You can edit these rules to allow you or required people
    • Marked as answer by Venky Pai68 Monday, June 3, 2013 6:35 PM
    Thursday, May 30, 2013 8:51 PM

All replies

  • If windows authentication is setup and you are using IE then it should not prompt. Check you .NET Authorization Rules in IIS for BAM virtual directory. Most likely it is denying you access to db. You can edit these rules to allow you or required people
    • Marked as answer by Venky Pai68 Monday, June 3, 2013 6:35 PM
    Thursday, May 30, 2013 8:51 PM
  • You have not mentioned the version of the IIS. Anyhow you can try these suggestions.

    If this is IIS7.0/7.5 then in authentication make sure that ASP.Net Impersonation and Windows Authentication has been enabled and

    While configuring the BAM in BizTalk Configuration wizard you must have specified a group for 'BAM Portal users' make sure that this user is part of this group.


    Please mark the post answered your question as answer, and mark other helpful posts as helpful, it'll help other users who are visiting your thread for the similar problem, Regards -Rohit Sharma (http://rohitt-sharma.blogspot.com/)

    Friday, May 31, 2013 3:41 AM
    Moderator
  • Hi Venky,

    I had this issue, two things you can do to solve this issue:

    * As suggested by Rohit, ensure in IIS ASP.Net Impersonation and Windows Authentication.

    * Check the security setting of your browser, for Internet Explorer:

    To modify the security settings in Internet Explorer, follow these steps:

    1. Start Internet Explorer.
    2. Click Tools, click Internet Options, and then click the Security tab.
    3. If your computer is connected to the Internet, click Internet, and then click Custom Level.
      If your computer is connected only to a local intranet, click Local Intranet, and then click Custom Level.
    4. In the Security Settings dialog box, make sure that Automatic logon with current username and password is enabled under User Authentication.
    5. Click OK two times.

    If this answers your question please mark it accordingly. If this post is helpful, please vote as helpful.

    Friday, May 31, 2013 9:02 AM
  • Hi, Are you seeing any errors in the windows application log?  This might give you some more info on the root cause.

    In IIS is the app pool also set to 'load user profile = false' and the BAM web apps authentication set to only ASP.NET impersonation and windows authentication enabled?  In the web.config also check the below exist in case the above didn't take affect.

     <identity impersonate="true" />
      <authentication mode="Windows"></authentication> 

      <authorization>
          <allow roles="Everyone" />
          <deny users="*" />
        </authorization>


    GilesB

    Monday, June 3, 2013 2:59 PM
  • Thank You All for your resolutions. It was an issue with .Net Authorization Rules.

    I always had Windows Authentication Enabled (and this is the only one enabled for Authentication).

    I changed .Net Authorization Rules from "Deny All Users" to "Deny Anonymous Users" and it started working.

    Monday, June 3, 2013 6:41 PM