locked
How to force to open links on managed browser - Intune RRS feed

  • Question

  • Hi,

    Can someone please tell me how can I force staff to open links on the managed browser.  Currently, when someone emailed a link to outlook, the user on mobile outlook app click on the link and it is opening on the default browser on the mobile. What I would like to do is when someone clicks on the link on outlook mobile app the website must open in the managed browser.

    how can I do this? much appreciate any help. 

    We are using Intune with O365 E3, Mobility and Security E5

    Thanks. 


    d.n weerasinghe

    Tuesday, October 16, 2018 5:30 AM

Answers

All replies

  • Hello,

    You can create a protection policy for the Outlook app in intune, and set the settings as the following screenshot.

    - Allow app to transfer data to other apps     Policy managed apps

    - Restrict web content transfer with other apps Policy managed browsers

    You can set either one of them, or both.

    More details about the settings above, please refer to the following articles.

    https://docs.microsoft.com/en-us/intune/app-protection-policy-settings-ios

    https://docs.microsoft.com/en-us/intune/app-protection-policy-settings-android

    Best regards,

    Andy Liu


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    • Marked as answer by newnw Tuesday, October 16, 2018 6:36 AM
    Tuesday, October 16, 2018 5:52 AM
  • Thank you very much Andy</g></g>,

    Is it possible to set this policy for a specific user to test it before roll out to the entire organization.</g>

    Thanks.


    d.n <g class="gr_ gr_8 gr-alert gr_spell gr_inline_cards gr_run_anim ContextualSpelling ins-del multiReplace" data-gr-id="8" id="8">weerasinghe</g>



    • Edited by newnw Tuesday, October 16, 2018 9:00 AM
    Tuesday, October 16, 2018 8:59 AM
  • thanks all good I m setting up the policy including a user I <g class="gr_ gr_37 gr-alert gr_spell gr_inline_cards gr_run_anim ContextualSpelling ins-del" data-gr-id="37" id="37">ll</g> get back to you if I required more help.

    Thanks.


    d.n weerasinghe

    Tuesday, October 16, 2018 9:16 AM
  • Hi Andy,

    I have managed to manage to implement the policy, but when a userclickon</g> the link it tries to open the link in the managed browser, but it says "you dont</g> have permission to open the site contact the system administrator" 

    Can you please tell me why is that.

     

    Thanks.


    d.n <g class="gr_ gr_4 gr-alert gr_spell gr_inline_cards gr_run_anim ContextualSpelling ins-del multiReplace" data-gr-id="4" id="4">weerasinghe</g>




    • Edited by newnw Wednesday, October 17, 2018 8:30 AM
    Wednesday, October 17, 2018 8:28 AM
  • Hello,

    How did you configure the policy? Did you enable both of the two settings, or just one?

    If you set "Policy managed apps", please make sure you also configure the protection policy for Managed Browser, and applied it to the Managed Browser.

    Otherwise, you can just set Restrict web content transfer with other apps Policy managed browsers.

    Best regards,

    Andy Liu


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Wednesday, October 17, 2018 8:40 AM
  • Hi Andy 

    as follows 

    What you mean by "please make sure you also configure the protection policy for Managed and applied it to the Managed Browser."


    d.n <g class="gr_ gr_7 gr-alert gr_spell gr_inline_cards gr_run_anim ContextualSpelling ins-del multiReplace" data-gr-id="7" id="7">weerasinghe</g>


    • Edited by newnw Wednesday, October 17, 2018 8:52 AM
    Wednesday, October 17, 2018 8:52 AM
  • Hello,

    Please change the "Allow app to transfer data to other apps  " to "All apps", and sync the policy to the client device. Then, check out if you can open the link in the managed browser.

    In addition, did you also create a new protection policy dedicated for the Managed Browser? Since previously you set the "Allow app to transfer data to other apps  " to "Policy managed apps", you may also need to create a protection policy for the Managed Browser.


    Best regards,

    Andy Liu



    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Wednesday, October 17, 2018 9:01 AM
  •  I have created a separate policy formanaged</g></g> browser as your first suggestion "Allow to transfer data to other apps  " to "Policy managed apps",

    But we have a separate MAM policy which is 



    d.n <g class="gr_ gr_4 gr-alert gr_spell gr_inline_cards gr_run_anim ContextualSpelling ins-del multiReplace" data-gr-id="4" id="4">weerasinghe</g>



    • Edited by newnw Wednesday, October 17, 2018 9:18 AM
    Wednesday, October 17, 2018 9:17 AM
  • Hello,

    It works in my environment, and the followings are what I did.

    1. Create two protection policies, the one is for Outlook, while the other is for Intune Managed Browser.

    2. For the protection policy of Outlook, please see the settings I configured in the following screenshot.

    3. For the protection policy of Intune Managed Browser, please see the settings I configured in the following screenshot. Please note that you must set "Allow app to receive data from other apps" to Policy managed apps.

    Finally, please make sure you sign in to the Intune Managed Browser with the AAD account during first opening it. 

    Best regards,

    Andy Liu


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Thursday, October 18, 2018 7:48 AM