none
validation failed on remote server - Ensure that the remote registry service is running, and have remote administration enabled RRS feed

  • Question

  • I am trying to setup my 2012 cluster and when i try to add my remote server it gives me an error

    Failed to access remote registry on server.

    Ensure that the remote registry service is running, and have remote administration enabled

    I checked the server but remote registry is started already

    any idea?

    also checked under server manager and remote management is enabled
    • Edited by JonDoe321 Monday, March 31, 2014 11:49 PM
    Monday, March 31, 2014 11:45 PM

Answers

  • I found what the issue was. Here is the fix

    http://support.microsoft.com/kb/2686098/en-us

    Is this a well known issue with 2012 servers?

    • Marked as answer by JonDoe321 Thursday, April 3, 2014 5:28 AM
    Thursday, April 3, 2014 5:28 AM

All replies

  • Hi,

    Before you can configure the cluster for the first time or add a server (node) to an existing failover cluster, you need to take the following preparatory steps:

    Install the Failover Clustering feature: You must install the Failover Clustering feature on any server that will become a server (node) in the cluster. For more information, see Install the Failover Clustering Feature.

    • Connect networks and storage: You must connect the networks and storage that the nodes will use. For details, see:

    ◦Prepare Hardware Before Validating a Failover Cluster

    ◦Understanding Requirements for Failover Clusters.

    • Validate the hardware configuration: We strongly recommend that you validate your hardware configuration (servers, network, and storage) before creating a cluster or adding a node to a cluster. To validate, you run a wizard. For more information.

    Please do the steps before you add a node to current cluster then monitor the issue again, if you have done this work already, please offer us the original error message content and the event log.

    The related KB:

    Add a Server to a Failover Cluster

    http://technet.microsoft.com/en-us/library/cc730998.aspx

    Hope this helps.


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time.
    Thanks for helping make community forums a great place.

    Wednesday, April 2, 2014 6:21 AM
    Moderator
  • I am setting up the 2012 cluster and I lan to use FS witeness. so its 2 server in different subnets. Same configuration. Failove cluster is installed. My first step was validate both servers in failover cluster manager but I cannot even add the remote server to validate.

    the error is

    Ensure that the remote registry service is running, and have remote administration enabled

    Both have been verified to be running and enabled

    Wednesday, April 2, 2014 3:30 PM
  • any idea on this? I cannot even validate or add the remote node to validate in cluster manager.

    I tried everything on this link and resettting the wmi repo does not work

    http://blogs.msdn.com/b/clustering/archive/2010/11/23/10095621.aspx

    Wednesday, April 2, 2014 5:55 PM
  • in the app log I saw this when trying to add the remote node for validation:

    The root\mscluster namespace is marked with the RequiresEncryption flag. Access to this namespace might be denied if the script or application does not have the appropriate authentication level. Change the authentication level to Pkt_Privacy and run the script or application again.

    any idea?

    both nodes are 2012 r2 servers

    Wednesday, April 2, 2014 6:09 PM
  • found this but I cannot edit the mof file. 

    what kind of rights do I need?

    http://support.microsoft.com/kb/2590230

    Wednesday, April 2, 2014 6:49 PM
  • It would be helpful if we had a description of your configuration.  It sounds like you might be working across multiple subnets, which is not a default installation.  So more detail would be helpful.

    .:|:.:|:. tim

    Wednesday, April 2, 2014 11:19 PM
  • I have 2 servers,  both are 2012r2 servers one in each site (subnet). No firewall between subnets.

    dns and nslookups are both working fine on both host. brand new setup hosts from dvd iso added failover cluster management enabled remote administration.

    open failover cluster manager and proceeded to add the remote host in and that is the error I got.

    windows firewall is stopped.  

    Thursday, April 3, 2014 2:20 AM
  • I found what the issue was. Here is the fix

    http://support.microsoft.com/kb/2686098/en-us

    Is this a well known issue with 2012 servers?

    • Marked as answer by JonDoe321 Thursday, April 3, 2014 5:28 AM
    Thursday, April 3, 2014 5:28 AM
  • Make sure the Server service is running on the nodes. I am finding that this error happens if it is not.

    Philip Elder Microsoft Cluster MVP Blog: http://blog.mpecsinc.ca

    Thursday, June 26, 2014 3:00 AM
  • Disabling IP v 6 and enabling Client for Microsoft network and File and Printer sharing for Microsoft network worked for me.
    Thursday, March 12, 2015 6:51 AM
  • Thanks for this. I had the same problem and I realised that I have disabled the Client for Microsoft network and File and Printer on the public network card. Once enabling it, cluster validated successfully.
    Tuesday, October 13, 2015 7:14 AM