none
Hyper-V, RDC, UAC and Ctrl Alt End RRS feed

  • Question

  • Greetings,

    Got a new computer running Win8.1 Pro. Still adjusting to Win8.1, but thought I'd give Hyper-V a spin so I can "replace" another system that I need to use for remote access to a client system. Be nice to just have one computer to do all my work. I've been using two systems to get my work done due to VPN conflicts - my primary work system connects me to work using one vendor's VPN, the remote client system uses a different VPN, and when I've worked on getting the VPNs to place nice together I have had little success.

    So I've been using two different, older and lower powered computers to get this done, but now I was thinking I could use Hyper-V to create a VM for accessing my remote client using their VPN without losing my work VPN connection.

    I've got the VM setup and configured, running Win7 Pro (because that's the other license I've got), and the VPN installed on it. I can connect to my work VPN, spin up the VM and connect to the client with their VPN, and RDC to the servers I need to work on when I need to work on them. Works great, right up to the point where the client UAC requires Admin elevation for the MMC (or other management type program). Up pops the box that says Press Ctrl-Alt-End to use my entered credentials, which have admin rights, to pass the creds on to the program.

    I can't figure out how to get Ctrl-Alt-End to the RDC dialog!

    I'm opening Hyper-V manager, then connecting to the VM on my computer. From the Virtual Machine Connection window, log into the client VPN, fire up RDC and connect to the server (logging in to their domain, etc.). I try to load the program on the client server in RDC, the UAC pops up, and - nothing. Hitting Ctrl-Alt-End on my keyboard brings up the lock screen on the Hyper-V connection, it doesn't pass it through to the active RDC session. I've loaded the onscreen keyboard on the remote server, clicked Ctrl Alt End, but that doesn't seem to pass into the UAC.

    I've thought - maybe I should configure my VM for remote access, then I can RDC to the VM, then RDC to the client's server, then... but... would that work?

    Suggestions?

    Thanks,

    Steven

    Monday, November 10, 2014 11:37 PM

All replies

  • Hi Steven,

    Yes, we cannot press CTRL+ALT+DELETE on the keyboard to send that key combination to a virtual machine. You can use the menu command. From the Action menu, click Ctrl+Alt+Delete. Or, you can press CTRL+ALT+END.


    Karen Hu
    TechNet Community Support

    Wednesday, November 12, 2014 9:03 AM
    Moderator
  • Thanks.

    I'm not wanting to press Ctrl-Alt-Del in the virtual session. I'm needing to send Ctrl-Alt-End to a remote session that is running in a Hyper-V VM on my Windows 8.1 computer.

    When I attempt Ctrl-Alt-End with the RDC session active in the VM, the VM is intercepting it instead of passing it into the RDC session. This prevents me from clearing a UAC prompt on the RDC computer. I've tried using the OSK in the RDC session as well.

    So, I appreciate your response, but, it doesn't address the issue I'm having.

    Steven

    Tuesday, November 18, 2014 4:08 PM
  • A workaround may be to use the on screen keyboard on the RDC to use CTRL + ALT + END. Not the best solution, but it may work in this case.

    Jared Hamilton, MCITP Enterprise Administrator


    • Edited by JaredHamilton Tuesday, November 18, 2014 6:16 PM Edited
    • Proposed as answer by JaredHamilton Wednesday, November 19, 2014 2:02 PM
    • Unproposed as answer by sklepzig Tuesday, December 9, 2014 4:29 PM
    Tuesday, November 18, 2014 6:12 PM
  • Thanks for the reply. I did try the OSK in the RDC session, it didn't work. The OSK was working though, as I could click Enter and it would dismiss the UAC dialog.

    I'll try it again, just in case. You're right, not the best solution but if it will work it will be fine.

    Thanks again,
    Steven

    Wednesday, November 19, 2014 9:43 PM
  • Hi.

    I have two further questions:

    Why would a UAC prompt need CTRL-Alt-Del to "be cleared"? What do you mean by "clear"? I never used CTRL-Al-Del for anything UAC-related.

    And how are your keyboard shortcut forwarding settings (that are options in the RD client) set to? To forward the shortcuts to the host might do it.

    Saturday, November 22, 2014 5:43 PM
  • Greetings, Thanks for the reply. I'm not trying to use Ctrl-Alt-Del to clear anything, I'm not trying to use Ctrl-Alt-Del at all. Here's what I'm attempting:

    1. Fire up a VM, log into the VM, run the customer's VPN
    2. RDC to the customer's server
    3. Run the management app on the customer's server that needs elevated privileges
    4. In the RDC session to the customer's server:
    5.  I get a UAC dialog, asking if "I want to complete this action by entering my credentials on the authentic Windows logon screen" or "I don't want to complete this action"
    6. I click the first option ("I want to complete...")
    7. I get a second UAC dialog saying "Press Control+Alt+End" to enter your credentials"
    8. I'm not able to press Control+Alt+End and have it go to the server in the RDC session, the VM is capturing it first; I HAVE tried it using the onscreen keyboard in the RDC session also without success

    (I took screen caps of the dialogs, but, I've pulled an all-nighter working on another issue and couldn't seem to figure out how to insert them here... doh!)

    So - no Ctrl-Alt-Del

    Next time I need to get to the client's server I'll have to check the settings for keyboard shortcut forwarding. Thanks for the suggestion.

    Steven

    • Edited by sklepzig Saturday, November 29, 2014 4:17 PM
    Saturday, November 29, 2014 4:11 PM
  • I am having the exact same problem.  I am not able to hit the control-alt-end.  Has anyone figured this out.  This is the only way to enter my credentials.  

    Bruce

    Tuesday, September 11, 2018 12:30 AM
  • There is key forwarding which works flawless here. Is it turned off?

    Using the hyper-v connection (vmconnect.exe), there is also a button for CTRL-Alt-Del in the upper left corner.

    Monday, September 17, 2018 7:17 AM