none
Hyper-V Hypervisor will not enable RRS feed

  • Question

  • We are trying to enable Hyper-V on a Windows 10 Pro workstation and the install is failing.
    The systeminfo command returns "Yes" on all 4 Hyper-V requirements.

    This are the actions:
    Control Panel > Programs and Features > Turn Windows features on or off > Expand Hyper-V > click Hyper-V Platform > Ok
    The install starts, and after reboot it continues until 92%, ending in the message "We couldn’t complete the updates, Undoing changes, Don’t turn off your computer".
    After reboot we check the "Turn Windows features on or off" again, and the Hyper-V Hypervisor is still not checked.

    When applying the same actions in safe mode (set by msconfig.exe to remain in safe mode after reboot), the Hyper-V Hypervisor can be installed. All Hyper-V check boxes are checked under "Turn Windows features on or off".
    However, when going out of safe mode and back to normal mode, the changes are undone again at reboot, and the Hyper-V Hypervisor is again not checked.

    How to tackle this problem. Is there maybe a log file with an error?

    Regards,
    Bert Kassies
    Wednesday, July 6, 2016 11:58 AM

All replies

  • Hello,

    have you checked if your hardware support Virtualization, Second Level Address Translation (SLAT) and Data Execute Prevention?

    These need to be enabled in the BIOS first.

    Also check if you have latest updates on machine.

    Please, let us know.

    Wednesday, July 6, 2016 2:36 PM
  • Yes, the hardware (Gigabyte GA-H170-HD3 motherboard with Intel Core I7-6700T processor)
    supports vitualization. The command systeminfo.exe lists under Hyper-V Requirements:
    > VM Momitor Mode Extensions: Yes
    > Vitualization Enabled in Firmware: Yes
    > Second Level Address Translation: Yes
    > Data Executionprevention Avallable: Yes

    All Windows updates have been applied.

    Also the fact that the Hyper-V Platform can be enabled in safe mode seems to indicate that
    there is no problem with the hardware.
    Wednesday, July 6, 2016 4:27 PM
  • Is there anyone with an idea how to proceed?
    Thursday, July 7, 2016 4:21 PM
  • Gigabyte...historically, there's been a lot of issues with their BIOS and virtualization.

    Can you update to the latest version of the BIOS?

    Also, give this a try, disable your USB 3 ports in the BIOS and see if this allows you to install the Hyper-V role.

    Thursday, July 7, 2016 5:12 PM
  • The latest version F5 (03/11/2016) of the BIOS is installed. This BIOS doesn't have the option to disable the USB3 ports.

    The fact that the Hyper-V Platform can be enabled in safe mode seems to indicate that there is no problem with the hardware. The system can be rebooted again and again in safe mode without losing the Hyper-V Hypervisor option.

    But as soon as we reboot back in normal mode, the Hyper-V Hypervisor option is being disabled. Which seems to indicate there is a process (which doesn't run in safe mode) that blocks Hyper-V.

    Is that possible? How to find which process it is?

    Friday, July 8, 2016 11:20 AM
  • We have not heard from you in a couple of days. Please post back at your convenience if we can assist further.

    Please mark the reply as an answer if you find it is helpful.

    If you have feedback for TechNet Support, contact tnmff@microsoft.com

    Wednesday, July 27, 2016 9:12 AM
    Moderator