Problems with Windows Vista Firewall & Permissions RRS feed

  • Question

  • Hello everyone. I am working with a Compaq Machine with Windows Vista Home.

    The system got a virus/malware. These have been removed, but the computer is still having problems. To start with, the system would not go on-line becuase services could not be started. This was fixed using the commands:

    net localgroup Administrators /add Local Service

    net localgroup Administrators /add Network Service

    The system now goes online fine, but the firewall will not run. The services for the firewall cannot be started. I am receiving an Access Denied error message. I found the MS article <> and tried the automatic fix which didn't work and then tried to apply the suggestions manually. I was able to add the permissions for the NT Service\MpsSvc account without a problem.

    However, when I try to add the Dhcp account or trustedinstaller account on the next two sets of registry entries, I cannot get the system to find the names of those accounts. I hope that someone out there is able to help me solve this problem and get the system back to 100%.

    By the way, I have also ran the sfc /scannow option.

    Sunday, December 19, 2010 8:48 PM


  • Hi,

    Given the situation, I suggest create a new account to check the result. Your user account may be damaged by virus.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    Friday, December 24, 2010 11:10 AM