none
Key Management Service (KMS) is unavailable. RRS feed

  • Question

  • Hi all,

    We use KMS activate our Windows 7. Nowadays, I hit a issue on a Windows7 client. The problematic client has been activated by KMS but it has been turned off for a long time.

    Today, when I start it, the system shows Widnows is not activated.

    I tried to run "Slmgr.vbs -ato" to activate it with our KMS server, but Windows Script Host shows the following error message.

    0xC004F074 the software licensing service reported that the computer could not be activated. the Key management service is unavailable

    I noticed that the KMS server can be pingable when the client connect to network. 

    How can I make this problematic client activated?

    Thanks for any help.

    Scorprio


    TechNet Software Assurance Managed Newsgroup MCTS: Windows Vista | Exchange Server 2007 MCITP: Enterprise Support Technician | Server & Enterprise Admin

    Monday, July 19, 2010 5:35 AM

Answers

  • Hello Dale,

    Thank you very much for your detailed reply.

    I got to check KB 974998 but it is not apply to our domain environment. The KMS server port 1688 is open and not blocked by Firewall. According to Resulotion3 that you provided, I manually set the KMS server name and port for the client by running "Slmgr /skms KMSSERVERNAME:PORT", and then tried to activate the problematic client with "Slmgr /ato"

    Now the client works well.

    Thanks for your hint.

    Scorprio

     


    TechNet Software Assurance Managed Newsgroup MCTS: Windows Vista | Exchange Server 2007 MCITP: Enterprise Support Technician | Server & Enterprise Admin
    • Marked as answer by Scorprio_Milo Monday, July 19, 2010 12:17 PM
    Monday, July 19, 2010 12:17 PM
  • Additionally, I would like to propose the following solutions as well, some of these resolutions might need to be worked together, and not just one or the other.

     

    Resolution 1:

     

    Check the Windows Firewall on the KMS Host and make sure Port 1688 (or if they changed the port is allowed traffic). Check the Windows Firewall on the KMS Clients to make sure Port 1688 is allowed outbound traffic.

     

    You will need to enable these ports on the Firewall in order to successfully be able to activate Windows to the KMS Host

     

    1.   Open Network and Sharing Center

    2.   Click Windows Firewall

    3.   Click "Allow a program or feature through Windows Firewall"

    4.   Look for the following entry:  Key Management Service.  Port 1688. 

    5.   Enable the exception

     

    You can verify connectivity by using Telnet from the Client machine and running "telnet <fqdn or ip address> 1688" and if it comes up with a blank screen then you are successfully connected to the system.

     

    Resolution 2:

     

    If there are no new events in the Key Management Service Event Log when attempting to activate client machines, you might have a corrupt Key Management Service log.

     

    Clear the log via the Event Viewer - Delete All Events menu item.

     

    Resolution 3:

    On the KMS Server:

    ·       slmgr -upk

    ·       slmgr -cpky

    ·       slmgr -ipk <KMS Host Product Key>

    ·       slmgr -ato

    After doing the above, run slmgr -ato on the client machines.

     

     Resolution 4:

     

    Check to make sure that the customer is not using a widely used port for the KMS Service, in one case the customer was using Port 80 for the KMS communications and it was failing due to a conflict with the HTTP service.

     

    Best Regards

    Dale Qiao
    TechNet Subscriber Support
    in forum. If you have any feedback on our support, please contact tngfb@microsoft.com

     


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    Monday, July 19, 2010 7:41 AM
    Moderator

All replies

  • Hi,

     

    Please visit the following KB:

     

    When trying to active you get 0xC004F074 with description "The Key Management Server (KMS) is unavailable"

     

    Best Regards

    Dale Qiao
    TechNet Subscriber Support
    in forum. If you have any feedback on our support, please contact tngfb@microsoft.com


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    Monday, July 19, 2010 7:35 AM
    Moderator
  • Additionally, I would like to propose the following solutions as well, some of these resolutions might need to be worked together, and not just one or the other.

     

    Resolution 1:

     

    Check the Windows Firewall on the KMS Host and make sure Port 1688 (or if they changed the port is allowed traffic). Check the Windows Firewall on the KMS Clients to make sure Port 1688 is allowed outbound traffic.

     

    You will need to enable these ports on the Firewall in order to successfully be able to activate Windows to the KMS Host

     

    1.   Open Network and Sharing Center

    2.   Click Windows Firewall

    3.   Click "Allow a program or feature through Windows Firewall"

    4.   Look for the following entry:  Key Management Service.  Port 1688. 

    5.   Enable the exception

     

    You can verify connectivity by using Telnet from the Client machine and running "telnet <fqdn or ip address> 1688" and if it comes up with a blank screen then you are successfully connected to the system.

     

    Resolution 2:

     

    If there are no new events in the Key Management Service Event Log when attempting to activate client machines, you might have a corrupt Key Management Service log.

     

    Clear the log via the Event Viewer - Delete All Events menu item.

     

    Resolution 3:

    On the KMS Server:

    ·       slmgr -upk

    ·       slmgr -cpky

    ·       slmgr -ipk <KMS Host Product Key>

    ·       slmgr -ato

    After doing the above, run slmgr -ato on the client machines.

     

     Resolution 4:

     

    Check to make sure that the customer is not using a widely used port for the KMS Service, in one case the customer was using Port 80 for the KMS communications and it was failing due to a conflict with the HTTP service.

     

    Best Regards

    Dale Qiao
    TechNet Subscriber Support
    in forum. If you have any feedback on our support, please contact tngfb@microsoft.com

     


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    Monday, July 19, 2010 7:41 AM
    Moderator
  • Hello Dale,

    Thank you very much for your detailed reply.

    I got to check KB 974998 but it is not apply to our domain environment. The KMS server port 1688 is open and not blocked by Firewall. According to Resulotion3 that you provided, I manually set the KMS server name and port for the client by running "Slmgr /skms KMSSERVERNAME:PORT", and then tried to activate the problematic client with "Slmgr /ato"

    Now the client works well.

    Thanks for your hint.

    Scorprio

     


    TechNet Software Assurance Managed Newsgroup MCTS: Windows Vista | Exchange Server 2007 MCITP: Enterprise Support Technician | Server & Enterprise Admin
    • Marked as answer by Scorprio_Milo Monday, July 19, 2010 12:17 PM
    Monday, July 19, 2010 12:17 PM
  • It works, thank you very much dude!

    • Proposed as answer by Abrahan1 Wednesday, July 27, 2016 4:11 PM
    Wednesday, December 21, 2011 8:56 PM
  • One more move to try, one that finally resolved my problem...

    Try "slmgr /ckms" to clear the name of the KMS computer to use. Once I did that, "slmgr /ato" activated my Windows!

    <object data-extension-version="0.4.0.129" data-install-updates-user-configuration="true" id="__symantecPKIClientMessenger" style="display:none;"></object>
    • Proposed as answer by Coinspinnr Monday, May 22, 2017 6:58 PM
    Thursday, March 10, 2016 4:37 PM
  • One more move to try, one that finally resolved my problem...

    Try "slmgr /ckms" to clear the name of the KMS computer to use. Once I did that, "slmgr /ato" activated my Windows!

    <object data-extension-version="0.4.0.129" data-install-updates-user-configuration="true" id="__symantecPKIClientMessenger" style="display:none;"></object


    "slmgr /ckms"

    This Fixed it for me, thanks a lot :)

    • Edited by Bassel1 Wednesday, February 22, 2017 3:03 PM
    Wednesday, February 22, 2017 3:03 PM
  • machines at one point were activated with  "Slmgr /skms KMSSERVERNAME:PORT"

    Problem started after we changed our KMS server and KMSSERVERNAME   in the above was no longer valid.

    "slmgr /ckms"

    followed by slmgr /ckms

    this worked for me as well. 

    thank you


    • Edited by Coinspinnr Monday, May 22, 2017 7:00 PM
    Monday, May 22, 2017 6:57 PM
  • That fixed it. Thank you.
    Thursday, July 19, 2018 2:45 PM
  • Thanks Steve, I knew there was a better way to fix the KMS problem then pointing it to a FQN server instead of using DNS to find the KMS

    -Richpo

    Thursday, June 6, 2019 9:52 PM