none
Virtual Disk Service and Registry RRS feed

  • Question

  • Virtual Disk Service won't start in Disk Management.

    I have had a long term subscription with Trend Micro and run Microsoft Malicious Software Tool once a month.

    During this episode I changed out hard drives from HDD to SDD. Two of each, internally, and it didn't matter. I also installed all three Windows 10 upgrades. All updates are current. Nothing has changed.


    This was a problem before/during when I did the following, multiple times over several months:

    I went into Computer Mgmt >Services and changed VDS to Automatic and started it.
    I checked every dependency for VDS and verified they were enabled and started.
    I checked all the User permissions.
    Regardless, the DMS could not start the VDS

    Today I found a specific error message in the log "VDS is marked as an Interactive Service; however, the system is configured to not allow Interactive Service."
    I tried to start Interactive Services in the Services tab but it was not allowed.
    With another idea now, back to the Internet where I read there is a Registry value. Considering all I have done/tried this seems a likely possibility since the Registry is at the top of the chain of command.   

    Hive: HKEY_LOCAL_MACHINE
    Path: SYSTEM\CurrentControlSet\Control\Windows

    DWORD: NoInteractiveServices
    Change value "1" to "0"

    I try to avoid mucking around in the Registry. Can anyone verify this Registry value?
    Does anyone know what the syntax would be to do it from the Command Prompt?


    Thank you

    Saturday, May 27, 2017 1:16 AM

All replies