none
Sql Server Express 2014 (x86) Setup fails RRS feed

  • Question

  • Hi, I am trying to install MS Sql Server Express 2014 (x86) but it fails on some computers.

    We already installed it on several computers with success,
    However, on two computers that we recently tried to install, the installation of Microsoft Sql Server Express 2014 (x86) failed with the following Exception :
    "'.', valeur hexadécimale 0x00, est un caractère non valide. Ligne 1, position 50."
    in english, it should be something like :
    "'.', hexadecimal value 0x00, is an invalid character. Line 1, position 50."

    The weird thing is, we already installed it serveral times on different computers without any problems (maybe 20 computers?)

    Those two specific computers are pretty old.
    I'm guessing they had the Vista OS, then they've been upgraded to Windows 7, and recently Windows 10.

    - - - - -

    The first problematic computer was a x86 OS on a x64 processor.
    Our support guy then immediately contacted us (devs) and we though, could it be because we install SQL express via a command line with /passive and some other arguments to make the installation silent and simple for the customer. Then we tried to install it manually -> Same exception. Retry as admin? -> Same exception

    Then of course, we googled everything we could find about this exception, including the 3 links that you provided us (thanks anyway)

    But nothing is installed in the program files, nothing seems to be in "C:/Program Files[ (x86)]/Microsoft SQL [... anything Related]/" either. I mean there's no old version installed.

    We did not check directly in the registry, because I think we shouldn't. Once, one of my colleagues did it on a dev computer here, to troubleshoot her, and she had to reformat due to some nasty errors... It was still about Sql server anyway, but that's another topic :relaxed:

    We checked about MSDE, but it wasnt in the installed programs either

    Tried several things simular too : 
    - https://social.msdn.microsoft.com/Forums/sqlserver/en-US/677a621a-25a8-4f23-9586-53a1cff88f04/hexadecimal-value-0x00-is-an-invalid-character?forum=sqlreportingservices
    - https://social.msdn.microsoft.com/Forums/aspnet/en-US/ad4a46c2-c3ff-45be-a8f3-94a74838147c/issue-installing-sql-server-2014?forum=sqlsetupandupgrade

    - - - - -

    The second problematic computer was a x64 OS.
    We did all the same steps to try to resolve the problem that we did on the other computer, uninstalled some pretty old stuff that could be related in some way to MSDE. But still, no success.
    However, this time I had an idea, since our server here is Sql server 2016, I guessed, why not try to install MS Sql Express 2016, instead of 2014.
    I had no other idea to fix the problem for our customer.
    Then we found the x64 setup, installed it and everything seems to work fine.

    Still, however and sadly, we cannot just upgrade from Sql express 2014 to 2016 on all our customer machines, because the 2016 version is not available in x86 architecture.
    And we must support x86, because we dont want to [Force] some of our customers to reformat/reinstall windows 10 x64

    - - - - -

    So for now, we have no clue why the installation worked on several computers, but those two are giving this vague exception
    Why does the installation of SQL express 2016 worked? Well surely because Microsoft fixed a bug in that setup. However we're still stuck because 2016 ain't available in x86

    We tried using the latest setup with SP3 included, and we still have the same exception.

    My best guess is that the registry still has some references to MSDE, but we didn't uninstall MSDE and we'd prefer to not play in it manually

    The solution will probably be to tell our customers to reformat their computer and install a brand new Windows 10 x64
    and maybe even change their whole computer because they are just too slow and old

    But we have to give it a try...

    Thanks
    - Francis Lussier
    Friday, November 22, 2019 9:03 PM

All replies

  • Here's one of the log files (called summary.txt)

    Overall summary:
      Final result:                  Failed: see details below
      Exit code (Decimal):           -2146232000
      Exit facility code:            19
      Exit error code:               6464
      Exit message:                  '.', valeur hexadécimale 0x00, est un caractère non valide. Ligne 1, position 50.
      Start time:                    2019-11-21 10:44:51
      End time:                      2019-11-21 10:46:08
      Requested action:              Install
      Exception help link:           http://go.microsoft.com/fwlink?LinkId=20476&ProdName=Microsoft+SQL+Server&EvtSrc=setup.rll&EvtID=50000&ProdVer=12.0.2000.8&EvtType=0x77A18E2F%400x972328DC&EvtType=0x77A18E2F%400x972328DC

    Machine Properties:
      Machine name:                  CLIENT-PC
      Machine processor count:       4
      OS version:                    Windows 8
      OS service pack:               
      OS region:                     United States
      OS language:                   français (France)
      OS architecture:               x64
      Process architecture:          32 Bit
      OS clustered:                  No

    Product features discovered:
      Product              Instance             Instance ID                    Feature                                  Language             Edition              Version         Clustered  Configured

    Package properties:
      Description:                   Microsoft SQL Server 2014 
      ProductName:                   SQL Server 2014
      Type:                          RTM
      Version:                       12
      SPLevel:                       0
      Installation location:         C:\SyncExpert\SqlExpress\Setup\x86\setup\
      Installation edition:          Express

    Product Update Status:
      None discovered.

    User Input Settings:
      ACTION:                        Install
      ADDCURRENTUSERASSQLADMIN:      false
      AGTSVCACCOUNT:                 <empty>
      AGTSVCPASSWORD:                <empty>
      AGTSVCSTARTUPTYPE:             Manual
      ASBACKUPDIR:                   Backup
      ASCOLLATION:                   Latin1_General_CI_AS
      ASCONFIGDIR:                   Config
      ASDATADIR:                     Data
      ASLOGDIR:                      Log
      ASPROVIDERMSOLAP:              1
      ASSERVERMODE:                  MULTIDIMENSIONAL
      ASSVCACCOUNT:                  <empty>
      ASSVCPASSWORD:                 <empty>
      ASSVCSTARTUPTYPE:              Automatic
      ASSYSADMINACCOUNTS:            <empty>
      ASTEMPDIR:                     Temp
      BROWSERSVCSTARTUPTYPE:         Disabled
      CLTCTLRNAME:                   <empty>
      CLTRESULTDIR:                  <empty>
      CLTSTARTUPTYPE:                0
      CLTSVCACCOUNT:                 <empty>
      CLTSVCPASSWORD:                <empty>
      CLTWORKINGDIR:                 <empty>
      COMMFABRICENCRYPTION:          0
      COMMFABRICNETWORKLEVEL:        0
      COMMFABRICPORT:                0
      CONFIGURATIONFILE:             
      CTLRSTARTUPTYPE:               0
      CTLRSVCACCOUNT:                <empty>
      CTLRSVCPASSWORD:               <empty>
      CTLRUSERS:                     <empty>
      ENABLERANU:                    false
      ENU:                           true
      ERRORREPORTING:                false
      FEATURES:                      
      FILESTREAMLEVEL:               0
      FILESTREAMSHARENAME:           <empty>
      FTSVCACCOUNT:                  <empty>
      FTSVCPASSWORD:                 <empty>
      HELP:                          false
      IACCEPTSQLSERVERLICENSETERMS:  true
      INDICATEPROGRESS:              false
      INSTALLSHAREDDIR:              C:\Program Files\Microsoft SQL Server\
      INSTALLSHAREDWOWDIR:           C:\Program Files (x86)\Microsoft SQL Server\
      INSTALLSQLDATADIR:             <empty>
      INSTANCEDIR:                   C:\Program Files (x86)\Microsoft SQL Server\
      INSTANCEID:                    <empty>
      INSTANCENAME:                  <empty>
      ISSVCACCOUNT:                  NT AUTHORITY\Network Service
      ISSVCPASSWORD:                 <empty>
      ISSVCSTARTUPTYPE:              Automatic
      MATRIXCMBRICKCOMMPORT:         0
      MATRIXCMSERVERNAME:            <empty>
      MATRIXNAME:                    <empty>
      NPENABLED:                     0
      PID:                           *****
      QUIET:                         false
      QUIETSIMPLE:                   false
      ROLE:                          AllFeatures_WithDefaults
      RSINSTALLMODE:                 DefaultNativeMode
      RSSHPINSTALLMODE:              DefaultSharePointMode
      RSSVCACCOUNT:                  <empty>
      RSSVCPASSWORD:                 <empty>
      RSSVCSTARTUPTYPE:              Automatic
      SAPWD:                         <empty>
      SECURITYMODE:                  <empty>
      SQLBACKUPDIR:                  <empty>
      SQLCOLLATION:                  SQL_Latin1_General_CP1_CI_AS
      SQLSVCACCOUNT:                 <empty>
      SQLSVCPASSWORD:                <empty>
      SQLSVCSTARTUPTYPE:             Automatic
      SQLSYSADMINACCOUNTS:           <empty>
      SQLTEMPDBDIR:                  <empty>
      SQLTEMPDBLOGDIR:               <empty>
      SQLUSERDBDIR:                  <empty>
      SQLUSERDBLOGDIR:               <empty>
      SQMREPORTING:                  false
      TCPENABLED:                    0
      UIMODE:                        AutoAdvance
      UpdateEnabled:                 true
      UpdateSource:                  MU
      USEMICROSOFTUPDATE:            false
      X86:                           true

      Configuration file:            C:\Program Files (x86)\Microsoft SQL Server\120\Setup Bootstrap\Log\20191121_104440\ConfigurationFile.ini

    Rules with failures:

    Global rules:

    Scenario specific rules:

    Rules report file:               The rule result report file is not available.

    Exception summary:
    The following is an exception stack listing the exceptions in outermost to innermost order
    Inner exceptions are being indented

    Exception type: System.Xml.XmlException
        Message: 
            '.', valeur hexadécimale 0x00, est un caractère non valide. Ligne 1, position 50.
        HResult : 0x80131940
        Data: 
          HelpLink.EvtType = 0x77A18E2F@0x972328DC
          DisableWatson = true
        Stack: 
            at System.Xml.XmlTextReaderImpl.Throw(Exception e)
            at System.Xml.XmlTextReaderImpl.Throw(String res, String[] args)
            at System.Xml.XmlTextReaderImpl.Throw(Int32 pos, String res, String[] args)
            at System.Xml.XmlTextReaderImpl.ThrowInvalidChar(Int32 pos, Char invChar)
            at System.Xml.XmlTextReaderImpl.ParseNumericCharRefInline(Int32 startPos, Boolean expand, BufferBuilder internalSubsetBuilder, Int32& charCount, EntityType& entityType)
            at System.Xml.XmlTextReaderImpl.ParseNumericCharRef(Boolean expand, BufferBuilder internalSubsetBuilder, EntityType& entityType)
            at System.Xml.XmlTextReaderImpl.HandleEntityReference(Boolean isInAttributeValue, EntityExpandType expandType, Int32& charRefEndPos)
            at System.Xml.XmlTextReaderImpl.ParseAttributeValueSlow(Int32 curPos, Char quoteChar, NodeData attr)
            at System.Xml.XmlTextReaderImpl.ParseAttributes()
            at System.Xml.XmlTextReaderImpl.ParseElement()
            at System.Xml.XmlTextReaderImpl.ParseElementContent()
            at System.Xml.XmlTextReaderImpl.Read()
            at System.Xml.XmlLoader.LoadNode(Boolean skipOverWhitespace)
            at System.Xml.XmlLoader.LoadDocSequence(XmlDocument parentDoc)
            at System.Xml.XmlLoader.Load(XmlDocument doc, XmlReader reader, Boolean preserveWhitespace)
            at System.Xml.XmlDocument.Load(XmlReader reader)
            at Microsoft.SqlServer.Chainer.Infrastructure.DataStoreService.LoadXmlDocument(String xml, XmlSchema schema, String namespacePrefix, String namespaceUri, String rootPath)
    Friday, November 22, 2019 9:14 PM
  • Hi Francis,

    Based on my search, here are some suggestions:

    1Make sure that there are no extra space in Disk name. This may cause setup to fail with "invalid Character" error.

    2You mentioned that you didn't uninstall the MSDE,please uninstall the MSDE completely.

    3Remove previous failed SQL  installtion completely.

     For information about uninstalling MSDE,please refer to this blog.

    For information about uninstalling SQL Server,please click this article.

    Hope this could help you.

    Best regards,

    Cris


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.


    Monday, November 25, 2019 10:04 AM
  • Hi Cris,

    We tried several things again and still no luck

    - The hard drive name doesn't contains a space. It had an underscore and we removed it.

    - "You mentioned that you didn't uninstall the MSDE,please uninstall the MSDE completely."
      The thing is, MSDE is not installed. There's just one directory in the registry that is left.
      Its this one : 
    "\HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSDE\"
      Last week, we were trying to delete/rename it and we weren't able. We though maybe something still has a reference on it, but it's not the case.
      I guess that MSDE was partially uninstalled years ago, and this little bit was left over due to a silent error.

      Today i've found out that we weren't able to delete it because we didn't have the permissions  Now I removed this entry, but the installation of MsSql 2014 express still fails with the same error

    - And also, none of the Ms Sql Server versions are installed

    - I checked both of your links too but we already tried them

    - As my manager suggested, I also create a new Windows Session (a user account for login), but as I was suspecting, same error :P


    So, in conclusion
    We can't find any trace of an installation of MSDE anywhere (the registry | programs list | C:/Program Files[ (x86)]/
    Ms Sql Server is not installed either.


    Friday, November 29, 2019 7:44 PM
  • Did I mention that we tried installing Sql Server Express 2012 (x86)

    You've probably guessed that we had the same error
    Friday, November 29, 2019 7:47 PM