locked
MS SQL Server Management Studio 2014 - Backspace, Enter Key, Arrow Keys Have Stopped Working in Text Editor. RRS feed

  • Question

  • I've had MS SQL Server 2014 Express installed and working on my Windows 7 machine for quite a few years now. 

    I am now seeing that the backspace, enter, and arrow keys no longer work when writing a query in the Management Studio text editor. 

    It cannot be my keyboard as these keys work fine in all other Windows applications, including Office and Visual Studio. 

    Any/all assistance gratefully accepted. 

    Here is the Help...About information:

    Microsoft SQL Server Management Studio                12.0.2000.8
    Microsoft Analysis Services Client Tools                    12.0.2000.8
    Microsoft Data Access Components (MDAC)             6.1.7601.17514
    Microsoft MSXML                                                     3.0 6.0
    Microsoft Internet Explorer                                      9.11.9600.18893
    Microsoft .NET Framework                                      4.0.30319.42000
    Operating System                                                   6.1.7601

    Sunday, April 22, 2018 8:30 PM

All replies

  • Hi WebFOCUSGuy,

    Please have a try following options:

    1. locate the default.vsk, and rename Default.vsk and current.vsk/User.vsk, e.g. Default_old.vsk.

    2. Reinstall SSMS.

    Check if this issue persist.

    Regards.

    Pirlo Zhang


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Tuesday, April 24, 2018 6:13 AM
  • Thank you for offering to assist Pirlo. 

    I cannot find any file called default.vsk. 

    Could you tell me what folder it would be in?

    I have reinstalled SSMS and the problem persists. 

    Thursday, April 26, 2018 2:30 AM
  • Hi WebFOCUSGuy,

    For example, for SSMS 2016, the default path is: C:\Users\xxx\AppData\Roaming\Microsoft\SQL Server Management Studio\13.0.

    Regards,

    Pirlo Zhang 


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Thursday, April 26, 2018 2:34 AM
  • I looked at that location (default path), and could not find default.vsk. 

    I also have Visual Studio Community 2013 on the same Windows 7 machine.  I opened VS and noticed that:

     1. I could connect to MS SQL Server 2014 Express.

     2. Once connect it looked like I had the same options/features that I had with SSMS.  For sure, I was able to create a query, and then within the editor, use the backspace, arrow, and enter keys. 

    So, two (2) questions:

      1. Is having VS 2013 incompatible with SSMS?  Meaning when I installed VS did I break SSMS?

      2. Is VS 2013 the preferred/more popular way to interact with SQL Server now?

    If VS 2013 isn't incompatible with SSMS, and SSMS is the preferred way to interact with SQL Server, then I would still love some assistance with fixing the SSMS editor.  :-)

    Thanks all for your consideration.

    Sunday, May 6, 2018 12:39 AM
  • I suspect you have the solution given on Experts Exchange to rename the following two files found under your user AppData folder:

    default.vsk
    current.vsk

    I found another root cause and solution. This probably won't apply to you as you did a full re-install and still had the issue, but it affected me on SSMS2016.

    Steps to re-create are:

    Go into a database, then diagrams folder and start a new diagram. Add a couple tables to the diagram but do not dismiss the dialogue box. Instead, click on the diagram. The dialogue box moves to the background. Now close your diagram without saving and go to the query editor (eg. right-click the DB and choose new query).

    Note that the DB name is not displayed in the query editor toolbar and your keyboard keys are disabled as you describe. If you minimise your application windows one by one you'll see that dialogue box from the diagram editor is still there but you can no longer interact with it. On shutting down SSMS you'll be prompted that a process is blocking some functionality and often it's a modal dialogue box - which it is. 

    Restart anyway and the issue resolves. Thought it worth noting for others finding this thread.

    Monday, September 10, 2018 11:26 PM
  • I had the same issue. A restart of the SQL Management Studio has solved the problem.
    Tuesday, June 18, 2019 12:53 PM
  • The way I solved my issue which had dogged me for weeks was to open SSMS, click Tools ->Options ->Keyboard, and clicked Reset.

    

    • Proposed as answer by Kronos1234 Saturday, July 11, 2020 5:35 AM
    Tuesday, December 24, 2019 8:45 PM
  • Natongm solution worked for me, thanks!
    Saturday, July 11, 2020 5:36 AM