none
Client Hyper-V "Cannot Connect to Virtual Machine" RRS feed

  • General discussion

  • I'm trying to run Client Hyper-V on my Windows 8 Pro machine. I was able to successfully install the service, and can create virtual machines and hard disks on my local system. I can even start them, and see boot activity via the preview window in the MMC. I cannot, however, connect to any machines from the local system: when I do, it hangs on "Connecting to <machinename>" for 30 seconds before it pops up with the dialog:

    "Cannot connect to virtual machine. Try to connect again. If the problem persists, contact your system administrator."

    Obviously, because this is Client Hyper-V, I am the system administrator, so I scour the Internet to solve my problem. I see solutions related to firewalls, administrative permissions, a few other things, and nothing has worked. I also tried creating a virtual machine on a Windows 8 Enterprise system (which can connect to it just fine) and export it for the Pro machine to import, and I still cannot connect to it, whether the VM is registered in place or copied to the host.

    Some other notes:

    - None of these systems has an OS installed - two locally created ones either had no boot or booted off a Linux LiveCD, and the exported one attempted to do a PXE boot. Thus, I cannot attempt to link via Remote Desktop since the computers have no names

    - Hyper-V has some other quirks on my system as well: in order to stop a virtual machine, I have to end the vmwp process - which restarts the machine - and then stop it from the console within a few seconds. Otherwise, it hangs in the "Stopping" state. In addition, none of the buttons on the side of the MMC work, but that occurs over all of MMC.

    - No events show up in the Event log when a connection fails

    - I am an admin on the Pro machine and have permissions to connect to machines and operate the management view

    Monday, February 11, 2013 7:56 PM

All replies

  • Have you tried uninstalling the Hyper-V feature and then reinstalling it?  It sound like something has gotten corrupted on your install.


    Bob Comer - Microsoft MVP Virtual Machine

    Monday, February 11, 2013 8:07 PM
  • I just did, by unchecking Hyper-V in "Add or Remove Windows Components", restarting, and rechecking Hyper-V, and I still got the same error. If it is truly corruption, I suspect that it has to do with the Windows 8 install, so how can I install the component directly off the Windows 8 disk?

    Monday, February 11, 2013 8:35 PM
  • So, I need a clarification (considering new releases).

    Is this Windows 8 Professional (on some random hardware) - or Surface Pro?

    (When I first read this Surface Pro popped into my head, so I thought to ask)


    Brian Ehlert
    http://ITProctology.blogspot.com
    Learn. Apply. Repeat.
    Disclaimer: Attempting change is of your own free will.

    Monday, February 11, 2013 8:41 PM
  • I don't think there is any other way to install the Hyper-V feature.  You're probably going to have to do a reset on the OS, but that will wipe out any normal windows based apps and you'll have to reinstall them.

    Maybe someone else will post with a manual fix.  It could be just a pure permissions problem, and if someone knows exactly what to fix...

     


    Bob Comer - Microsoft MVP Virtual Machine

    Monday, February 11, 2013 8:43 PM
  • So, I need a clarification (considering new releases).

    Is this Windows 8 Professional (on some random hardware) - or Surface Pro?

    (When I first read this Surface Pro popped into my head, so I thought to ask)

    No, this is Windows 8 Pro on a Dell Inspiron 15 (N5050, to be exact).

    Monday, February 11, 2013 8:46 PM
  • You mean that if I were to place the Windows 8 install disk in the drive when I install the feature, my computer won't autodetect it and pull the files from there? And nothing shows up in the event log, so I don't know if it's a permissions problem.
    Monday, February 11, 2013 8:48 PM
  • Correct, it wont pull it from the DVD.


    Bob Comer - Microsoft MVP Virtual Machine

    Monday, February 11, 2013 8:53 PM
  • I had a similar issue where I couldn't use the Virtual Machine Connection tool, with the same error message about needing to contact my system administrator - Bing led me here so hoping this will help the next seacher.  I am admin on my laptop, but I decided to check in Computer Management / Local Users and Groups / Groups there's a new group for Hyper-V Administrators.  I put in my login account, but had to reboot before I could connect to my VM through the Connection tool.

    Steve

    Tuesday, March 5, 2013 3:10 PM
  • did you find any fix for this. I am having the same issue. and I have tried almost everything I could find on various blogs.

    I would appreciate any help in this

    Thanks

    Monday, June 24, 2013 4:16 AM
  • Having the same issue with Server 2012 Data centre  edition

    Sunday, June 30, 2013 6:44 AM
  • Same problem...anyone.  Firewall 2179 is good, group access is good, nothing in event logs.
    Saturday, August 3, 2013 4:01 AM
  • how, exactly are you trying to connect to the vm?

    are you a member if the hyper-v administrators local security group?


    Brian Ehlert
    http://ITProctology.blogspot.com
    Learn. Apply. Repeat.
    Disclaimer: Attempting change is of your own free will.

    Saturday, August 3, 2013 4:15 AM
  • Yes, member of the hyper-v admin group.  Trying to connect from the hyper-v console to the vm (no os installed).  I can see it working in the bottom left window, but when I try and connect to the machine, no go.

    Tried saving the machine and restarting it - nothing.

    Tried uninstall/reinstall of hyper-v.  No joy.

    Tried creating a second VM to see if it was an issue with just that one machine.  Same issue, can't connect.

    There is nothing in the event logs reflecting any of this, either, which is doubly frustrating.

    Saturday, August 3, 2013 5:05 AM
  • Forgot to mention, this is in Win 8 Pro.
    Saturday, August 3, 2013 5:06 AM
  • Is your machine domain joined or in a workgroup?

    -Taylor


    -Taylor Brown
    -Program Manager, Hyper-V
    -http://blogs.msdn.com/taylorb

    Monday, August 5, 2013 3:57 PM
  • The machine is not on a domain.  Thanks for having a look :)
    Monday, August 5, 2013 4:33 PM
  • When you checked the event log’s what sources did you check?  Can you verify there are not any relevant error/warning events under the following sources:

    Applications and Services Logs

                    Microsoft

    Windows

    Hyper-V-VMMS

                                                                    Admin

                                                                    Operational

    Hyper-V-Worker

                    Admin

                    Operational

    If not we should enable some additional logging if possible to see what is going on.

    1. Shutdown any running VM’s
    2. Close all of the Hyper-V UI
    3. Stop the VMMS service (net stop vmms)
    4. Enable Analytic logging for the VMMS and Worker Process (see below)
    5. Enable UI Tracing for Hyper-V Manager and VMConnect (see below)
    6. Start the VMMS service (net start vmms)
    7. Open Hyper-V Manger
    8. Restart the VM
    9. Attempt to connect (try two or three times)
    10. Gather Logs (see below)
    11. Disable Tracing (see below)

    Enabling Analytic Logging For the VMMS and Worker Process

    1. Open the Event Viewer
    2. From the menu bar select View -> Show Analytic and Debug Logs
    3. Navigate to the Hyper-V logs and Enable the Analytic Channels

    Applications and Services Logs

                    Microsoft

    Windows

    Hyper-V-VMMS

                                                                    Analytic

                                                                                    Right Click -> Enable (yes if a pop up asks about enabling the logs)

    Hyper-V-Worker

                                                                    Analytic

                                                                                    Right Click -> Enable (yes if a pop up asks about enabling the logs)

    Enabling UI Tracing

    1. Create a new text file named “VMClientTrace.config” in the "%appdata%\Microsoft\Windows\Hyper-V\Client\1.0\” folder

    Copy the following XML text into that file:
    <?xml version="1.0" encoding="utf-8"?>
    <configuration>
        <Microsoft.Virtualization.Client.TraceConfigurationOptions>
            <setting name="TraceTagFormat" type="System.Int32">
                <value>3</value>
            </setting>
            <setting name="BrowserTraceLevel" type="System.Int32">
                <value>71</value>
            </setting>
            <setting name="VMConnectTraceLevel" type="System.Int32">
                <value>71</value>
            </setting>

        </Microsoft.Virtualization.Client.TraceConfigurationOptions>
    </configuration>

    1. Save the file.

    Gathering The Logs

    1. The Analytic logs will be in the analytic folder (you often have to refresh or select another source then analytic again to see them)
    2. The UI trace Logs will be in %temp% (sometime back one directory i.e. %temp% = “C:\Users\taylorb\AppData\Local\Temp\2” for me but the logs are at “C:\Users\taylorb\AppData\Local\Temp”

    Disabling Tracing

    1. To disable Analytic Tracing just right click on the analytic sources and select disable (same as enabling)
    2. To disable UI tracing just delete the “%appdata%\Microsoft\Windows\Hyper-V\Client\1.0\VMClientTrace.config” file.

    -Taylor Brown
    -Program Manager, Hyper-V
    -http://blogs.msdn.com/taylorb

    Thursday, August 8, 2013 6:08 PM
  • Excellent suggestions....I'll get on this as soon as I can hack out some time and report back - many thanks.
    Saturday, August 10, 2013 12:51 PM
  • Have anyone fix this error? I'm find all in internet, but no one have a right solution about it?
    Tuesday, August 13, 2013 12:48 PM
  • Hello,

    I found the solution for my case.

    I uninstall Team Viewer than restart, everything is ok now.

    I have windows 8 pro, I got installed Team Viewer before I installed Hyper-V.

    Tuesday, August 13, 2013 6:39 PM
  • I am facing the exact same problem. Client Hyper-V on Windows 8.  However it is domain joined.

    Here is the contents of "VMConnect_Trace_20130905113207.log"

    Tracing Hyper-V Client version: 6.2.0.0. Rough build date (virtman file written): 07/26/2012 10:20:33

    2013-09-05 11:32:07.805 [06] WARNING VirtMan WmiAssociation:GetRelatedObjects() The WMI object 'Msvm_RdvComponentSettingData' + could not be mapped to VirtMan type so ignore it.
    2013-09-05 11:32:07.743 [01] USER_ACTION_INITIATED VmConnect RdpViewerControl:ConnectCallback() Connecting with server full name: Mullick1.*********.net to RDP port 2179
    2013-09-05 11:33:34.044 [01] WARNING VmConnect RdpViewerControl:PrintDisconnectionErrorDebugMessage() The server disconnected the client with the text ''. Disconnect code: '204', Extended disconnect code: 'exDiscReasonNoInfo'.
    2013-09-05 11:33:34.044 [01] WARNING VmConnect RdpViewerControl:PrintDisconnectionErrorDebugMessage() Disconnect error message: Cannot connect to the virtual machine. Try to connect again. If the problem persists, contact your system administrator.
    Thursday, September 5, 2013 6:21 PM
  • I had to enable the traffic for vmms.exe (virtual machine management service) on my firewall (mcafee)
    Monday, October 21, 2013 8:25 PM
  • Thanks for the post - this worked perfectly for me. Great piece of troubleshooting.

    Monday, June 9, 2014 5:31 PM
  • ditto...McAfee SaaS Endpoint Security Firewall component blocking communications....

    I had thought initially I had a corrupt component in Hyper-V, so tried removing, rebooting and re-adding the Hyper-V windows component.

    My platform is an HP Elite 8300 SFF PC factory installed with Windows 8 Pro and later updated to 8.1 Pro, so I initially suspected a bad upgrade, but alas, I disabled the McAfee firewall component and it worked as expected.


    Richard

    Thursday, June 25, 2015 2:17 PM
  • Hello,

    I found the solution for my case.

    I uninstall Team Viewer than restart, everything is ok now.

    I have windows 8 pro, I got installed Team Viewer before I installed Hyper-V.


    aha, kahaivinh, your solution applies to my problem! I fixed the problem by unstall TV and restarting. Thank you very much!
    Tuesday, October 20, 2015 3:36 PM
  • IF you are using MCAFEE MCSHEILD go to services and disable it then reboot your server ..that solved my problem temporarily ..still looking for a permanent fix. 
    Monday, December 7, 2015 9:27 AM
  • This is what worked for me, as well. The moment I hit "OK" after adding the exception to MacAfee, I was able to launch!
    Friday, April 29, 2016 7:21 PM
  • Im using McAfee End Point Security and I had to allow VMMS.EXE local port 2179 IN for the connection for Hyper-V VM's to work on the McAfee Firewall Rules.  I turned on "Enable Adaptive mode" under "Tuning Options" and let it automatically create the rule for me.  Thanks for the tip DroutChosorou.

    

    Friday, April 29, 2016 11:37 PM
  • Excellent same issue by me. and resolved by this. 
    Thursday, June 1, 2017 4:26 PM
  • Had the same problem with win 10 turning off my avast antivirus has temporarily fixed the problem
    Tuesday, October 10, 2017 1:50 PM
  • For me on Windows 10 it was the Firewall of Avast Anti Virus because the virtual Network was a private on.
    Sunday, October 22, 2017 6:37 PM
  • Same issue on Server 2012 R2

    Can connect to VMs on one cluster member, but not on the other one.

    had to RDP to the host in question, log off & the connection to VMs was suddenly allowed

    What gives?

    Seb


    • Edited by scerazy Friday, November 10, 2017 10:40 AM
    Friday, November 10, 2017 10:36 AM
  • The same error happened to me in Windows Server 2012 R2. I deactivated the McAfee Endpoint Protection Firewall and the problem has been resolved.
    Sunday, November 19, 2017 3:09 PM
  • I found that my anti-virus, specifically Avast, was the issue. Disabled all shields momentarily, and it immediately started working. So, check that your AV or firewall isn't blocking the connection. 
    Monday, January 15, 2018 7:12 AM
  • I recently ran into this issue after windows 10 did an update.  Somehow in the update, Remote Desktop access was disabled. Funny thing is, I had to reset it Remote Desktop page in the Settings applet.  The computer properties was showing that Remote desktop was enabled, however, the Remote Desktop page in the Settings applet said it was disabled.

    FYI: I tried everything on this thread before stumbling onto the Remote Desktop Settings page.  I even played with the windows defender firewall settings along with uninstall-reinstall.

    So, its worth checking this SETTING FIRST before doing all those other gyrations.  

    As I said, no clue how this setting got disabled.  I figure its an added "feature" when auto updating.

    Regards,
    MaxV ( MSFT )

    Sunday, August 12, 2018 5:46 PM
  • I was having the exact same issue.  And what's worse, I had a connection on one and then lost it.

    Turns out that the issue was my enterprise MacAfee.  As soon as I uninstalled that, it started working perfectly again.

    Friday, October 26, 2018 5:51 PM
  • Thanks a lot.

    This solution works for my case. 

    Monday, November 12, 2018 10:29 AM