locked
MBAM Clients not reporting to Administration and Monitoring Server RRS feed

  • Question

  • I have setup an MBAM test environment. We are currently using the 3 machine MBAM topology. We also setup during MBAM installation encrypted communication between our two servers using SSL certificates. During installation there were no errors. The MBAM GPOs have been created and linked in our test OU. I have confirmed through running gpresult that client machines have received the group policy. Yet, I am receiving an error in the logs that the workstations are not communicating with the endpoint.

      

    From the screen shot the machine is trying to check-in every 90 minutes as outlined in the GPOs but the machine is not communicating. I have also confirmed that the service endpoints in the GPOs are correct. Can someone assist with this issue?

    ----Update-----

    After researching for hours I see in the client logs that I have an incorrect endpoint. I receive the following message:

    Hardware exemption check failed.

    Error code:

    0x803d0020

    Details:

    The endpoint address URL is invalid.

     

     

    Are the following endpoints correct in the GPO? 

    Key Recovery Service: http://<NameofAdministrationandMonitoringServer>:<Port#>/MBAMRecoveryAndHardwareService/CoreService.svc 

    Status Reporting Service: http://<NameofAdministrationandMonitoringServer>:<Port#>/MBAMComplianceStatusService/StatusReportingService.svc  

    I have the FQDN of my web server in place of <NameofAdministrationandMonitoringServer>

    When I input the URL in my web browser they check out and are verfied.

    • Edited by crich11988 Thursday, August 25, 2011 8:14 PM More Information
    Thursday, August 25, 2011 5:54 PM

Answers

  • Reboot the client after installing MBAM.

    As a resolution ensure that the Administration and monitoring server is able to talk to the Recovery and Hardware database on the database server.  This can be found by going into the Event Viewer/Windows Log/Application and searching for an ASP.net warning on the Administration and Monitoring server.

    Once this error is resolved by opening up port 1434 for UDP on the database server, the clients should now be able to communicate.

    • Marked as answer by crich11988 Friday, August 26, 2011 1:46 PM
    Friday, August 26, 2011 1:46 PM

All replies

  • Reboot the client after installing MBAM.

    As a resolution ensure that the Administration and monitoring server is able to talk to the Recovery and Hardware database on the database server.  This can be found by going into the Event Viewer/Windows Log/Application and searching for an ASP.net warning on the Administration and Monitoring server.

    Once this error is resolved by opening up port 1434 for UDP on the database server, the clients should now be able to communicate.

    • Marked as answer by crich11988 Friday, August 26, 2011 1:46 PM
    Friday, August 26, 2011 1:46 PM
  • Glad you solve the issue and share it with us. It can help other community members who encounter the similar issue.

    Thanks for the efforts here.

    Regards,

    Miya


    This posting is provided "AS IS" with no warranties, and confers no rights. | Please remember to click "Mark as Answer" on the post that helps you, and to click "Unmark as Answer" if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Monday, August 29, 2011 7:03 AM
  • Hi,

    I am also getting the same problem.

    I have turned off the firewall on both MBAM server and the Win7 client machine, but still i am getting the error :


    Error code:

    0x803d0020

    Details:

    The endpoint address URL is invalid.


    Thanks Chandan



    Tuesday, November 6, 2012 3:59 PM
  • Hi,

    I am also getting the same problem.

    I have turned off the firewall on both MBAM server and the Win7 client machine, but still i am getting the error :


    Error code:

    0x803d0020

    Details:

    The endpoint address URL is invalid.


    Thanks Chandan



    Hello Chandan 

    Do you find a solution for your problem? Because I have the same problem with my client "The endpoint address URL is invalid"

    Can you help me?

    Thanks & Cheers Raebaan

    Sunday, September 29, 2013 4:24 PM
  • Hi Raebaan,

    In my case, the URLs that i have entered in the GPO was containing a space at the end, and that was causing the problem  and the error was coming - 'The endpoint address URL is invalid'. This usually happens when you do a copy paste.

    Removing the space at the end solved my problem.

    So you can check that too.


    Thanks Chandan

    Monday, September 30, 2013 7:15 PM