none
Adminstrator...not me? RRS feed

  • Question

  • I'm running Vista Home Premium on my home computer. There are several points where I can't access 'administrator options' (for instance to turn on/turn off Windows Defender. I've searched for answers but all I find is constant references to Group Policy, System Administrator etc. The problem is, this isn't a networked computer, there is only one administrator/user (myself) so why would I be locked out? As I understand it Home Premium doesn't even have the 'Group Policy' feature, and yet in Windows Firewall it won't let me turn WF on or off, because of "Group Policy settings".

    There are also other issues, such as not having permissions for certain things (i.e. "you need permission to perform this action") even though my user account have "full control" permissions, along with everything else.

    I'm lost here. How/why would I, the only administrator or user, not be allowed to change setting, and not have permission for things?
    Saturday, December 13, 2008 9:42 AM

Answers

  •  

    Hi DJG INC, you can first check the following link on how to turn off Windows Defender:

     

    http://windowshelp.microsoft.com/Windows/en-us/help/31d797aa-091d-4d67-a556-dbfaf21bf0dc1033.mspx

     

    If you are not allowed to change setting, please let me know the detailed error message.

     

    For file permission, you can try the following steps to take ownership and then try to delete it again:

     

    1. Please navigate to the target file/folder.

    2. Right-click on the file/folder and choose Properties.

    3. Click the "Security" tab and see if your current user is listed in the "Group or user names" list. If not, please click the Add button, type the name of your current user in the "Enter the object names to select " box, then click "OK" to add this group.

    4. Select the user from the list and then check the "Allow" checkbox next to "Full Control".

    5. Click the Advanced button and click the "Owner" tab. Then, press "Edit" button.

    6. Select current user from the list and check the "Replace owner on subcontainers and objects" checkbox.

    7. Click "OK" to save changes and wait for Windows Vista to transfer the ownership of all the objects on the partition.

    8. Click OK again to save changes and exit the Properties window.

     

    Hope this helps!


    Sean Zhu - MSFT
    • Marked as answer by Andy Song Friday, December 26, 2008 8:16 AM
    Tuesday, December 16, 2008 8:00 AM
    Moderator

All replies

  • Hi,

    Take a look at Vista's new security model on my blog here, it will make it clearer for you.

    After you acknowledge the prompt, can you do the file operation you were attempting?


    Monday, December 15, 2008 12:03 PM
  • No, I can't perform the operations at all.
    I haven't been able to turn Windows Defender or Windows Firewall on or off for some time now.
    And invariably after the 'permission' prompt it won't let me, say, delete a file - although usually after some time/restart it will, without a permission prompt.
    Monday, December 15, 2008 2:47 PM
  •  

    Hi DJG INC, you can first check the following link on how to turn off Windows Defender:

     

    http://windowshelp.microsoft.com/Windows/en-us/help/31d797aa-091d-4d67-a556-dbfaf21bf0dc1033.mspx

     

    If you are not allowed to change setting, please let me know the detailed error message.

     

    For file permission, you can try the following steps to take ownership and then try to delete it again:

     

    1. Please navigate to the target file/folder.

    2. Right-click on the file/folder and choose Properties.

    3. Click the "Security" tab and see if your current user is listed in the "Group or user names" list. If not, please click the Add button, type the name of your current user in the "Enter the object names to select " box, then click "OK" to add this group.

    4. Select the user from the list and then check the "Allow" checkbox next to "Full Control".

    5. Click the Advanced button and click the "Owner" tab. Then, press "Edit" button.

    6. Select current user from the list and check the "Replace owner on subcontainers and objects" checkbox.

    7. Click "OK" to save changes and wait for Windows Vista to transfer the ownership of all the objects on the partition.

    8. Click OK again to save changes and exit the Properties window.

     

    Hope this helps!


    Sean Zhu - MSFT
    • Marked as answer by Andy Song Friday, December 26, 2008 8:16 AM
    Tuesday, December 16, 2008 8:00 AM
    Moderator