none
No networking, system hang etc ("SOLVED") RRS feed

  • General discussion

  • Disconnect your printer and disable files and printer network sharing. http://social.technet.microsoft.com/Forums/en/w7itpronetworking/thread/004a20c4-2ded-4ed6-875f-3805a8c977b1

    ---------------------------------------------------------------------------------------------------------------------------------------

    I can't access network when: installing SPTD from daemon tools (last version), then restarting and no network; installing Microsoft .NET services for Azure (2008), 2009 July CTP solves this issue; installing Daemon Tools AFTER installing lastest SPTD from official install file (ie, the manufacturer).

    I've got two network adapters: a Nvidia nforce integrated (nforce 4 driver) and a d-link pci card (chipset is RTL8139).

    When i restart after doing such steps happens this: if the networking cable is connected to Nvidia's adapter i get on the IPv4 and IPv6 "Not connected" message (on the connection status tab), although i've got IPv4 manually configured.

    If the cable is, instead, connected to the d-link card i simply get Limited connectivity message with no way to configure it (no matter what i do input, it won't work).

    Now, if i try to uninstall one of those cards my system just hangs (i still get the monitor output but processor hangs and the only way to solve it is restarting); note that it also hangs in safe mode.

    The only way i've found to solve this is to restore system to a point before i installed that.

    I'm running Ultimate x64, i've reinstalled Seven Ultimate x64 5 times and the problem persists.

    Also note that i've installed all this software on a seperate computer (HP 6720s) without having any problem, so it MUST be a driver problem.

    EDIT: (Probably found the problem) This happens only when i install a driver (yes, .NET services is a driver!).

    When i do restore system i always get the following (no matter what i've installed, this is always there):

    On the "Programs and controllers that will be erased (literal translation, i've got the spanish version)":

    Hewlett-Packard Company (SCSIAdapter) 02/05/2009 6.12.4.54 (I've got an HP DeskJet 710c) (In spanish)
    Microsoft (Net) 06/11/2009 1.0.0.15 (I didn't uninstall .NET July 2008 CTP, instead i left it to the installation program of the 2009 July CTP package)
    Microsoft remote desktop services (Printer) 06/21/2006 6.1.7600.16385 (in spanish)

    All those 3 are type "Controller"

    And on the "Programs and controllers that will be restored":

    %MSFT% (Net) 06/11/2009
    Hewlett-Packard Company (SCSIAdapter) 02/05/2009 6.12.4.64 (in english)
    Microsoft Remote Desktop Services (Printer) 06/21/2009 6.1.7600.16385 (in english)

    As you can see, when you restore the system you restore what you delete in the same restoration, it's an endless chain.

    Solutions? Well i'm right now doing a system restore from a point i've created when i did not have internet (i had the issue).

    If this works we'll know at least how to solve it, but it'll be painfully to do this every time you want to install a driver (or update one, like SPTD).

    Another way to solve it might be to disable Microsoft Update before installing a driver (because all those updates are from Microsoft update, i remember that the one for HP DeskJet 710c was called "Microsoft update for HP DeskJet 710c").

    Well, i shouldn't say that windows 7 will be released on 22nd October; that's less than two months!.

    EDIT2: Yes! It worked!

    A temporary solution is that, when you've got the problem, you have to create a system restore point and then restore the system to that point (without rebooting, it isn't needed).

    After system restore's reboot, you'll have internet working again.

    EDIT3:

    What's curious is that if you update the SPTD driver from the Daemon Tools' installation program you get the error, but if you do from the own SPTD program not (at least if you click on the update button, i've not tried on uninstalling and then installing). Maybe the daemon tools' setup uninstalls and then installs the driver?

    I'm almost sure it's a driver problem because only if you install the SCSI driver (run the program the first time) you'll get the error on restart.

    Same if you install the IDE driver (create an IDE disk).

    If i get now daemon to install i'll try out installing without Microsoft Update enabled (all this time i did with it, i've just read a post of another problem on this forums saying it might be the cause of a similar problem).

    EDIT4: Confirmed, i installed my Agfa e25 Snapscan driver and on reboot i had the problem again.

    EDIT5: Also note that if you do system restore when you actually don't have the problem, at reboot you'll have it.

    EDIT6: If you want to get Daemon Tools disks installed without having the error you have to do the following:

    - Install SPTD, reboot and make whatever is necessary to get internet back on.

    - Install Daemon Tools and add (without rebooting) as many disks as you'll ever want.

    - Create a system restore point (WITHOUT HAVING REBOOTED FROM STEP 2!).

    - Reboot (you won't have internet now).

    - System restore to the point you created.

    Note that if you add more disks after this you'll need (imperative) to create the system restore point BEFORE rebooting or you won't be able to get internet back on (creating a system restore point when not having internet and restoring to that point won't work).

    Hope this helps someone, as for me i won't probably look to any responses as far as i don't get this problem anymore (i've installed all the disks i want and the drivers i need).

    Also note, I've tried disabling Microsoft Update and/or Remote Assistance and the problem persists; also reinstalling .NET services 2009, disabling Remote desktop printer service and reinstalling (uninstalling and then installing) HP DeskJet 710c won't solve it.

    Good luck to those having this problem.

    EDIT:

    Going around with it you can disable "Client for Internet Printing" (or somewhat like this) inside the "Documents and printing services" tick. It should make your windows boot/shutdown faster, remove some problems with this (on internet, it doesn't solve it completely but it does somewhat like it), cpu usage on games and what's most important it solves the hang issue.

    EDIT:

    Found a solution that notably helps the user to solve it. Just uninstall or install a windows characteristic that requires a reboot, on reboot you'll have the problem solved for that session. Then you can "install or uninstall a windows characteristic that requires a reboot" on the same session you've the error solved, then at the next one (reboot) you'll have it.

    I'm going to do some sort of script/program to automate this as i've got no support from any microsoft members/technicians.


    EDIT:

    Just run this batch file when you start windows (remeber to elevate it, as DISM requires!).

    NOTE: You can replace Tablet pc with another that requires restart like NFS client. Just use dism /online /Get-Features >> name.txt (it's too large to get all in the screen) to know the command-line feature name. (Copy&Paste, In Compatiblity tab on the propierties menu select "Run as administrator", Make it run on boot and enjoy your Windows 7 - Fucked up system)

    @echo off
    :: This method takes more time and you could make a more complicated script that looks if it's enabled or not, but for me it's fine as long as it works
    start /w dism /Online /Enable-Feature /FeatureName:TabletPCOC /NoRestart
    start /w dism /Online /Disable-Feature /FeatureName:TabletPCOC /NoRestart
    @echo off

    If you want to make the windows invisible just use some sort of program out there to do so (google it!).

    If you don't want to allow the program to run every time in elevated mode, disable uac or make it run with the UserPrivilege (or somewhat like it).

    If you want another sort of solution ask microsoft, for me this works and i've got no problem with it, and if you don't like it do it yourself.

    Note: If you don't mind on progress just delete "start /w".

    Tuesday, August 25, 2009 12:18 AM

All replies

  • Hi,

     

    Thank you for your sharing. I think this will be a good reference for the users who meet the similar issues.

     

    In the future, if you experience any issues regarding our products, you are welcome to post a new thread to our forum. It is always our pleasure to be of assistance.

     

    Thanks again for your efforts. Have a great day!


    Nicholas Li - MSFT
    Thursday, August 27, 2009 9:37 AM
    Moderator