excludeprofiledirs syntax for folders with spaces RRS feed

  • Question

  • I have a dilemma. This setting in the registry is working fine unless the folder path has one or more spaces in it. Below is what I have in there now. When the user logs off, the Ditto folder gets ignored, but the Foxit updater folder is copied back to the server.  I've looked through articles all over the place, but haven't seen anything that shows how to deal with spaces. Any ideas?

    AppData\Local;AppData\LocalLow;$Recycle.Bin;AppData\Roaming\Foxit Software\Addon\Foxit Reader\Install\updater;AppData\Roaming\Ditto

    Monday, September 30, 2019 10:03 PM

All replies

  • Hi,

    Try to use powershell command to create a registry key contains space, like: 

    New-Item -Path "HKCU:\Software\My Software\My Version" -Name "Sample key" -Force

    For your reference:

    Note: This is a third-party link and we do not have any guarantees on this website. This is just for your convenience. And Microsoft does not make any guarantees about the content.

    Best regards,


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact

    Tuesday, October 1, 2019 3:42 AM
  • Thanks for the reply. I don't have any trouble getting spaces in there. The problem is Windows isn't recognizing a path that contains a space. I'm hoping it just needs an escape character or something like that.
    Tuesday, October 1, 2019 5:40 AM
  • Can you believe it? I totally thought I was onto something when I remembered how long filenames or names with spaces were handled way back when (8.3 filename), so I tried the following:

    I tried adjusting this:

    AppData\Roaming\Foxit Software\Install\updater

    To this:


    And this:


    But no such luck! Windows Registry isn't even able to follow its own rules? What more can I try?

    • Edited by Sm1th Tuesday, October 1, 2019 11:32 PM typo
    Tuesday, October 1, 2019 11:27 PM
  • *BUMP* I'm hoping someone will read my last post. I don't want to give up yet!
    Tuesday, October 8, 2019 8:45 PM