none
SSL error 61 RRS feed

  • Question

  • I am now using windows 7 and firefox. I have always worked from home on Citrix. Now I receive an error "SSL error 61" You have not chosen to trust the certificate. I have not found anything on the web that can help me.
    Thanks~
    Tuesday, December 1, 2009 12:48 AM

Answers

  • Hi,

    This error can occur because one of the following causes.

    1.    The required CA Root certificate is not installed on the client device.
    2.    If your server certificate was issued by an intermediate certification authority, the Win32 ICA Client version 6.20.985 will not connect using SSL.
    3.    Error code occurs after upgrading to ICA Client 7.0
    4.    Ensure DNS is properly configured between the client machine and the FQDN of the Citrix Secure Gateway Server.

    For more information, please refer to the suggestions provided on the following site.

    http://support.citrix.com/article/CTX711855

    If all the suggestions above do not work, I suggest contacting Citrix Support with the issue as well.

    Good Luck!

     

     


    Judy :)
    Tuesday, December 1, 2009 5:13 AM

All replies

  • Hi,

    This error can occur because one of the following causes.

    1.    The required CA Root certificate is not installed on the client device.
    2.    If your server certificate was issued by an intermediate certification authority, the Win32 ICA Client version 6.20.985 will not connect using SSL.
    3.    Error code occurs after upgrading to ICA Client 7.0
    4.    Ensure DNS is properly configured between the client machine and the FQDN of the Citrix Secure Gateway Server.

    For more information, please refer to the suggestions provided on the following site.

    http://support.citrix.com/article/CTX711855

    If all the suggestions above do not work, I suggest contacting Citrix Support with the issue as well.

    Good Luck!

     

     


    Judy :)
    Tuesday, December 1, 2009 5:13 AM
  • I am also very curious what system and browser you used previously. Please let us know.
    Judy :)
    Tuesday, December 1, 2009 9:37 AM
  • I am now using windows 7 and firefox. I have always worked from home on Citrix. Now I receive an error "SSL error 61" You have not chosen to trust the certificate. I have not found anything on the web that can help me.
    Thanks~

    Have you discussed this with the Sys Admin people?  Have you contacted Citrix about this?
    Tuesday, December 1, 2009 11:58 AM
  • Hi, I've just had this problem after installing windows 7 professional on a netbook (runs sweet as a nut btw.) and firefox 3.6

    To resolve the issue I exported the root ca certificate from firefox (Tools, Options, Advanced tab, then the Encryption sub tab and then click 'View Certificates', find the root ca you are having issues with and export it using the default settings)

    I then right clicked on the newly exported .crt file, left clicked 'Install Certificate' and manually choose the certificate store (choosing Trusted Root Certification Authorities).

    Once the certificate was installed in windows I was then able to click on my published app on citrix remote access web page and it connected straight away, I didn't have to log out of the web server or restart firefox.

    Even though firefox validates my web page and is ok with the certificate when the ICA client starts up it tries to verify against the windows certificate store not the firefox store and the windows cert store mustn't have had this particular root ca.

    If your certificate isn't been identified by firefox as trusted you will need to download the root ca file from your certificate provider and install it in the firefox certificate manager and the windows Trusted Root Certification Authorities store.

    HTH Burundi.
    • Edited by Burundi Saturday, February 13, 2010 8:43 PM Bad formatting
    • Proposed as answer by REALLYAnnoying Wednesday, March 9, 2011 9:15 AM
    Saturday, February 13, 2010 8:39 PM
  • It has worked for me!

    Thank you very much.

    Huh, finally i get a solution.

    BR Krasi

    Tuesday, February 23, 2010 5:38 PM
  • This worked perfectly and it saved me to drive to the office for an emergency

    Thanks a lot

    Tuesday, April 6, 2010 11:05 PM
  • Burundi,

    Thanks for the solution. It works for me.

    Chester

     

    Friday, June 25, 2010 3:53 AM
  • Thank you Burundi.  It worked great.  Saved the weekend.
    Saturday, June 26, 2010 5:30 PM
  • This solved my problem beautifully :)
    Friday, May 26, 2017 10:21 AM