none
SSL Certificate add failed, Error: 31 RRS feed

  • Question

  • I'm tring to add SSL certificate  with this command

    netsh http add sslcert 127.0.0.1:8035 certhash=hash appid={guid fo appid}

    This command returns an error

    SSL Certificate add failed, Error: 31 A device attached to the system is not functioning

    Also I've tried to add certificate for WebSite directly from IIS Manager and got another error

    Error during operation - A device attached to the system is not functioning (Exception from HRESULT: 0x8007001F)

    Thursday, November 22, 2018 8:39 AM

Answers

  • Hi,

    Thanks for posting in Microsoft TechNet Forum.

    According to your description, it is recommended that you try to update cryptography service provider to a newer version.

    Reboot and check if it works.

    About error:A device attached to the system is not functioning, the link makes a simple description. You can refer to it.

    Hope it will help you.

    Best regards,

    Hurry


    Please remember to mark the reply as an answer if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com





    Thursday, November 22, 2018 7:24 PM

All replies

  • Hi,

    Thanks for posting in Microsoft TechNet Forum.

    According to your description, it is recommended that you try to update cryptography service provider to a newer version.

    Reboot and check if it works.

    About error:A device attached to the system is not functioning, the link makes a simple description. You can refer to it.

    Hope it will help you.

    Best regards,

    Hurry


    Please remember to mark the reply as an answer if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com





    Thursday, November 22, 2018 7:24 PM
  • Hi,

    Is there anything else I can do to help you on this issue?

    Please feel free to contact me if you have any questions.

    Best regards,

    Hurry


    Please remember to mark the reply as an answer if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com


    Saturday, November 24, 2018 12:08 PM
  • Thanks Hurry!

    Upgrading to newer version of cryptography service provider solved my issue. 

    Once again thanks a lot!

    Monday, November 26, 2018 10:43 AM
  • Hi,

    I'm glad to hear that your question was successfully resolved.

    Wish you a happy life.

    Best regards,

    Hurry


    Please remember to mark the reply as an answer if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Monday, November 26, 2018 1:55 PM