locked
SharePoint Online Video Player URL update grey out under behavior tag RRS feed

  • Question

  • Hi all:

       I was trying to insert a video player web part into a SPO page, but after I did that, I found I cannot specify the URL and preview image URL for the video player, in other words, items under behavior tag cannot be updated at all. Does someone know how to solve this?

       And I'm trying to update the code of the web part in designer, but it tells me I cannot edit the code, which I have not met before, is it SPO configuration or something else?

       Thanks,

       Tony


    • Edited by Tony_Leo Tuesday, December 24, 2013 4:02 AM
    Tuesday, December 24, 2013 3:00 AM

Answers

  • Hi,                                                             

    To change the video URL and the preview image URL, please take a look at the following steps: Click "Edit page"->"Edit Web Part" of the video web part, then there will be a "MEDIA" tab appears in the ribbon, we can easily find the two button "Change Media" and "Change Image".

    To modify the code of the video web part, please ensure that you have the sufficient permission to edit the page. We can use SharePoint Designer to open the current site page in "Advanced Mode", then the whole site page will be editable and you can modify the code as you want.

    Best regards

    Patrick Liang
    TechNet Community Support

    • Marked as answer by Tony_Leo Tuesday, December 31, 2013 7:22 AM
    Wednesday, December 25, 2013 11:14 AM

All replies

  • do you want embed a video or video player?

    for embed videos, i dont think you can customize it.

    http://community.office365.com/en-us/blogs/office_365_community_blog/archive/2011/09/26/hosting-and-embedding-video-with-sharepoint-online.aspx


    Please remember to mark your question as answered &Vote helpful,if this solves/helps your problem. ****************************************************************************************** Thanks -WS MCITP(SharePoint 2010, 2013) Blog: http://wscheema.com/blog

    Tuesday, December 24, 2013 3:58 AM
  • Thanks Sarwar for your reply, actually the video player I'm trying to use is the OOB web part of SharePoint, and I did as the instruction steps, but the issue's still there.



    • Edited by Tony_Leo Tuesday, December 24, 2013 4:38 AM
    Tuesday, December 24, 2013 4:37 AM
  • Hi,                                                             

    To change the video URL and the preview image URL, please take a look at the following steps: Click "Edit page"->"Edit Web Part" of the video web part, then there will be a "MEDIA" tab appears in the ribbon, we can easily find the two button "Change Media" and "Change Image".

    To modify the code of the video web part, please ensure that you have the sufficient permission to edit the page. We can use SharePoint Designer to open the current site page in "Advanced Mode", then the whole site page will be editable and you can modify the code as you want.

    Best regards

    Patrick Liang
    TechNet Community Support

    • Marked as answer by Tony_Leo Tuesday, December 31, 2013 7:22 AM
    Wednesday, December 25, 2013 11:14 AM
  • Hi Liang, Thanks for the reply.

    Strange thing is I did not find the "media" tab in the ribbon like you said, there are only browse, page insert and web part when the page gets into editing mode.(Sorry I don't get permission to insert a image here) And Only interface I got to update the URL are, unfortunately like I said, all grey out..

    BTW, the site template is publishing site and all settings are default, any possibility site/site collection features should be activated?

    Thanks and Regards.

    Tony

    Thursday, December 26, 2013 9:48 AM
  • Hi,

    Do you mean that when you click "Edit Web Part" of the Media web part, there is no "MEDIA" tab on the ribbon?

    I tried to reproduce like this: Create a Publishing site with the "Publishing Site" template, click "Edit Page"->"INSERT", in the "Media and Content" category, select the "Media Web Part" and "Add".
    Then the Media Web Part will be added into the page. When I click the little triangle of the Media Web Part and click "Edit Web Part", the "MEDIA" tab will show up in the ribbon.

    What's more, I haven't modified the default site features settings after the site created.

    What if you create a new page and do the test again, will the issue still occurs?

    Best regards


    Patrick Liang
    TechNet Community Support

    Friday, December 27, 2013 3:33 AM
  • Hi,

    After I create a new page, the issue is gone, don't know y..

    Anyway it's solved somehow, thank you very much Liang.

    Tony

    • Marked as answer by Miles Li - MSFT Tuesday, December 31, 2013 7:20 AM
    • Unmarked as answer by Tony_Leo Tuesday, December 31, 2013 7:22 AM
    Friday, December 27, 2013 4:14 AM
  • Hi,

    Glad to hear that you solve the issue, thanks for your sharing.

    Best regards


    Patrick Liang
    TechNet Community Support

    Friday, December 27, 2013 4:37 AM
  • Hi Patrick

    I know this is an old thread, but the Media tab is missing for me on my SharePoint 2013 publishing site created with the publishing template. All settings are default.

    I tried to create a new page but it did not solve the problem for me. Could it be something in the Master Page? If I switch to the default Master Page, the problem still exists.

    Thank you.

    Yoshi

    Monday, March 24, 2014 2:12 AM
  • I too am having this problem. An entire page of video web parts are no longer functional (no play button). If I try to edit the web part to change the media, the Media tab is not visible. 

    If I create a new sub site and add a new media web part, same behavior. All of the sudden, media web parts are not working.

    Note: The media source is stored on an external server. However, when adding new media web parts, the Media tab is unavailable from the start, so I don't think the problem is the source location.

    These are all publishing sites on "on premise" servers.

    Please advise,

    Ana

    • Proposed as answer by Joshi_Ashish Friday, May 15, 2015 1:24 PM
    • Unproposed as answer by Joshi_Ashish Friday, May 15, 2015 1:24 PM
    Wednesday, April 23, 2014 4:24 AM
  • Did anyone get the solution? I am also facing the same issue with O365 publishing site. After searching for the solution for a long time, it did not get fixed.
    Friday, May 15, 2015 1:27 PM
  • Yes, this is definitely still a problem. Using Internet Explorer (version 11), after first adding a Media web part, sometimes the Media tab will be available and both the Media and the Image can be set. But, after setting them and publishing the page, there is no joy in accessing the Media tab again to change this.

    However, I was able to then make changes using a different browser. I used Firefox.

    Tuesday, July 7, 2015 2:03 PM
  • I replied too soon. I am also having the same problem using Firefox now.
    Tuesday, July 7, 2015 5:18 PM
  • Hello everyone,

    I too am experiencing this issue.  It appears to have been in an update from early in 2015.  I have a user who added videos at the end of January and now recently went in to make changes.  Upon trying to edit the page and web part, the areas were locked... preventing any edits. 

    I see comments about using a WIKI page, which is not a bad idea... but do we have other options?

    Thanks for your help,


    Thursday, July 9, 2015 2:49 PM
  • Hi Tony,

    I had the exact same problem and someone told me I had to click ON the video itself to get the Media tab to appear on the ribbon. So opening the web part properties is not enough. You have to go back and click on the video....the black box area... just click it...and the MEDIA TAB APPEARS IN THE RIBBON.

    Another SharePoint quirk. Ugh.

    Rachel

    Friday, January 8, 2016 5:50 PM
  • doesn't work for me - no media tab anymore.

    I know how to use this, but it isn't working anymore.


    Mark

    Wednesday, June 15, 2016 2:25 PM
  • Had to use Firefox to get the Media tab to show but I guess that is just our company browser settings
    Thursday, March 1, 2018 9:28 AM
  • Google Chrome is also suitable
    Friday, July 31, 2020 9:52 AM